[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ASUS PC-DL DualXeon won't work with GENERIC.MP



Hi list!

Advised by Nick (thanks a lot!) i'm going to expose all the stuff regarding the box. So,
Dual Xeon 2,4GHz 1GB RAM, 2x160Gb SATA (no RAID, of course)...
Installing as usual, booting just fine:

OpenBSD 3.6 (GENERIC) #59: Fri Sep 17 12:32:57 MDT 2004 
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC 
cpu0: Intel(R) Xeon(TM) CPU 2.40GHz ("GenuineIntel" 686-class) 2.41 GHz 
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID 
real mem = 1073287168 (1048132K) 
avail mem = 972746752 (949948K) 
using 4278 buffers containing 53768192 bytes (52508K) of memory 
mainbus0 (root) 
bios0 at mainbus0: AT/286+(e4) BIOS, date 10/09/03, BIOS32 rev. 0 @ 0xfba90 
apm0 at bios0: Power Management spec V1.2 
apm0: AC on, battery charge unknown 
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf54 
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde60/224 (12 entries) 
pcibios0: PCI Exclusive IRQs: 5 9 11 12 15 
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82801EB/ER LPC" rev 0x00) 
pcibios0: PCI bus #3 is the last bus 
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x1000 
cpu0 at mainbus0 
pci0 at mainbus0 bus 0: configuration mode 1 (no bios) 
pchb0 at pci0 dev 0 function 0 "Intel 82875P Host" rev 0x02 
ppb0 at pci0 dev 1 function 0 "Intel 82875P AGP" rev 0x02 
pci1 at ppb0 bus 1 
ppb1 at pci0 dev 3 function 0 "Intel 82875P PCI-CSA" rev 0x02 
pci2 at ppb1 bus 2 
em0 at pci2 dev 1 function 0 "Intel PRO/1000CT (82547EI)" rev 0x00: irq 15, address: 00:0e:a6:5f:77:5b 
ppb2 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0xc2 
pci3 at ppb2 bus 3 
vga1 at pci3 dev 9 function 0 "S3 ViRGE DX/GX" rev 0x01 
wsdisplay0 at vga1: console (80x25, vt100 emulation) 
wsdisplay0: screen 1-5 added (80x25, vt100 emulation) 
rl0 at pci3 dev 10 function 0 "Realtek 8139" rev 0x10: irq 11 address 00:c0:26:8c:5d:f2 
rlphy0 at rl0 phy 0: RTL internal phy 
ichpcib0 at pci0 dev 31 function 0 "Intel 82801EB/ER LPC" rev 0x02 
pciide0 at pci0 dev 31 function 1 "Intel 82801EB/ER IDE" rev 0x02: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility 
atapiscsi0 at pciide0 channel 0 drive 0 
scsibus0 at atapiscsi0: 2 targets 
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CR-48XGTE, 1.0K> SCSI0 5/cdrom removable 
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 
pciide0: channel 1 ignored (disabled) 
pciide1 at pci0 dev 31 function 2 "Intel 82801EB SATA" rev 0x02: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI 
pciide1: using irq 15 for native-PCI interrupt 
wd0 at pciide1 channel 0 drive 0: <SAMSUNG SP1614C> 
wd0: 16-sector PIO, LBA48, 152627MB, 312581808 sectors 
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5 
wd1 at pciide1 channel 1 drive 0: <SAMSUNG SP1614C> 
wd1: 16-sector PIO, LBA48, 152627MB, 312581808 sectors 
wd1(pciide1:1:0): using PIO mode 4, Ultra-DMA mode 5 
"Intel 82801EB/ER SMBus" rev 0x02 at pci0 dev 31 function 3 not configured 
isa0 at ichpcib0 
isadma0 at isa0 
pckbc0 at isa0 port 0x60/5 
pckbd0 at pckbc0 (kbd slot) 
pckbc0: using irq 1 for kbd slot 
wskbd0 at pckbd0: console keyboard, using wsdisplay0 
pcppi0 at isa0 port 0x61 
midi0 at pcppi0: <PC speaker> 
sysbeep0 at pcppi0 
lpt0 at isa0 port 0x378/4 irq 7 
lm0 at isa0 port 0x290/8: W83627THF 
npx0 at isa0 port 0xf0/16: using exception 16 
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo 
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo 
biomask f765 netmask ff65 ttymask ffe7 
pctr: user-level cycle counter enabled 
dkcsum: wd0 matched BIOS disk 80 
dkcsum: wd1 matched BIOS disk 81 
root on wd0a 
rootdev=0x0 rrootdev=0x300 rawdev=0x302

and the box is happy, with one CPU ("half" of CPU?  ;-)...
Being not agree with box's happiness, at next reboot i've tried to boot the supplied bsd.mp, it hangs with dmesg below:

>> OpenBSD/i386 BOOT 2.06 
boot> boot bsd.mp 
booting hd0a:bsd.mp: 4967004+864308 [52+232928]=0x5fc3c4 
entry point at 0x100120 
[ using 444724 bytes of bsd ELF symbol table ] 
Copyright (c) 1982, 1986, 1989, 1991, 1993 
The Regents of the University of California. All rights reserved. 
Copyright (c) 1995-2004 OpenBSD. All rights reserved. http://www.OpenBSD.org

OpenBSD 3.6 (GENERIC.MP) #173: Fri Sep 17 12:52:31 MDT 2004 
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC.MP 
cpu0: Intel(R) Xeon(TM) CPU 2.40GHz ("GenuineIntel" 686-class) 2.41 GHz 
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID 
real mem = 1072209920 (1047080K) 
avail mem = 971702272 (948928K) 
using 4278 buffers containing 53714944 bytes (52456K) of memory 
mainbus0 (root) 
bios0 at mainbus0: AT/286+(10) BIOS, date 09/14/04, BIOS32 rev. 0 @ 0xfb7c0 
apm0 at bios0: Power Management spec V1.2 
apm0: AC on, battery charge unknown 
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf54 
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde60/224 (12 entries) 
pcibios0: PCI Exclusive IRQs: 10 11 12 15 
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82801EB/ER LPC" rev 0x00) 
pcibios0: PCI bus #3 is the last bus 
bios0: ROM list: 0xc0000/0x8000 
mainbus0: Intel MP Specification (Version 1.4) (OEM00000 PROD00000000) 
cpu0 at mainbus0: apid 0 (boot processor) 
cpu0: apic clock running at 133 MHz 
cpu1 at mainbus0: apid 6 (application processor) 
cpu1: Intel(R) Xeon(TM) CPU 2.40GHz ("GenuineIntel" 686-class) 2.41 GHz 
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CNXT-ID 
mainbus0: bus 0 is type PCI 
mainbus0: bus 1 is type PCI 
mainbus0: bus 2 is type PCI 
mainbus0: bus 3 is type PCI 
mainbus0: bus 4 is type ISA 
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 20, 24 pins 
ioapic0: misconfigured as apic 0, remapped to apic 4 
pci0 at mainbus0 bus 0: configuration mode 1 (no bios) 
pchb0 at pci0 dev 0 function 0 "Intel 82875P Host" rev 0x02 
ppb0 at pci0 dev 1 function 0 "Intel 82875P AGP" rev 0x02 
pci1 at ppb0 bus 1 
ppb1 at pci0 dev 3 function 0 "Intel 82875P PCI-CSA" rev 0x02 
pci2 at ppb1 bus 2 
em0 at pci2 dev 1 function 0 "Intel PRO/1000CT (82547EI)" rev 0x00: apic 4 int 18 (irq 15), address: 00:0e:a6:5f:77:5b 
ppb2 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0xc2 
pci3 at ppb2 bus 3 
vga1 at pci3 dev 9 function 0 "S3 ViRGE DX/GX" rev 0x01 
wsdisplay0 at vga1: console (80x25, vt100 emulation) 
wsdisplay0: screen 1-5 added (80x25, vt100 emulation) 
rl0 at pci3 dev 10 function 0 "Realtek 8139" rev 0x10: apic 4 int 22 (irq 11) address 00:c0:26:8c:5d:f2 
rlphy0 at rl0 phy 0: RTL internal phy 
ichpcib0 at pci0 dev 31 function 0 "Intel 82801EB/ER LPC" rev 0x02 
pciide0 at pci0 dev 31 function 1 "Intel 82801EB/ER IDE" rev 0x02: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility 
atapiscsi0 at pciide0 channel 0 drive 0 
scsibus0 at atapiscsi0: 2 targets 
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CR-48XGTE, 1.0K> SCSI0 5/cdrom removable 
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 
pciide0: channel 1 ignored (disabled) 
pciide1 at pci0 dev 31 function 2 "Intel 82801EB SATA" rev 0x02: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI 
pciide1: using apic 4 int 16 (irq 15) for native-PCI interrupt 
wd0 at pciide1 channel 0 drive 0: <SAMSUNG SP1614C> 
wd0: 16-sector PIO, LBA48, 152627MB, 312581808 sectors 
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5 
wd1 at pciide1 channel 1 drive 0: <SAMSUNG SP1614C> 
wd1: 16-sector PIO, LBA48, 152627MB, 312581808 sectors 
wd1(pciide1:1:0): using PIO mode 4, Ultra-DMA mode 5 
"Intel 82801EB/ER SMBus" rev 0x02 at pci0 dev 31 function 3 not configured 
isa0 at ichpcib0 
isadma0 at isa0 
pckbc0 at isa0 port 0x60/5 
pckbd0 at pckbc0 (kbd slot) 
pckbc0: using irq 1 for kbd slot 
wskbd0 at pckbd0: console keyboard, using wsdisplay0 
pcppi0 at isa0 port 0x61 
midi0 at pcppi0: <PC speaker> 
sysbeep0 at pcppi0 
lm0 at isa0 port 0x290/8: W83627THF 
npx0 at isa0 port 0xf0/16: using exception 16 
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo 
pccom0: console 
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo 
biomask 0 netmask 0 ttymask 0 
pctr: user-level cycle counter enabled 
wd0(pciide1:0:0): timeout 
type: ata 
c_bcount: 512 
c_skip: 0 
wd0(pciide1:0:0): timeout 
type: ata 
c_bcount: 512 
c_skip: 0 

at this point the box is completely locked.
Tried these maneuvres:
- rewriting a fresher BIOS
- less RAM, 512MB (there are 2x512MB DDR's in the box)
- disabling ALL unneeded hardware
still no result.
Even with disabling apm @ ukc> gives the same result:



>> OpenBSD/i386 BOOT 2.06 
boot> boot bsd.mp -c 
booting hd0a:bsd.mp: 4967004+864308 [52+232928+211371]=0x5fc3c4 
entry point at 0x100120 
[ using 444724 bytes of bsd ELF symbol table ] 
Copyright (c) 1982, 1986, 1989, 1991, 1993 
The Regents of the University of California. All rights reserved. 
Copyright (c) 1995-2004 OpenBSD. All rights reserved. http://www.OpenBSD.org 

OpenBSD 3.6 (GENERIC.MP) #173: Fri Sep 17 12:52:31 MDT 2004 
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC.MP 
cpu0: Intel(R) Xeon(TM) CPU 2.40GHz ("GenuineIntel" 686-class) 2.41 GHz 
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID 
real mem = 1072209920 (1047080K) 
avail mem = 971702272 (948928K) 
using 4278 buffers containing 53714944 bytes (52456K) of memory 
User Kernel Config 
UKC> find apm 
239 apm0 at bios0 flags 0x0 
UKC> disable apm0 
239 apm0 disabled 
UKC> exit 
Continuing... 
mainbus0 (root) 
bios0 at mainbus0: AT/286+(10) BIOS, date 09/14/04, BIOS32 rev. 0 @ 0xfb7c0 
apm at bios0 function 0x15 not configured 
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf54 
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde60/224 (12 entries) 
pcibios0: PCI Exclusive IRQs: 10 11 12 15 
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82801EB/ER LPC" rev 0x00) 
pcibios0: PCI bus #3 is the last bus 
bios0: ROM list: 0xc0000/0x8000 
mainbus0: Intel MP Specification (Version 1.4) (OEM00000 PROD00000000) 
cpu0 at mainbus0: apid 0 (boot processor) 
cpu0: apic clock running at 133 MHz 
cpu1 at mainbus0: apid 6 (application processor) 
cpu1: Intel(R) Xeon(TM) CPU 2.40GHz ("GenuineIntel" 686-class) 2.41 GHz 
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CNXT-ID 
mainbus0: bus 0 is type PCI 
mainbus0: bus 1 is type PCI 
mainbus0: bus 2 is type PCI 
mainbus0: bus 3 is type PCI 
mainbus0: bus 4 is type ISA 
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 20, 24 pins 
ioapic0: misconfigured as apic 0, remapped to apic 4 
pci0 at mainbus0 bus 0: configuration mode 1 (no bios) 
pchb0 at pci0 dev 0 function 0 "Intel 82875P Host" rev 0x02 
ppb0 at pci0 dev 1 function 0 "Intel 82875P AGP" rev 0x02 
pci1 at ppb0 bus 1 
ppb1 at pci0 dev 3 function 0 "Intel 82875P PCI-CSA" rev 0x02 
pci2 at ppb1 bus 2 
em0 at pci2 dev 1 function 0 "Intel PRO/1000CT (82547EI)" rev 0x00: apic 4 int 18 (irq 15), address: 00:0e:a6:5f:77:5b 
ppb2 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0xc2 
pci3 at ppb2 bus 3 
vga1 at pci3 dev 9 function 0 "S3 ViRGE DX/GX" rev 0x01 
wsdisplay0 at vga1: console (80x25, vt100 emulation) 
wsdisplay0: screen 1-5 added (80x25, vt100 emulation) 
rl0 at pci3 dev 10 function 0 "Realtek 8139" rev 0x10: apic 4 int 22 (irq 11) address 00:c0:26:8c:5d:f2 
rlphy0 at rl0 phy 0: RTL internal phy 
ichpcib0 at pci0 dev 31 function 0 "Intel 82801EB/ER LPC" rev 0x02 
pciide0 at pci0 dev 31 function 1 "Intel 82801EB/ER IDE" rev 0x02: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility 
atapiscsi0 at pciide0 channel 0 drive 0 
scsibus0 at atapiscsi0: 2 targets 
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CR-48XGTE, 1.0K> SCSI0 5/cdrom removable 
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 
pciide0: channel 1 ignored (disabled) 
pciide1 at pci0 dev 31 function 2 "Intel 82801EB SATA" rev 0x02: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI 
pciide1: using apic 4 int 16 (irq 15) for native-PCI interrupt 
wd0 at pciide1 channel 0 drive 0: <SAMSUNG SP1614C> 
wd0: 16-sector PIO, LBA48, 152627MB, 312581808 sectors 
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5 
wd1 at pciide1 channel 1 drive 0: <SAMSUNG SP1614C> 
wd1: 16-sector PIO, LBA48, 152627MB, 312581808 sectors 
wd1(pciide1:1:0): using PIO mode 4, Ultra-DMA mode 5 
"Intel 82801EB/ER SMBus" rev 0x02 at pci0 dev 31 function 3 not configured 
isa0 at ichpcib0 
isadma0 at isa0 
pckbc0 at isa0 port 0x60/5 
pckbd0 at pckbc0 (kbd slot) 
pckbc0: using irq 1 for kbd slot 
wskbd0 at pckbd0: console keyboard, using wsdisplay0 
pcppi0 at isa0 port 0x61 
midi0 at pcppi0: <PC speaker> 
sysbeep0 at pcppi0 
lm0 at isa0 port 0x290/8: W83627THF 
npx0 at isa0 port 0xf0/16: using exception 16 
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo 
pccom0: console 
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo 
biomask 0 netmask 0 ttymask 0 
pctr: user-level cycle counter enabled 
wd0(pciide1:0:0): timeout 
type: ata 
c_bcount: 512 
c_skip: 0 
wd0(pciide1:0:0): timeout 
type: ata 
c_bcount: 512 
c_skip: 0 


Any suggestions? I'm ready to do any further tests, guess i'm not alone with this situation.
As the box will not have big loads a couple of months - it can run(and is running) with only "half of CPU".
Many thanks in advance,
John

---------------------------------------------------
Ion Gavrilita, Technical University of Moldova,
Network and Systems Administrator,
+3737-9543210 (private cell);
+3736-9138776 (corporate cell);
+37322-497025, int 23 (work)
---------------------------------------------------



Visit your host, monkey.org