[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PATCH: Enable 3COM OfficeConnect 11Mpbs Wireless LAN 3CRSHPW796 Cardbus card



On Wednesday 28 July 2004 14.53, Sigfred Håversen wrote:
> On Wednesday 28 July 2004 05.59, Todd C. Miller wrote:
> > I'd rather use this instead.
> >
> >  - todd
>
> Your patch is applied, and card works fine.
<snip>

> /Sigfred

My previous testing was just with "cvs -q up -Pd" and web browsing, and the 
card seemed OK. But when I rebuild kernel or does a "make build" I get the 
following output to console :

atw0: transmit process not idle [RUNNING - transmitting]
atw0: bits 00002002 test0 08c10100 stsr 00110000

I use isakpmd for my wireless, but not sure if that has anything to do 
with these messages. 

/Sigfred


OpenBSD 3.5-current (GENERIC) #4: Wed Jul 28 23:19:35 CEST 2004
    root_(_at_)_laptop_(_dot_)_mumak_(_dot_)_com:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache) 301 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 335126528 (327272K)
avail mem = 301531136 (294464K)
using 4116 buffers containing 16859136 bytes (16464K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(7f) BIOS, date 05/02/01, BIOS32 rev. 0 @ 0xf4e22
apm0 at bios0: Power Management spec V1.2
apm0: battery life expectancy 0%
apm0: AC on, battery charge critical
pcibios0 at bios0: rev. 2.1 @ 0xf4e20/0x910
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf5610/288 (16 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371AB PIIX4 ISA" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xc000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX" rev 0x02
vga1 at pci0 dev 2 function 0 "Trident CYBER 9397" rev 0xf3
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <HITACHI_DK23EA-40>
wd0: 16-sector PIO, LBA, 38154MB, 78140160 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TOSHIBA, CD-ROM XM-1602B, 1132> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 0, DMA mode 1
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 10
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82371AB Power Mgmt" rev 0x02 at pci0 dev 7 function 3 not configured
cbb0 at pci0 dev 10 function 0 "Cirrus Logic CL-PD6832 CardBus" rev 0xc1: irq 10
cbb1 at pci0 dev 10 function 1 "Cirrus Logic CL-PD6832 CardBus" rev 0xc1: irq 10
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
mpu0 at isa0 port 0x300/2: generic MPU-401 compatible
midi0 at mpu0: <MPU-401 MIDI UART>
sb0 at isa0 port 0x220/24 irq 5 drq 1: dsp v3.01
midi1 at sb0: <SB MIDI UART>
audio0 at sb0
opl0 at sb0: model OPL3
midi2 at opl0: <SB Yamaha OPL3>
wss0: irq 10 already in use
pcppi0 at isa0 port 0x61
midi3 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 1 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
biomask ef4d netmask ef4d ttymask ffcf
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
atw0 at cardbus1 dev 0 function 0: 3Com 3CRSHPW796 802.11b, revision 1.5
: 3Com 3CRSHPW796 802.11b: irq 10
atw0: RFMD RF, RFMD BBP 802.11 address 00:0d:54:f8:47:97
atw0: transmit process not idle [RUNNING - transmitting]
atw0: bits 00002002 test0 08c10100 stsr 00110000
atw0: transmit process not idle [RUNNING - transmitting]
atw0: bits 00002002 test0 08c10100 stsr 00110000
atw0: transmit process not idle [RUNNING - transmitting]
atw0: bits 00002002 test0 08c10100 stsr 00000000