[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: UPDATE: net/irssi-0.8.10



viq [2006-03-10, 21:54:10]:
> This time a diff that seems to work. Applying that patch left me with bunch of 
> *.orig files which I don't know whether is an error of patch, patching 
> process I used (patch -p0 -E < irssi.diff) or just The Way Things Are.
> 
> Based heavily on update posted by Antti Harri, and code pointed to by Jacob 
> Meuser.
> 
> Please test, and look whether everything is correct - especially such things 
> like tags and comments in Makefile, I just bumped a number in there.
> 
> It's my first port so I'd like it to be done correctly ;)
> 
> -- 
> viq
> 
> 
> ---------------------------------------------------------------------
> Toshiba i FIFA World Cup
> Wygraj bilety i notebooki z Intel Centrino Duo Mobile Technology
> http://link.interia.pl/f1912

> Index: Makefile
> ===================================================================
> RCS file: /cvs/ports/net/irssi/Makefile,v
> retrieving revision 1.25
> diff -u -d -r1.25 Makefile
> --- Makefile	16 Dec 2004 00:31:22 -0000	1.25
> +++ Makefile	10 Mar 2006 18:02:53 -0000
> @@ -5,7 +5,7 @@
>  
>  COMMENT=	"modular IRC client with many features (ipv6,socks,proxy)"
>  
> -DISTNAME=	irssi-0.8.9
> +DISTNAME=	irssi-0.8.10
>  CATEGORIES=	net
>  
>  MASTER_SITES=	${HOMEPAGE}/files/ \
> @@ -26,15 +26,16 @@
>  PERMIT_PACKAGE_FTP=	Yes
>  PERMIT_DISTFILES_CDROM=	Yes
>  PERMIT_DISTFILES_FTP=	Yes
> -WANTLIB=		c crypto m ncurses perl ssl util
> +WANTLIB=		c crypto m ncurses perl ssl util iconv intl
>  
> -LIB_DEPENDS+=		glib.1.2,gmodule::devel/glib
> +LIB_DEPENDS+=		glib-2.0.0.0,gmodule-2.0.0.0::devel/glib2
> +BUILD_DEPENDS+=		:pkgconfig-*:devel/pkgconfig
>  
>  CONFIGURE_STYLE=	gnu
>  
>  CONFIGURE_ARGS+=	--datadir=${PREFIX}/share/doc --enable-ipv6 \
>  	--with-proxy --enable-perl=yes --with-included-gettext \

can you put without-included-gettext here?

Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm