[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Xplanet



On Tue, Jan 03, 2006 at 02:35:02PM +0100, Jasper Lievisse Adriaanse wrote:
> On Tue, 3 Jan 2006 14:32:53 +0100
> Hermann Gottschalk <hg_(_at_)_ostc_(_dot_)_de> wrote:
> 
> > Hi,
> > I use OpenBSD 3.8 and xplanet-1.1.2p4.
> > 
> > When I use the included marker_file for the earth I get
> > 
> > Warning: iconv_open() failed, fromCode is UTF-8, toCode is 
> > Warning: iconv_open() failed, fromCode is , toCode is UTF-8
> > Warning: iconv_open() failed, fromCode is UTF-8, toCode is 
> > Warning: iconv_open() failed, fromCode is , toCode is UTF-8
> > 
> > continuously.
> > 
> > Trying to compile the xplanet port gave me some warnings:
> > 
> > bimage/libimage.a(WriteImage.o)(.text+0x45): In function `WriteImage(char const*, int, int, unsigned char*, unsigned char*, int)':
> > : warning: strcpy() is almost always misused, please use strlcpy()
> > /usr/X11R6/lib/libX11.so.9.0: warning: sprintf() is often misused, please use snprintf()
> > /usr/X11R6/lib/libX11.so.9.0: warning: strcat() is almost always misused, please use strlcat()
> > /usr/bin/ld: warning: libintl.so.2.0, needed by /usr/local/lib/libpangoft2-1.0.so.800.1, may conflict with libintl.so.3.0
> > 
> > The last line could be a hint for the error-messages...
> > 
> > Does anybody know a solution?
> Are you using the most current ports tree?

I updated src and ports, compiled kernel and the system again
(3.8stable) but nothing changed. Neither the package nor the port run
properly.

Attachment: pgpbVMglspim9.pgp
Description: PGP signature


Visit your host, monkey.org