[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

textproc/expat shared lib version problem



Hi,


having textproc/p5-XML-Parser installed, it is always shown as outdated by the new out-of-date script. It wants to be use expat.5.0 instead of expat.4.0.


The reason for this is that textproc/expat contains libexpat.4.0, while the base system's X11 has /usr/X11R6/lib/libexpat.so.5.0.

This looks weird to me, but I don't understand all the implications well enough to really propose a solution ... maybe bump the port's .so number so it's always ahead of base? Leave-as-is-because-it's-ok and teach out-of-date about special cases like this?

Maybe TPTB have a better idea, so I'll just drop this notice here.


Hope it helps,

Moritz