[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: update: multimedia/transcode



Am Donnerstag, 13. Oktober 2005 03:32 schrieb Jacob Meuser:

> can you verify this happen with 0.6.14 on -current too?

It happens, too. And yes, I ran it from dvdrip, but also directly from the 
shell.

*** WARNING: The option -V is deprecated. ***
*** Transcode internal frame handling is now in YV12 / YUV420 ***
*** format by default because most codecs can only handle this format, ***
*** otherwise leading to unnecessary time and quality wasting conversions. ***
*** If you want to have to "old" behaviour (RGB24 as internal format), ***
*** then please use the new -1/--use_rgb option ***
transcode v0.6.14 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
libdvdread: Using libdvd version 0.3 for DVD access
libdvdread: Couldn't find device name.
libdvdread: Can't open file VIDEO_TS.IFO.
[transcode] (probe) suggested AV correction -D 2 (80 ms) | AV 80 ms | 0 ms
[transcode] auto-probing source /home/tesch/dvdrip/test/vob/002 (ok)
[transcode] V: import format    | MPEG-2  (V=vob|A=vob)
[transcode] V: AV demux/sync    | (1) sync AV at initial MPEG sequence
[transcode] V: import frame     | 720x576  1.25:1  encoded @ 4:3
[transcode] V: de-interlace     | (mode=3) zoom to full frame (slow)
[transcode] V: new aspect ratio | 640x480  1.33:1 (-B)
[transcode] V: bits/pixel       | 0.146 (low)
[transcode] V: decoding fps,frc | 25.000,0
[transcode] V: multi-pass       | (mode=2) reading data (pass2) from divx4.log
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x2001  AC3/A52      [48000,16,2]  448 kbps
[transcode] A: export format    | 0x55    MPEG layer-3 [48000,16,2]  128 kbps
[transcode] V: encoding fps,frc | 25.000,3
[transcode] A: bytes per frame  | 7680 (7680.000000)
[transcode] A: adjustment       | 0_(_at_)_1000
[transcode] A: rescale stream   | 3.800
[transcode] V: IA32 accel mode  | sse (sse mmxext mmx asm C)
tc_memcpy: using mmxext for memcpy
[transcode] V: video buffer     | 10 @ 720x576
[import_vob.so] v0.6.0 (2003-10-02) (video) MPEG-2 | (audio) MPEG/AC3/PCM | 
(subtitle)
[export_xvid4.so] v0.0.5 (2003-12-05) (video) XviD 1.0.x series (aka API 4.0) 
| (audio) MPEG/AC3/PCM
[import_vob.so] tccat -i "/home/tesch/dvdrip/test/vob/002" -t vob -d 0 -S 0 | 
tcdemux -a 0 -x ac3 -S 0 -M 1 -d 0 | tcextract -t vob -a 0 -x ac3 -d 0 | 
tcdecode -x a52 -d 0 -A 1
[import_vob.so] tccat -i "/home/tesch/dvdrip/test/vob/002" -t vob -d 0 -S 0 | 
tcdemux -s 0x80 -x mpeg2 -S 0 -M 1 -d 0 | tcextract -t vob -a 0 -x mpeg2 -d 0 
| tcdecode -x mpeg2 -d 0 -y yv12
[export_xvid4.so] Neither './xvid4.cfg' nor '~/.transcode/xvid4.cfg'
[export_xvid4.so] found. Default settings will be used instead.
tc_memcpy: using mmxext for memcpy
tc_memcpy: using mmxext for memcpy
No accelerated IMDCT transform found
Audio: using new version
Audio: using lame-3.96.1
[/usr/ports/multimedia/transcode/w-transcode-0.6.14p2/transcode-0.6.14/src/encoder.c] 
Delaying audio (0)
Segmentation fault (core dumped)   1.03 fps, EMT: 0:00:53, ( 0| 0| 9)
Segmentation fault (core dumped)   1.03 fps, EMT: 0:00:53, ( 0| 0| 9)
encoding frames [000000-001338],   1.03 fps, EMT: 0:00:53, ( 0| 0| 1)
clean up | frame threads | unload modules | cancel signal | internal threads | 
done
[transcode] clipped 9591 audio samples
[transcode] encoded 1339 frames (0 dropped, 0 cloned), clip length  53.56 s


> check if it was tcdemux that segfaulted.  if it is. and you can get
> useful backtrace, I'd like to see it.

OK, I'll try to tackle this on the weekend.

Regards,
Stephan