[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pkg_add -u



>From pkg_add(1) man page:

-u       Update the given pkgname(s), and anything it depends upon.

But when issuing the command there isn't any output:

# echo $PKG_PATH            
ftp://ftp.openbsd.org/pub/OpenBSD/snapshots/packages/i386/
# pkg_add -u xchat          
# pkg_info | grep xchat
xchat-2.4.1         GTK+2 IRC client
#

even though xchat-2.4.5 is on $PKG_PATH.

I tryed a -r -F updatedepends:

# pkg_add -r -F updatedepends xchat-2.4.5
Can't install xchat-2.4.5: lib not found atk-1.0.1011.3
Even by looking in the dependency tree:
        tiff-3.7.3, jpeg-6bp2, png-1.2.8, glib2-2.6.4, atk-1.10.1,
gettext-0.10.40p3, libiconv-1.9.2p1, gtk+2-2.6.9, pango-1.8.1
Maybe it's in a dependent package, but not tagged with @lib ?
(check with pkg_info -K -L)
If you are still running 3.6 packages, update them.
Can't install xchat-2.4.5: lib not found gdk-x11-2.0.600.10
Can't install xchat-2.4.5: lib not found gdk_pixbuf-2.0.600.10
Can't install xchat-2.4.5: lib not found gtk-x11-2.0.600.10
#



Visit your host, monkey.org