[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bsd.port.mk USE_MOTIF LIB_DEPENDS problem



On Fri, Feb 28, 2003 at 03:06:37PM +1100, Andrew Dalgleish wrote:
> If you install openmotif (which provides libXm.so.2.1),
> then make a package for lesstif, the binaries require libXm.so.2.1
> but the package has a LIB_DEPENDS of lesstif (which only provides
> libXm.so.1.2).

I have two questions here.

Why would you make a lesstif package if you have openmotif installed?

Why would you use lesstif anyway, when openmotif is available?
Its name (less) implies more than the authors intended, because it
really gives you less.  It's full of bugs, and there's probably a reason
for openmotif being preferred in OpenBSD.

-- 
Zvezdan Petkovic



Visit your host, monkey.org