[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: updated: devel/astyle



Andrey Smagin <andrey_(_at_)_smagin_(_dot_)_com> wrote:

> Sparc64 - RFC: Could somebody please test this on sparc64?
> 
> For some reason I am getting 'internal compiler error' when trying to
> compile either current or updated port of astyle on Ultra5.

Same here (Blade 100).  Builds fine with GCC 3.1.

> Recent report of sparc64 ports breakage from David Lebel did not
> show that astyle-1.14.1 was broken,

But there is no astyle snapshot package either.  David doesn't
report breakage due to internal compiler errors any longer, because
those simply aren't the port's fault.

> (I get this 'internal compiler error' way too often
> lately - astyle, tightvnc, fwbuilder, etc...)

By now I'm way more interested in
1. hearing about ports that don't build with GCC 3.1,
2. fixes for those.

Just about everything that uses C++ breaks with the system compiler,
and quite a bit of plain C code does, too.

-- 
Christian "naddy" Weisgerber                          naddy_(_at_)_mips_(_dot_)_inka_(_dot_)_de



Visit your host, monkey.org