[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mpeg2 on OpenBSD



Hi folks,

this morning I took a look at several open-source projekts
working on mpeg2-capable "players" for unices.
Among these projects were the following:

http://www.videolan.org/
http://xine.sourceforge.net/
http://www.linuxvideo.org/ (mpeg2dec)

Trying to compile each of them, I get stuck at some point ;(
(I run -current from two days ago)

http://www.videolan.org/vlc/bsd.html states about their port to
*BSD.
Trying to compile vlc-0.2.73, it stops with these messages:

| /tmp/ccd31259.s: Assembler messages:
| /tmp/ccd31259.s:170: Error: no such 386 instruction: `pxor'
| /tmp/ccd31259.s:171: Error: no such 386 instruction: `movq'
| /tmp/ccd31259.s:172: Error: no such 386 instruction: `movq'
| /tmp/ccd31259.s:173: Error: no such 386 instruction: `punpckhbw'
| /tmp/ccd31259.s:174: Error: no such 386 instruction: `punpcklbw'
| /tmp/ccd31259.s:175: Error: no such 386 instruction: `paddw'
| /tmp/ccd31259.s:176: Error: no such 386 instruction: `paddw'
| /tmp/ccd31259.s:177: Error: no such 386 instruction: `packuswb'
| /tmp/ccd31259.s:178: Error: no such 386 instruction: `movq'
| /tmp/ccd31259.s:180: Error: no such 386 instruction: `movq'
| /tmp/ccd31259.s:181: Error: no such 386 instruction: `movq'
| /tmp/ccd31259.s:182: Error: no such 386 instruction: `punpckhbw'
| /tmp/ccd31259.s:183: Error: no such 386 instruction: `punpcklbw'
| /tmp/ccd31259.s:184: Error: no such 386 instruction: `paddw'
| /tmp/ccd31259.s:185: Error: no such 386 instruction: `paddw'
| /tmp/ccd31259.s:186: Error: no such 386 instruction: `packuswb'
| /tmp/ccd31259.s:187: Error: no such 386 instruction: `movq'
| /tmp/ccd31259.s:189: Error: no such 386 instruction: `movq'

No, I have to admit, I don't know nothing about assembler :(

Next candidate was mpeg2dec-0.2.0:

| /tmp/ccE32632.s: Assembler messages:
| /tmp/ccE32632.s:255: Error: no such 386 instruction: `emms'
| /tmp/ccE32632.s:532: Error: no such 386 instruction: `emms'
| *** Error code 1

xine-0.4.3 was next, but already chokes on -lpthread during 
configure....

| checking for pthread_create in -lpthread... no

Maybe someone else has some ideas on how to get further on these
things...
-fkr
-- 
gpg-fingerprint: 076E 1E87 3E05 1C7F B1A0  8A48 0D31 9BD3 D9AC 74D0 
  |http://www.hazardous.org/ | whois -h whois.ripe.de FKR-RIPE  |
  |all your base are belong to us  |  shame on me  | fkr_(_at_)_IRCnet | 




Visit your host, monkey.org