[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with USB "axe" network card



Hello again,

just wanted to mention here that aside from the weird bandwidth problem,
the axe devices also stop working after a while and I am getting

axe0: error PHY failed
or
axe1: error PHY failed

...I went from 3.8 to 3.9 and currently I am following the snapshots.

Currently, nothing works correctly with the D-Link DUB E-100.

If anyone got a clue on what to do or if I can help someone getting a
clue on this problem I would be really happy.

Its a really nasty bug that makes the devices almost useless. =(

Michael Lechtermann



OpenBSD 3.9-current (GENERIC) #739: Sun May 14 16:23:45 MDT 2006
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Celeron(R) CPU 2.40GHz ("GenuineIntel" 686-class) 2.40 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID
real mem  = 259031040 (252960K)
avail mem = 229011456 (223644K)
using 3187 buffers containing 13053952 bytes (12748K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 09/29/04, BIOS32 rev. 0 @
0xffe90, SMBIOS rev. 2.3 @ 0xf0450 (61 entries)
bios0: Dell Computer Corporation OptiPlex SX270
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
apm0: flags 30102 dobusy 0 doidle 1
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfeae0/176 (9 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82801EB/ER LPC" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xa800 0xca800/0x1800
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82865G/PE/P CPU-I/0-1" rev 0x02
vga1 at pci0 dev 2 function 0 "Intel 82865G Video" rev 0x02: aperture at
0xf0000000, size 0x8000000
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
uhci0 at pci0 dev 29 function 0 "Intel 82801EB/ER USB" rev 0x02: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 2 "Intel 82801EB/ER USB" rev 0x02: irq 10
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 3 "Intel 82801EB/ER USB" rev 0x02: irq 11
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801EB/ER USB2" rev 0x02: irq 9
usb3 at ehci0: USB revision 2.0
uhub3 at usb3
uhub3: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub3: 8 ports with 8 removable, self powered
ppb0 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0xc2
pci1 at ppb0 bus 1
em0 at pci1 dev 12 function 0 "Intel PRO/1000MT (82540EM)" rev 0x02: irq
10, address 00:0d:56:cc:01:2b
ichpcib0 at pci0 dev 31 function 0 "Intel 82801EB/ER LPC" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 82801EB/ER IDE" rev 0x02: DMA,
channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <SAMSUNG MP0402H>
wd0: 16-sector PIO, LBA48, 38204MB, 78242976 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVD-ROM GDR8081N, 0110> SCSI0
5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801EB/ER SMBus" rev 0x02: irq 5
iic0 at ichiic0
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask ff6d netmask ff6d ttymask ffef
pctr: user-level cycle counter enabled
axe0 at uhub3 port 7 configuration 1 interface 0
axe0: D-Link 10/100 ethernet, rev 2.00/10.01, addr 2, AX88172, address
00:80:c8:37:dc:2f
rlphy0 at axe0 phy 3: IP101 10/100 PHY, rev. 4
axe1 at uhub3 port 8 configuration 1 interface 0
axe1: D-Link 10/100 ethernet, rev 2.00/10.01, addr 3, AX88172, address
00:80:c8:37:dc:33
rlphy1 at axe1 phy 3: IP101 10/100 PHY, rev. 4
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302


lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 33224
	groups: lo
	inet 127.0.0.1 netmask 0xff000000
	inet6 ::1 prefixlen 128
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 00:0d:56:cc:01:2b
	media: Ethernet autoselect (1000baseT full-duplex)
	status: active
	inet 192.168.131.65 netmask 0xffffffc0 broadcast 192.168.131.127
	inet6 fe80::20d:56ff:fecc:12b%em0 prefixlen 64 scopeid 0x1
pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33224
pfsync0: flags=0<> mtu 1460
enc0: flags=0<> mtu 1536
axe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 00:80:c8:37:dc:2f
	groups: egress
	media: Ethernet autoselect (100baseTX full-duplex)
	status: active
	inet6 fe80::280:c8ff:fe37:dc2f%axe0 prefixlen 64 scopeid 0x6
	inet 192.168.13.254 netmask 0xffffff00 broadcast 192.168.13.255
axe1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 00:80:c8:37:dc:33
	media: Ethernet autoselect
	status: no carrier
	inet 192.168.131.129 netmask 0xffffffc0 broadcast 192.168.131.191
	inet6 fe80::280:c8ff:fe37:dc33%axe1 prefixlen 64 scopeid 0x7


Controller /dev/usb0:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 powered
 port 2 powered
Controller /dev/usb1:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 powered
 port 2 powered
Controller /dev/usb2:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 powered
 port 2 powered
Controller /dev/usb3:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 powered
 port 2 powered
 port 3 powered
 port 4 powered
 port 5 powered
 port 6 powered
 port 7 addr 2: high speed, power 450 mA, config 1, 10/100
ethernet(0x1a00), D-Link(0x2001), rev 10.01
 port 8 addr 3: high speed, power 450 mA, config 1, 10/100
ethernet(0x1a00), D-Link(0x2001), rev 10.01



Visit your host, monkey.org