[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: appling X-Patch -> make build breaks?



Hi.

I have the same problem. Compiling 007_xorg.patch on 3.8

root_(_at_)_thot ~ # cd /usr/src/XF4/
root_(_at_)_thot XF4 # patch -p0 < /home/juancho/parches/007_xorg.patch
[...]
root_(_at_)_thot XF4 # make build
[...]

main.c:249: error: syntax error before "Tcl_Interp"
main.c:251: error: syntax error before '{' token
*** Error code 1

Stop in /usr/src/XF4/xc-old/programs/Xserver/hw/xfree86/XF86Setup.
*** Error code 1

Stop in /usr/src/XF4/xc-old/programs/Xserver/hw/xfree86 (line 879 of
Makefile).
*** Error code 1

Stop in /usr/src/XF4/xc-old/programs/Xserver (line 1148 of Makefile).
*** Error code 1

Stop in /usr/src/XF4/xc-old/programs (line 688 of Makefile).
*** Error code 1

Stop in /usr/src/XF4/xc-old (line 662 of xmakefile).
*** Error code 1

Stop in /usr/src/XF4/xc-old (line 716 of xmakefile).
*** Error code 1

Stop in /usr/src/XF4/xc-old (line 39 of Makefile).
*** Error code 1

Stop in /usr/src/XF4 (line 64 of Makefile).
*** Error code 1

Stop in /usr/src/XF4 (line 77 of Makefile).


Any ideas?

El jue, 04-05-2006 a las 10:45 +0000, Didier Wiroth escribis:
> see also: man 8 release, it's a bit more detailedunder:  "5.   Build and
> install XF4".Use another directory to build, for example:a) mkdir
> /usr/XF4BLDb) cd /usr/XF4BLD;lndir /usr/XF4c) nice make build----- Original
> Message -----From: sebastian_(_dot_)_rother_(_at_)_jpberlin_(_dot_)_deDate: Thursday, May 4, 2006
> 11:10Subject: Re: appling X-Patch -> make build breaks?To: Rogier Krieger Cc:
> misc_(_at_)_openbsd_(_dot_)_org> > On 5/4/06, sebastian_(_dot_)_rother_(_at_)_jpberlin_(_dot_)_de > > wrote:> >>
> Stop in /usr/XF4/xc-old/programms/Xserver/hw/xfree86/XF86Setup> >> > A quick
> guess: did you install the tcl and tk packages? IIRC, > the FAQ> > mentions
> those as a prerequisite for building XF86Setup on i386.> >> > The lines in the
> preceding source code deal with tk parsing command> > line arguments.> >> >
> Cheers,> >> > Rogier> > Yupp...> > tk-8.4.7            graphical toolkit for
> Tcl> tcl-8.4.7p1         Tool Command Language> > Well I`ll check the HDD for
> Errors...> I installed the Sources via FTP (it`s faster then CVS :)).> > If
> others had no problem so far there must be somethign wrong > with the HDD> or
> the Sources.> > didier: I`m not sure if these Sources are ok... (not anymore)>
> Ted: I had also other Errors. I just posted the first.> > > I`ll simply rm -RF
> /usr/XF4 and refetch the Src and try again.> > > Kind regards,> Sebastian> >
> 
-- 
Juan J D'Alessandro M
Coordinador General
Grupo BSD Venezuela
Valencia - Venezuela