[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[RESOLVED] Re: update: 3.9 amd64 hangs with mp on boot



My problem is resolved. Offlist it was suggested that I build to
-current and it's working well (so far, anyhow; I rebooted it remotely
and the box came up)

Here are dmesgs, bsd and bsd.mp respectively. I made no changes at all,
these are plain vanilla GENERIC and GENERIC.MP included here for
developer use and the archives.

Thanks a million!
 Gord

===========

uniprocessor kernel from current:

OpenBSD 3.9-current (GENERIC) #2: Wed Apr 26 10:58:19 CDT 2006
    grieder_(_at_)_xena_(_dot_)_ibd_(_dot_)_nrc_(_dot_)_ca:/usr/src/sys/arch/amd64/compile/GENERIC
real mem = 2146758656 (2096444K)
avail mem = 1835565056 (1792544K)
using 22937 buffers containing 214884352 bytes (209848K) of memory
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, 2004.80 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0 "ATI RS480 Host" rev 0x01
ppb0 at pci0 dev 2 function 0 "ATI RX480 PCIE" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon X600 (RV370)" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"ATI Radeon X600 (RV370) Sec" rev 0x00 at pci1 dev 0 function 1 not configured
pchb1 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb4 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
ppb1 at pci0 dev 26 function 0 "Acer Labs M5249 PCI-PCI" rev 0x00
pci2 at ppb1 bus 2
ppb2 at pci2 dev 17 function 0 "Texas Instruments PCI2250 PCI-PCI" rev 0x02
pci3 at ppb2 bus 3
sis0 at pci3 dev 0 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: irq 11, address 00:00:24:c5:98:54
nsphyter0 at sis0 phy 0: DP83815 10/100 PHY, rev. 1
sis1 at pci3 dev 1 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: irq 5, address 00:00:24:c5:98:55
nsphyter1 at sis1 phy 0: DP83815 10/100 PHY, rev. 1
sis2 at pci3 dev 2 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: irq 5, address 00:00:24:c5:98:56
nsphyter2 at sis2 phy 0: DP83815 10/100 PHY, rev. 1
sis3 at pci3 dev 3 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: irq 7, address 00:00:24:c5:98:57
nsphyter3 at sis3 phy 0: DP83815 10/100 PHY, rev. 1
skc0 at pci2 dev 20 function 0 "Marvell Yukon 88E8001/8003/8010" rev 0x14, Marvell Yukon Lite (0x9): irq 7
sk0 at skc0 port A, address 00:15:f2:87:34:f6
eephy0 at sk0 phy 0: Marvell 88E1011 Gigabit PHY, rev. 5
ohci0 at pci0 dev 28 function 0 "Acer Labs M5237 USB" rev 0x03: irq 3, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1 at pci0 dev 28 function 1 "Acer Labs M5237 USB" rev 0x03: irq 11, version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
ohci2 at pci0 dev 28 function 2 "Acer Labs M5237 USB" rev 0x03: irq 5, version 1.0, legacy support
usb2 at ohci2: USB revision 1.0
uhub2 at usb2
uhub2: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub2: 3 ports with 3 removable, self powered
ehci0 at pci0 dev 28 function 3 "Acer Labs M5239 USB2" rev 0x01: irq 10
usb3 at ehci0: USB revision 2.0
uhub3 at usb3
uhub3: Acer Labs EHCI root hub, rev 2.00/1.00, addr 1
uhub3: 8 ports with 8 removable, self powered
pcib0 at pci0 dev 30 function 0 vendor "Acer Labs", unknown product 0x1575 rev 0x00
"Acer Labs M7101 Power" rev 0x00 at pci0 dev 30 function 1 not configured
pciide0 at pci0 dev 31 function 0 "Acer Labs M5229 UDMA IDE" rev 0xc8: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD2500JB-00GVA0>
wd0: 16-sector PIO, LBA48, 238475MB, 488397168 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GSA-4167B, DL11> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
pciide1 at pci0 dev 31 function 1 vendor "Acer Labs", unknown product 0x5288 rev 0x10: DMA (unsupported), channel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide1: using irq 5 for native-PCI interrupt
wd1 at pciide1 channel 0 drive 0: <ST3400832AS>
wd1: 16-sector PIO, LBA48, 381554MB, 781422768 sectors
wd2 at pciide1 channel 1 drive 0: <ST3400832AS>
wd2: 16-sector PIO, LBA48, 381554MB, 781422768 sectors
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
it2 at isa0 port 0xd00/8: IT87
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Chicony USB Keyboard, rev 1.10/3.90, addr 2, iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev1 at uhub1 port 1 configuration 1 interface 1
uhidev1: Chicony USB Keyboard, rev 1.10/3.90, addr 2, iclass 3/1
uhidev1: 2 report ids
uhid0 at uhidev1 reportid 1: input=6, output=0, feature=0
uhid1 at uhidev1 reportid 2: input=1, output=0, feature=0
dkcsum: wd0 matches BIOS drive 0x80
wd1: no disk label
dkcsum: wd1 matches BIOS drive 0x81
dkcsum: wd1 matches BIOS drive 0x82 IGNORED
wd2: no disk label
dkcsum: wd2 matches BIOS drive 0x81 IGNORED
dkcsum: wd2 matches BIOS drive 0x82
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

=====================

mp kernel from current:

OpenBSD 3.9-current (GENERIC.MP) #0: Wed Apr 26 10:48:18 CDT 2006
    grieder_(_at_)_xena_(_dot_)_ibd_(_dot_)_nrc_(_dot_)_ca:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 2146758656 (2096444K)
avail mem = 1835454464 (1792436K)
using 22937 buffers containing 214884352 bytes (209848K) of memory
mainbus0 (root)
mainbus0: Intel MP Specification (Version 1.4) (TEMPLATE             )
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, 2004.81 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: apic clock running at 200MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, 2004.55 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu1: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
mpbios: bus 0 is type PCI   
mpbios: bus 1 is type PCI   
mpbios: bus 2 is type PCI   
mpbios: bus 3 is type PCI   
mpbios: bus 4 is type ISA   
ioapic0 at mainbus0 apid 2 pa 0xfec00000, version 11, 24 pins
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0 "ATI RS480 Host" rev 0x01
ppb0 at pci0 dev 2 function 0 "ATI RX480 PCIE" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon X600 (RV370)" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"ATI Radeon X600 (RV370) Sec" rev 0x00 at pci1 dev 0 function 1 not configured
pchb1 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb4 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
ppb1 at pci0 dev 26 function 0 "Acer Labs M5249 PCI-PCI" rev 0x00
pci2 at ppb1 bus 2
ppb2 at pci2 dev 17 function 0 "Texas Instruments PCI2250 PCI-PCI" rev 0x02
pci3 at ppb2 bus 3
sis0 at pci3 dev 0 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: apic 2 int 18 (irq 11), address 00:00:24:c5:98:54
nsphyter0 at sis0 phy 0: DP83815 10/100 PHY, rev. 1
sis1 at pci3 dev 1 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: apic 2 int 19 (irq 5), address 00:00:24:c5:98:55
nsphyter1 at sis1 phy 0: DP83815 10/100 PHY, rev. 1
sis2 at pci3 dev 2 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: apic 2 int 20 (irq 5), address 00:00:24:c5:98:56
nsphyter2 at sis2 phy 0: DP83815 10/100 PHY, rev. 1
sis3 at pci3 dev 3 function 0 "NS DP83815 10/100" rev 0x00, DP83816A: apic 2 int 21 (irq 7), address 00:00:24:c5:98:57
nsphyter3 at sis3 phy 0: DP83815 10/100 PHY, rev. 1
skc0 at pci2 dev 20 function 0 "Marvell Yukon 88E8001/8003/8010" rev 0x14, Marvell Yukon Lite (0x9): apic 2 int 21 (irq 7)
sk0 at skc0 port A, address 00:15:f2:87:34:f6
eephy0 at sk0 phy 0: Marvell 88E1011 Gigabit PHY, rev. 5
ohci0 at pci0 dev 28 function 0 "Acer Labs M5237 USB" rev 0x03: apic 2 int 17 (irq 3), version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1 at pci0 dev 28 function 1 "Acer Labs M5237 USB" rev 0x03: apic 2 int 18 (irq 11), version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
ohci2 at pci0 dev 28 function 2 "Acer Labs M5237 USB" rev 0x03: apic 2 int 19 (irq 5), version 1.0, legacy support
usb2 at ohci2: USB revision 1.0
uhub2 at usb2
uhub2: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub2: 3 ports with 3 removable, self powered
ehci0 at pci0 dev 28 function 3 "Acer Labs M5239 USB2" rev 0x01: apic 2 int 23 (irq 10)
usb3 at ehci0: USB revision 2.0
uhub3 at usb3
uhub3: Acer Labs EHCI root hub, rev 2.00/1.00, addr 1
uhub3: 8 ports with 8 removable, self powered
pcib0 at pci0 dev 30 function 0 vendor "Acer Labs", unknown product 0x1575 rev 0x00
"Acer Labs M7101 Power" rev 0x00 at pci0 dev 30 function 1 not configured
pciide0 at pci0 dev 31 function 0 "Acer Labs M5229 UDMA IDE" rev 0xc8: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD2500JB-00GVA0>
wd0: 16-sector PIO, LBA48, 238475MB, 488397168 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GSA-4167B, DL11> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
pciide1 at pci0 dev 31 function 1 vendor "Acer Labs", unknown product 0x5288 rev 0x10: DMA (unsupported), channel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide1: using apic 2 int 19 (irq 5) for native-PCI interrupt
wd1 at pciide1 channel 0 drive 0: <ST3400832AS>
wd1: 16-sector PIO, LBA48, 381554MB, 781422768 sectors
wd2 at pciide1 channel 1 drive 0: <ST3400832AS>
wd2: 16-sector PIO, LBA48, 381554MB, 781422768 sectors
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
it2 at isa0 port 0xd00/8: IT87
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Chicony USB Keyboard, rev 1.10/3.90, addr 2, iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev1 at uhub1 port 1 configuration 1 interface 1
uhidev1: Chicony USB Keyboard, rev 1.10/3.90, addr 2, iclass 3/1
uhidev1: 2 report ids
uhid0 at uhidev1 reportid 1: input=6, output=0, feature=0
uhid1 at uhidev1 reportid 2: input=1, output=0, feature=0
dkcsum: wd0 matches BIOS drive 0x80
wd1: no disk label
dkcsum: wd1 matches BIOS drive 0x81
dkcsum: wd1 matches BIOS drive 0x82 IGNORED
wd2: no disk label
dkcsum: wd2 matches BIOS drive 0x81 IGNORED
dkcsum: wd2 matches BIOS drive 0x82
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

===========



Visit your host, monkey.org