[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Nokia IP330 OpenBSD 3.8 Information and Installation Assistance



On 12/13/05, NetNeanderthal <netneanderthal_(_at_)_gmail_(_dot_)_com> wrote:
> FreeBSD 6.0 dmesg
> ---8<---
> Copyright (c) 1992-2005 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>         The Regents of the University of California. All rights reserved.
> FreeBSD 6.0-RELEASE #0: Thu Nov  3 09:36:13 UTC 2005

The number of responses I've gotten to this message from people in the
same situation is astounding.  As such, I'll keep information I find
contained to this thread for simple location and archival rather than
relaying my findings and progress privately.

Here is a NetBSD 3.0RC6 dmesg I managed last night using 'consdev
com0' at the boot> prompt.  I looked for a 'verbose' option briefly,
but didn't see anything that stands out with what I'm familiar with in
OpenBSD.  Please note that all fxp NICs are assigned an initial MAC
address of ff:ff:ff:ff:ff:ff and must be manually set to operate
correctly.  Your best bet for reliable (and uninterferable) operation
is probably to assign the originally specified MACs from Nokia;
however, you may do as you please as long as you are aware of other
devices on your network.  For this specific device to be the only
exhibitor of this problem, a 'patch' against the fxp driver isn't
warranted since a healthy 'workaround' exists.  Note that NetBSD
labels the additional two NICs as tlp instead of dc (in FreeBSD 6),
though the drivers are of the same family.
(disclaimer:  Some of my dmesgs may differ slightly in terms of
hardware (optical drive mostly) as I have multiple units I am working
with in different locations.  If someone has a 266MHz version with
64MB of RAM and 8GB drive, I would like to collect some BIOS
information, possibly hardware versions as well if it is no longer
under a service contract or in production use.)

---8<---
BIOS32 rev. 0 found at 0xfaa20
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: AMD K6-2 (586-class), 398.65 MHz, id 0x58c
cpu0: features 8021bf<FPU,VME,DE,PSE,TSC,MSR,MCE,CX8>
cpu0: features 8021bf<PGE,MMX>
cpu0: "AMD-K6(tm) 3D processor"
cpu0: I-cache 32 KB 32B/line 2-way, D-cache 32 KB 32B/line 2-way
cpu0: ITLB 64 4 KB entries direct-mapped
cpu0: DTLB 128 4 KB entries 2-way
cpu0: 4 page colors
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x8086 product 0x7100 (rev. 0x01)
pcib0 at pci0 dev 7 function 0
pcib0: vendor 0x8086 product 0x7110 (rev. 0x02)
piixide0 at pci0 dev 7 function 1
piixide0: Intel 82371AB IDE controller (PIIX4) (rev. 0x01)
piixide0: bus-master DMA support present
piixide0: primary channel wired to compatibility mode
piixide0: primary channel interrupting at irq 14
atabus0 at piixide0 channel 0
piixide0: secondary channel wired to compatibility mode
piixide0: secondary channel interrupting at irq 15
atabus1 at piixide0 channel 1
uhci0 at pci0 dev 7 function 2: vendor 0x8086 product 0x7112 (rev. 0x01)
uhci0: interrupting at irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x8086 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
vendor 0x8086 product 0x7113 (miscellaneous bridge, revision 0x02) at
pci0 dev 7 function 3 not configured
fxp0 at pci0 dev 13 function 0: i82558 Ethernet, rev 5
fxp0: interrupting at irq 10
fxp0: failed to detect EEPROM size
fxp0: Ethernet address ff:ff:ff:ff:ff:ff
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 0
inphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp1 at pci0 dev 14 function 0: i82558 Ethernet, rev 5
fxp1: interrupting at irq 12
fxp1: failed to detect EEPROM size
fxp1: Ethernet address ff:ff:ff:ff:ff:ff
inphy1 at fxp1 phy 1: i82555 10/100 media interface, rev. 0
inphy1: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp2 at pci0 dev 15 function 0: i82558 Ethernet, rev 5
fxp2: interrupting at irq 5
fxp2: failed to detect EEPROM size
fxp2: Ethernet address ff:ff:ff:ff:ff:ff
inphy2 at fxp2 phy 1: i82555 10/100 media interface, rev. 0
inphy2: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ppb0 at pci0 dev 16 function 0: vendor 0x8086 product 0xb154 (rev. 0x00)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled, rd/line, wr/inv ok
tlp0 at pci1 dev 5 function 0: DECchip 21143 Ethernet, pass 4.1
tlp0: QS6611 PHY
tlp0: interrupting at irq 10
tlp0: Ethernet address 00:c0:95:c7:cd:88
tlp0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
tlp1 at pci1 dev 6 function 0: DECchip 21143 Ethernet, pass 4.1
tlp1: QS6611 PHY
tlp1: interrupting at irq 12
tlp1: Ethernet address 00:c0:95:c7:cd:89
tlp1: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com0: console
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pcppi0 at isa0 port 0x61
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
isapnp0: no ISA Plug 'n Play devices found
Kernelized RAIDframe activated
md0: internal 5000 KB image area
atapibus0 at atabus0: 2 targets
cd0 at atapibus0 drive 1: <Hewlett-Packard DVD Writer 300, MY31E5C90n,
1.25> cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2 (Ultra/33)
wd0 at atabus0 drive 0: <WDC WD200EB-11CPF0>
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 19092 MB, 38792 cyl, 16 head, 63 sec, 512 bytes/sect x 39102336 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 5 (Ultra/100)
wd0(piixide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA)
cd0(piixide0:0:1): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA)
boot device: <unknown>
root on md0a dumps on md0b
root file system type: ffs
warning: no /dev/console
init: Creating mfs /dev (412 blocks, 1024 inodes)
---8<---