[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Upgrade + ports question



Hello,

This is my first attempt at actually upgrading a system. Usually, it was quicker to simply reinstall from scratch but now that is not the case. So...

When I upgrade to from 3.7 -> 3.8, I know I have to update my ports as well. Before I do any "Oh My God!" blunders, I would like to see if I am missing anything.

I am running i386 3.7-release currently. Target is 3.8-stable. My plan so far:

1) Upgrade to OpenBSD 3.8 binary snapshots since 3.8 release will not be available for a few weeks.

2)fetch and build OpenBSD 3.8 -stable using the following FAQ as a guide.

http://www.openbsd.org/faq/faq5.html

3) Backup my existing /usr/ports

4) Update ports to 3.8-stable:

From: http://www.se.openbsd.org/anoncvs.html
 (modified for my shell/desired tag)

	# *export CVSROOT=anoncvs_(_at_)_anoncvs_(_dot_)_ca_(_dot_)_openbsd_(_dot_)_org:/cvs*
	# *cd /usr*
	# *cvs -q get -rOPENBSD_3_8 -P ports*


5) make; make install in /usr/ports/devel/jdk/... (yes, this is only for java)



Am I missing and/or doing anything wrong?

-Keith


OpenBSD 3.7 (GENERIC) #50: Sun Mar 20 00:01:57 MST 2005
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Athlon(tm) ("AuthenticAMD" 686-class) 1.20 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem = 1073258496 (1048104K)
avail mem = 972713984 (949916K)
using 4278 buffers containing 53764096 bytes (52504K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(56) BIOS, date 01/21/03, BIOS32 rev. 0 @ 0xfb520
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf94
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdef0/160 (8 entries)
pcibios0: PCI Exclusive IRQs: 5 10 11
pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8366 ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8366 PCI" rev 0x00
ppb0 at pci0 dev 1 function 0 "VIA VT8366 AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Matrox MGA G400/G450 AGP" rev 0x04
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"AT&T/Lucent FW322 1394" rev 0x61 at pci0 dev 10 function 0 not configured
ohci0 at pci0 dev 11 function 0 "NEC USB" rev 0x41: irq 11, version 1.0
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1 at pci0 dev 11 function 1 "NEC USB" rev 0x41: irq 11, version 1.0
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 11 function 2 "NEC USB" rev 0x02: irq 10
ehci0: EHCI version 0.95
ehci0: companion controllers, 3 ports each: ohci0 ohci1
usb2 at ehci0: USB revision 2.0
uhub2 at usb2
uhub2: NEC EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: single transaction translator
uhub2: 5 ports with 5 removable, self powered
"Texas Instruments ACX100A" rev 0x00 at pci0 dev 12 function 0 not configured
pciide0 at pci0 dev 13 function 0 "Promise PDC20265" rev 0x02: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using irq 10 for native-PCI interrupt
pciide0: channel 0 disabled (no drives)
pciide0: channel 1 disabled (no drives)
cmpci0 at pci0 dev 14 function 0 "C-Media Electronics CMI8738/C3DX Audio" rev 0x10: irq 11
audio0 at cmpci0
pcib0 at pci0 dev 17 function 0 "VIA VT8366 ISA" rev 0x00
pciide1 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA100, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide1 channel 0 drive 0: <WDC WD400BB-00CLB0>
wd0: 16-sector PIO, LBA, 38166MB, 78165360 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
pciide1: channel 1 disabled (no drives)
vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x70: irq 11 address 00:50:2c:01:b5:26
icsphy0 at vr0 phy 1: ICS1893 10/100 PHY, rev. 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0 (mux 1 ignored for console): console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
it0 at isa0 port 0x290/8: IT87
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ef65 netmask ef65 ttymask ffe7
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302