[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Slow Sparc Ultra 5



On 9/16/05, BadMagic <badmagic_(_at_)_bigpond_(_dot_)_net_(_dot_)_au> wrote:
> Hello,
> 
> I installed OpenBSD 3.7 (Sparc64) on my Ultra 5 and it's performance is not what I'd expected. I'd recently had Solaris on there (using CDE) and it ran quite quickly but with OpenBSD, when I do an 'ls -la', it takes forever for the screen to scroll through the list and try it via ssh! Slow. I'm using it as a Web server and it's noticably slower at serving pages than the old x86 I had doing the job before was.
> 
> Anyone know something about this?
> 
> Regards,
> sl
> 
> Here's it's dmesg (This took forEVER):
> /*--------------------8<---------------------
> 
> console is keyboard/display
> Copyright (c) 1982, 1986, 1989, 1991, 1993
>         The Regents of the University of California.  All rights reserved.
> Copyright (c) 1995-2005 OpenBSD. All rights reserved.  http://www.OpenBSD.org
> 
> OpenBSD 3.7 (RAMDISK) #344: Sun Mar 20 14:38:37 MST 2005
>     deraadt_(_at_)_sparc64_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/sparc64/compile/RAMDISK
> total memory = 134217728
> avail memory = 112893952
> using 819 buffers containing 6709248 bytes of memory
> bootpath: /pci_(_at_)_1f,0/pci_(_at_)_1,1/ide_(_at_)_3,0/cdrom_(_at_)_2,0:f
> mainbus0 (root): Sun Ultra 5/10 UPA/PCI (UltraSPARC-IIi 270MHz)
> cpu0 at mainbus0: SUNW,UltraSPARC-IIi @ 270 MHz, version 0 FPU
> cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 256K external (64 b/l)
> psycho0 at mainbus0 addr 0xfffc4000
> SUNW,sabre: impl 0, version 0: ign 7c0 bus range 0 to 2; PCI bus 0
> DVMA map: c0000000 to e0000000
> IOTDB: 10bb4000 to 10c34000
> pci0 at psycho0
> ppb0 at pci0 dev 1 function 1 vendor 0x108e product 0x5000 rev 0x11
> pci1 at ppb0 bus 1
> ebus0 at pci1 dev 1 function 0 vendor 0x108e product 0x1000 rev 0x01
> auxio0 at ebus0 addr 726000-726003, 728000-728003, 72a000-72a003, 72c000-72c003, 72f000-72f003
> power at ebus0 addr 724000-724003 ipl 37 not configured
> SUNW,pll at ebus0 addr 504000-504002 not configured
> sab0 at ebus0 addr 400000-40007f ipl 43: rev 3.2
> sabtty0 at sab0 port 0
> sabtty1 at sab0 port 1
> comkbd0 at ebus0 addr 3083f8-3083ff ipl 41: layout 34
> wskbd0 at comkbd0: console keyboard
> com0 at ebus0 addr 3062f8-3062ff ipl 42, mouse: ns16550a, 16 byte fifo
> ecpp at ebus0 addr 3043bc-3043cb, 30015c-30015d, 700000-70000f ipl 34 not configured
> fdthree at ebus0 addr 3023f0-3023f7, 706000-70600f, 720000-720003 ipl 39 not configured
> clock1 at ebus0 addr 0-1fff: mk48t59: hostid 809f8b30
> flashprom at ebus0 addr 0-fffff not configured
> SUNW,CS4231 at ebus0 addr 200000-2000ff, 702000-70200f, 704000-70400f, 722000-722003 ipl 35 ipl 36 not configured
> hme0 at pci1 dev 1 function 1 vendor 0x108e product 0x1001 rev 0x01: address 08:00:20:9f:8b:30
> nsphy0 at hme0 phy 1: DP83840 10/100 PHY, rev. 1
> hme0: using ivec 3021 for interrupt
> vgafb0 at pci1 dev 2 function 0 vendor 0x1002 product 0x4754 rev 0x9a
> wsdisplay0 at vgafb0: console (std, sun emulation), using wskbd0
> pciide0 at pci1 dev 3 function 0 vendor 0x1095 product 0x0646 rev 0x03: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI
> pciide0: using ivec 1820 for native-PCI interrupt
> wd0 at pciide0 channel 0 drive 0: <FUJITSU MPD3043AT>
> wd0: 16-sector PIO, LBA, 4125MB, 8448300 sectors
> wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
> atapiscsi0 at pciide0 channel 1 drive 0
> scsibus0 at atapiscsi0: 2 targets
> cd0 at scsibus0 targ 0 lun 0: <GoldStar, CD-ROM CRD-8240B, 1.24> SCSI0 5/cdrom removable
> cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
> ppb1 at pci0 dev 1 function 0 vendor 0x108e product 0x5000 rev 0x11
> pci2 at ppb1 bus 2
> pcons at mainbus0 not configured
> No counter-timer -- using %tick at 270MHz as system clock.
> rd0: fixed, 6144 blocks
> root on rd0a
> rootdev=0x500 rrootdev=0x3d00 rawdev=0x3d02
> 
> --------------------8<----------------------*/
> 
> 

I have no problems at all with pretty much the same system. The system
is running Xorg with fluxbox, and it works just fine. I have also
tried Solaris but that ran a lot slower, in some cases i was waiting
10 minutes for a a window to show up.

- Alexander

Here is the dmesg with at the bottom the time it took for the command
to execute.

console is keyboard/display
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2005 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 3.7 (GENERIC) #431: Sun Mar 20 14:10:02 MST 2005
    deraadt_(_at_)_sparc64_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/sparc64/compile/GENERIC
total memory = 134217728
avail memory = 110485504
using 819 buffers containing 6709248 bytes of memory
bootpath: /pci_(_at_)_1f,0/pci_(_at_)_1,1/ide_(_at_)_3,0/disk_(_at_)_0,0
mainbus0 (root): Sun Ultra 5/10 UPA/PCI (UltraSPARC-IIi 270MHz)
cpu0 at mainbus0: SUNW,UltraSPARC-IIi @ 270 MHz, version 0 FPU
cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 256K
external (64 b/l)
psycho0 at mainbus0 addr 0xfffc4000
SUNW,sabre: impl 0, version 0: ign 7c0 bus range 0 to 2; PCI bus 0
DVMA map: c0000000 to e0000000
IOTDB: bc0000 to c40000
pci0 at psycho0
ppb0 at pci0 dev 1 function 1 "Sun Simba PCI-PCI" rev 0x11
pci1 at ppb0 bus 1
ebus0 at pci1 dev 1 function 0 "Sun PCIO Ebus2" rev 0x01
auxio0 at ebus0 addr 726000-726003, 728000-728003, 72a000-72a003,
72c000-72c003, 72f000-72f003
power at ebus0 addr 724000-724003 ipl 37 not configured
SUNW,pll at ebus0 addr 504000-504002 not configured
sab0 at ebus0 addr 400000-40007f ipl 43: rev 3.2
sabtty0 at sab0 port 0
sabtty1 at sab0 port 1
comkbd0 at ebus0 addr 3083f8-3083ff ipl 41: layout 33
wskbd0 at comkbd0: console keyboard
com0 at ebus0 addr 3062f8-3062ff ipl 42, mouse: ns16550a, 16 byte fifo
lpt0 at ebus0 addr 3043bc-3043cb, 30015c-30015d, 700000-70000f ipl 34: polled
fdthree at ebus0 addr 3023f0-3023f7, 706000-70600f, 720000-720003 ipl
39 not configured
clock1 at ebus0 addr 0-1fff: mk48t59: hostid 809f07e3
flashprom at ebus0 addr 0-fffff not configured
audioce0 at ebus0 addr 200000-2000ff, 702000-70200f, 704000-70400f,
722000-722003 ipl 35 ipl 36: nvaddrs 0
audio0 at audioce0
hme0 at pci1 dev 1 function 1 "Sun HME" rev 0x01: address 08:00:20:9f:07:e3
nsphy0 at hme0 phy 1: DP83840 10/100 PHY, rev. 1
hme0: using ivec 3021 for interrupt
vgafb0 at pci1 dev 2 function 0 "ATI Mach64 GT" rev 0x9a
wsdisplay0 at vgafb0: console (std, sun emulation), using wskbd0
pciide0 at pci1 dev 3 function 0 "CMD Technology PCI0646" rev 0x03:
DMA, channel 0 configured to native-PCI, channel 1 configured to
native-PCI
pciide0: using ivec 1820 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <ST34321A>
wd0: 32-sector PIO, LBA, 4103MB, 8404830 sectors
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <COMPAQ, SC-148F, FA07> SCSI0 5/cdrom removable
wd1 at pciide0 channel 1 drive 1: <WDC AC12100L>
wd1: 16-sector PIO, LBA, 2051MB, 4201344 sectors
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
wd1(pciide0:1:1): using PIO mode 4, DMA mode 2
ppb1 at pci0 dev 1 function 0 "Sun Simba PCI-PCI" rev 0x11
pci2 at ppb1 bus 2
pcons at mainbus0 not configured
No counter-timer -- using %tick at 270MHz as system clock.
root on wd0a
rootdev=0xc00 rrootdev=0x1a00 rawdev=0x1a02
syncing disks... console is keyboard/display
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2005 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 3.7 (GENERIC) #431: Sun Mar 20 14:10:02 MST 2005
    deraadt_(_at_)_sparc64_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/sparc64/compile/GENERIC
total memory = 134217728
avail memory = 110485504
using 819 buffers containing 6709248 bytes of memory
bootpath: /pci_(_at_)_1f,0/pci_(_at_)_1,1/ide_(_at_)_3,0/disk_(_at_)_0,0
mainbus0 (root): Sun Ultra 5/10 UPA/PCI (UltraSPARC-IIi 270MHz)
cpu0 at mainbus0: SUNW,UltraSPARC-IIi @ 270 MHz, version 0 FPU
cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 256K
external (64 b/l)
psycho0 at mainbus0 addr 0xfffc4000
SUNW,sabre: impl 0, version 0: ign 7c0 bus range 0 to 2; PCI bus 0
DVMA map: c0000000 to e0000000
IOTDB: bc0000 to c40000
pci0 at psycho0
ppb0 at pci0 dev 1 function 1 "Sun Simba PCI-PCI" rev 0x11
pci1 at ppb0 bus 1
ebus0 at pci1 dev 1 function 0 "Sun PCIO Ebus2" rev 0x01
auxio0 at ebus0 addr 726000-726003, 728000-728003, 72a000-72a003,
72c000-72c003, 72f000-72f003
power at ebus0 addr 724000-724003 ipl 37 not configured
SUNW,pll at ebus0 addr 504000-504002 not configured
sab0 at ebus0 addr 400000-40007f ipl 43: rev 3.2
sabtty0 at sab0 port 0
sabtty1 at sab0 port 1
comkbd0 at ebus0 addr 3083f8-3083ff ipl 41: layout 33
wskbd0 at comkbd0: console keyboard
com0 at ebus0 addr 3062f8-3062ff ipl 42, mouse: ns16550a, 16 byte fifo
lpt0 at ebus0 addr 3043bc-3043cb, 30015c-30015d, 700000-70000f ipl 34: polled
fdthree at ebus0 addr 3023f0-3023f7, 706000-70600f, 720000-720003 ipl
39 not configured
clock1 at ebus0 addr 0-1fff: mk48t59: hostid 809f07e3
flashprom at ebus0 addr 0-fffff not configured
audioce0 at ebus0 addr 200000-2000ff, 702000-70200f, 704000-70400f,
722000-722003 ipl 35 ipl 36: nvaddrs 0
audio0 at audioce0
hme0 at pci1 dev 1 function 1 "Sun HME" rev 0x01: address 08:00:20:9f:07:e3
nsphy0 at hme0 phy 1: DP83840 10/100 PHY, rev. 1
hme0: using ivec 3021 for interrupt
vgafb0 at pci1 dev 2 function 0 "ATI Mach64 GT" rev 0x9a
wsdisplay0 at vgafb0: console (std, sun emulation), using wskbd0
pciide0 at pci1 dev 3 function 0 "CMD Technology PCI0646" rev 0x03:
DMA, channel 0 configured to native-PCI, channel 1 configured to
native-PCI
pciide0: using ivec 1820 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <ST34321A>
wd0: 32-sector PIO, LBA, 4103MB, 8404830 sectors
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <COMPAQ, SC-148F, FA07> SCSI0 5/cdrom removable
wd1 at pciide0 channel 1 drive 1: <WDC AC12100L>
wd1: 16-sector PIO, LBA, 2051MB, 4201344 sectors
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
wd1(pciide0:1:1): using PIO mode 4, DMA mode 2
ppb1 at pci0 dev 1 function 0 "Sun Simba PCI-PCI" rev 0x11
pci2 at ppb1 bus 2
pcons at mainbus0 not configured
No counter-timer -- using %tick at 270MHz as system clock.
root on wd0a
rootdev=0xc00 rrootdev=0x1a00 rawdev=0x1a02

real    0m0.033s
user    0m0.000s
sys     0m0.030s