[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ami0 and bioctl.



Hi all,

I've just upgraded to -current (3.8-beta, snapshots op August 16th) to try out the bioctl utility on my raid controller. However, when I try to access it, I always get the error "bioctl: bioc_ioctl() call failed":

# bioctl -Dhiv ami0
bioctl: cookie = 0xd0c56e80
bio_inq
bioctl: bioc_ioctl() call failed

# bioctl -Dhiv sd0
bioctl: cookie = 0x0
bio_inq
bioctl: bioc_ioctl() call failed

# bioctl -Dhiv -a get ami0
bioctl: cookie = 0xd0c56e80
bio_inq
bioctl: bioc_ioctl() call failed

Any ideas to what I might be doing wrong? The controller is a Dell PERC2/SC in `Mass Storage' mode. Full dmesg:

OpenBSD 3.8-beta (GENERIC.MP) #260: Tue Aug 16 07:20:51 MDT 2005
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel Pentium III ("GenuineIntel" 686-class, 512KB L2 cache) 499 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MM
X,FXSR,SSE
real mem = 268013568 (261732K)
avail mem = 237621248 (232052K)
using 3297 buffers containing 13504512 bytes (13188K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 02/13/03, BIOS32 rev. 0 @ 0xffe90
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfc7c0/176 (9 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371FB ISA" rev 0x00)
pcibios0: PCI bus #4 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0xc00 0xc9000/0x800 0xc9800/0x800
mainbus0: Intel MP Specification (Version 1.4) (DELL PowerEdge 81)
cpu0 at mainbus0: apid 1 (boot processor)
cpu0: apic clock running at 99 MHz
cpu1 at mainbus0: apid 0 (application processor)
cpu1: Intel Pentium III ("GenuineIntel" 686-class, 512KB L2 cache) 499 MHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MM
X,FXSR,SSE
mainbus0: bus 0 is type PCI
mainbus0: bus 1 is type PCI
mainbus0: bus 2 is type PCI
mainbus0: bus 3 is type PCI
mainbus0: bus 4 is type PCI
mainbus0: bus 5 is type ISA
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 11, 24 pins
ioapic0: misconfigured as apic 0, remapped to apic 2
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82440BX AGP" rev 0x00
ppb0 at pci0 dev 1 function 0 "Intel 82440BX AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Mach64 GD" rev 0x5c
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb1 at pci0 dev 2 function 0 "DEC 21152 PCI-PCI" rev 0x03
pci2 at ppb1 bus 2
ahc1 at pci2 dev 4 function 0 "Adaptec AIC-7890/1 U2" rev 0x00: apic 2 int 16 (i
rq 11)
scsibus0 at ahc1: 16 targets
ahc2 at pci2 dev 6 function 0 "Adaptec AIC-7860" rev 0x03: apic 2 int 16 (irq 11
)
scsibus1 at ahc2: 8 targets
cd0 at scsibus1 targ 5 lun 0: <NEC, CD-ROM DRIVE:466, 1.06> SCSI2 5/cdrom remova
ble
ppb2 at pci2 dev 10 function 0 "Intel i960 RP PCI-PCI" rev 0x05
pci3 at ppb2 bus 3
ami0 at pci2 dev 10 function 1 "Intel 80960RP ATU" rev 0x05: apic 2 int 18 (irq
10) Dell 466v2/32b
ami0: FW 3.00, BIOS v1.36, 16MB RAM
ami0: 1 channels, 16 targets, 1 logical drives
scsibus2 at ami0: 1 targets
sd0 at scsibus2 targ 0 lun 0: <AMI, Host drive #00, > SCSI2 0/direct fixed
sd0: 42840MB, 5461 cyl, 255 head, 63 sec, 512 bytes/sec, 87736320 sec total
scsibus3 at ami0: 16 targets
safte0 at scsibus3 targ 6 lun 0: <DELL, 1x6 U2W SCSI BP, 5.33> SCSI2 3/processor
fixed
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA, channel 0 wi
red to compatibility, channel 1 wired to compatibility
pciide0: channel 0 ignored (disabled)
pciide0: channel 1 ignored (disabled)
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01pci_intr_map: bus 0 d
ev 7 func 2 pin 4; line 5
pci_intr_map: no MP mapping found
isa_intr_establish: no MP mapping found
: irq 5
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82371AB Power" rev 0x02 at pci0 dev 7 function 3 not configured
xl0 at pci0 dev 12 function 0 "3Com 3c905 100Base-TX" rev 0x00: apic 2 int 22 (i
rq 14), address 00:60:08:78:35:0c
nsphy0 at xl0 phy 24: DP83840 10/100 PHY, rev. 1
ppb3 at pci0 dev 14 function 0 "DEC 21152 PCI-PCI" rev 0x03
pci4 at ppb3 bus 4
"Sun PCIO Ebus2" rev 0x01 at pci4 dev 0 function 0 not configured
hme0 at pci4 dev 0 function 1 "Sun HME" rev 0x01: address 08:00:20:e4:22:53
luphy0 at hme0 phy 1: LU6612 10/100 PHY, rev. 1
hme0: using apic 2 int 22 (irq 14) for interrupt
isp0 at pci4 dev 4 function 0 "QLogic ISP1020" rev 0x05: apic 2 int 17 (irq 5)
isp0: Polled Mailbox Command (0x2) Timeout
isp0: Polled Mailbox Command (0x34) Timeout
isp0: Polled Mailbox Command (0x8) Timeout
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ffff netmask ffff ttymask ffff
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: sd0 matches BIOS drive 0x80
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02


Thanks in advance!



Visit your host, monkey.org