[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Writes to samba server very, very slow



On Tue, Jul 19, 2005 at 01:28:17PM -0700, Gary Clemans-Gibbon wrote:
> A little bit more info,
> 
> i ran the following...
> >
> > .
> >
> $ ifconfig -m dc0 
> 
> dc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>         address: 00:50:bf:9c:62:e4
>         media: Ethernet autoselect (100baseTX full-duplex)
>         status: active
>         supported media:
>                 media none
>                 media 10baseT
>                 media 10baseT mediaopt full-duplex
>                 media 100baseTX
>                 media 100baseTX mediaopt full-duplex
>                 media autoselect
>         inet 192.168.20.3 netmask 0xffffff00 broadcast 192.168.20.255
>         inet6 fe80::250:bfff:fe9c:62e4%dc0 prefixlen 64 scopeid 0x1
> $ ifconfig dc0 media 100baseTX mediaopt full-duplex
> ifconfig: SIOCSIFMEDIA: Operation not permitted
> $ su
> Password:
> salyut# ksh
> # ifconfig dc0 media 100baseTX mediaopt full-duplex 
> 
> # ifconfig dc0 media 100baseTX
> # ifconfig dc0 media 10baseT
> # ifconfig dc0 media 100baseTX mediaopt full-duplex
> # ifconfig dc0 media 10baseT mediaopt full-duplex
> 
> It speeded up for the 10baseT setting. I ran through the rest of the 
> settings and now it seems hosed. I think I have thouroughly confused my 
> switch now. Obviously it goes without saying that I want it to work at 
> 100 not 10 but now it is really not working at all, like 30 minutes to 
> copy a 5 Mb file in either direction!
> 
> Not good :(

Reset your switch. Try 100baseTX half-duplex. If autonegiotion is
broken, and the switch is not manageable (to turn off autoneg), this may
be the best you can do.

Also, this may be obvious, but have you tried different cables?

-- 
stephen



Visit your host, monkey.org