[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problem with postgresql on sparc64 (lack of working socket?)



Hi list,
i've set up postgresql as usual and wanted to connect... but:
$ psql
psql: could not send startup packet: Broken pipe

Strange, ok... looking into the database log:
$ tail /var/postgresql/logfile  
LOG:  could not connect socket for statistics collector: Invalid
argument
LOG:  could not connect socket for statistics collector: Invalid
argument
LOG:  disabling statistics collector for lack of working socket
LOG:  database system was shut down at 2005-07-02 14:54:22 CEST
LOG:  checkpoint record is at 0/9DFE50
LOG:  redo record is at 0/9DFE50; undo record is at 0/0; shutdown TRUE
LOG:  next transaction ID: 536; next OID: 17142
LOG:  database system is ready
LOG:  setsockopt(TCP_NODELAY) failed: Protocol not available

This is a 3.7-stable GENERIC on sparc64, with 2 sysctls set:
kern.seminfo.semmni=256
kern.seminfo.semmns=2048

It's NOT dependent on the tcp listening socket as the same thing
happens without enabling tcp.

I also added the login class as stated in the install script... so i
don't think there's anything i've forgotten.
Any hints, ideas or something else i might have missed?

Regards,
Simon

P.S.: dmesg:
console is /pci_(_at_)_1f,0/pci_(_at_)_1,1/ebus_(_at_)_1/se_(_at_)_14,400000:a
Copyright (c) 1982, 1986, 1989, 1991, 1993
      The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2005 OpenBSD. All rights reserved.
 http://www.OpenBSD.org

OpenBSD 3.7-stable (GENERIC) #0: Tue Jun 28 21:22:59 CEST 2005
  janus_(_at_)_ultrafish_(_dot_)_errornet_(_dot_)_lan:/usr/src/sys/arch/sparc64/compile/GENERIC
total memory = 268435456
avail memory = 235143168
using 1638 buffers containing 13418496 bytes of memory
bootpath: /pci_(_at_)_1f,0/pci_(_at_)_1,1/ide_(_at_)_3,0/disk_(_at_)_0,0
mainbus0 (root): Sun Ultra 5/10 UPA/PCI (UltraSPARC-IIi 440MHz)
cpu0 at mainbus0: SUNW,UltraSPARC-IIi @ 440 MHz, version 0 FPU
cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 2048
 external (64 b/l)
psycho0 at mainbus0 addr 0xfffc4000
SUNW,sabre: impl 0, version 0: ign 7c0 bus range 0 to 2; PCI bus 0
DVMA map: c0000000 to e0000000
IOTDB: 11360000 to 113e0000
pci0 at psycho0
ppb0 at pci0 dev 1 function 1 "Sun Simba PCI-PCI" rev 0x13
pci1 at ppb0 bus 1
ebus0 at pci1 dev 1 function 0 "Sun PCIO Ebus2" rev 0x01
auxio0 at ebus0 addr 726000-726003, 728000-728003, 72a000-72a003,
 72c000-72c003, 72f000-72f003
power at ebus0 addr 724000-724003 ipl 37 not configured
SUNW,pll at ebus0 addr 504000-504002 not configured
sab0 at ebus0 addr 400000-40007f ipl 43: rev 3.2
sabtty0 at sab0 port 0: console i/o
sabtty1 at sab0 port 1
comkbd0 at ebus0 addr 3083f8-3083ff ipl 41: no keyboard
com0 at ebus0 addr 3062f8-3062ff ipl 42, mouse: ns16550a, 16 byte fifo
lpt0 at ebus0 addr 3043bc-3043cb, 30015c-30015d, 700000-70000f ipl 34:
 polled
fdthree at ebus0 addr 3023f0-3023f7, 706000-70600f, 720000-720003 ipl 39
 not configured
clock1 at ebus0 addr 0-1fff: mk48t59: hostid 80e767f0
flashprom at ebus0 addr 0-fffff not configured
audioce0 at ebus0 addr 200000-2000ff, 702000-70200f, 704000-70400f,
 722000-722003 ipl 35 ipl 36: nvaddrs 0
audio0 at audioce0
hme0 at pci1 dev 1 function 1 "Sun HME" rev 0x01: address
 08:00:20:e7:67:f0
nsphy0 at hme0 phy 1: DP83840 10/100 PHY, rev. 1
hme0: using ivec 3021 for interrupt
vgafb0 at pci1 dev 2 function 0 "ATI Mach64 GP" rev 0x5c
wsdisplay0 at vgafb0
wsdisplay0: screen 0 added (std, sun emulation)
pciide0 at pci1 dev 3 function 0 "CMD Technology PCI0646" rev 0x03: DMA,
 channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using ivec 1820 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <ST320414A>
wd0: 16-sector PIO, LBA, 19458MB, 39851760 sectors
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <LG, CD-ROM CRD-8322B, 1.05> SCSI0 5/cdrom
 removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
ppb1 at pci0 dev 1 function 0 "Sun Simba PCI-PCI" rev 0x13
pci2 at ppb1 bus 2
pcons at mainbus0 not configured
No counter-timer -- using %tick at 440MHz as system clock.
root on wd0a
rootdev=0xc00 rrootdev=0x1a00 rawdev=0x1a02



Visit your host, monkey.org