[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CARP i/f stuck in INIT when carpdev (dc) comes up



Did this work with a previous release or is this a new setup?

// Brad

On Thu, May 26, 2005 at 05:12:09PM +0100, Stephen Marley wrote:
> I have some boxes with dc (quad Znyx), xl and some virtual gre
> interfaces. Using CARP with dc's as the carpdev, the carp i/f sticks in
> INIT state when I take the physical i/f down and up. I need to ifconfig
> up the carp i/f itself to get it to return to MASTER state.
> 
> However, with the xl and gre interfaces, the carp device returns to
> MASTER when I bring the carpdev back up, which is what I'd expect.
> 
> Is there something about these dc's (or these old pcs) that makes them
> difficult for CARP?
> 
> OpenBSD 3.7-current (GENERIC) #126: Sun May 15 18:52:44 MDT 2005
>     deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: Intel Pentium/MMX ("GenuineIntel" 586-class) 199 MHz
> cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8,MMX
> cpu0: F00F bug workaround installed
> real mem  = 133804032 (130668K)
> avail mem = 115552256 (112844K)
> using 1658 buffers containing 6791168 bytes (6632K) of memory
> mainbus0 (root)
> bios0 at mainbus0: AT/286+(00) BIOS, date 08/27/97, BIOS32 rev. 0 @
> 0xffe90
> apm0 at bios0: Power Management spec V1.2
> apm0: AC on, battery charge unknown
> pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfc7b0/128 (6 entries)
> pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371FB ISA" rev
> 0x00)
> pcibios0: PCI bus #1 is the last bus
> bios0: ROM list: 0xc0000/0x8000
> cpu0 at mainbus0
> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
> pchb0 at pci0 dev 0 function 0 "Intel 82439TX System" rev 0x01
> pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x01
> pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
> channel
> 0 wired to compatibility, channel 1 wired to compatibility
> wd0 at pciide0 channel 0 drive 0: <Maxtor 83240D4>
> wd0: 16-sector PIO, LBA, 3089MB, 6328125 sectors
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
> atapiscsi0 at pciide0 channel 1 drive 0
> scsibus0 at atapiscsi0: 2 targets
> cd0 at scsibus0 targ 0 lun 0: <NEC, CD-ROM DRIVE:288, 3.04> SCSI0
> 5/cdrom re
> movable
> cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
> uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 11
> usb0 at uhci0: USB revision 1.0
> uhub0 at usb0
> uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered
> "Intel 82371AB Power Mgmt" rev 0x01 at pci0 dev 7 function 3 not
> configured
> ppb0 at pci0 dev 14 function 0 "DEC 21152 PCI-PCI" rev 0x03
> pci1 at ppb0 bus 1
> dc0 at pci1 dev 4 function 0 "DEC 21142/3" rev 0x41: irq 11, address
> 00:c0:9
> 5:e2:bd:90
> dcphy0 at dc0 phy 31: internal PHY
> dc1 at pci1 dev 5 function 0 "DEC 21142/3" rev 0x41: irq 11, address
> 00:c0:9
> 5:e2:bd:91
> dcphy1 at dc1 phy 31: internal PHY
> dc2 at pci1 dev 6 function 0 "DEC 21142/3" rev 0x41: irq 11, address
> 00:c0:9
> 5:e2:bd:92
> dcphy2 at dc2 phy 31: internal PHY
> dc3 at pci1 dev 7 function 0 "DEC 21142/3" rev 0x41: irq 9, address
> 00:c0:95
> :e2:bd:93
> dcphy3 at dc3 phy 31: internal PHY
> xl0 at pci0 dev 15 function 0 "3Com 3c905B 100Base-TX" rev 0x30: irq 9,
> addr
> ess 00:04:76:1a:19:cb
> exphy0 at xl0 phy 24: 3Com internal media interface
> vga1 at pci0 dev 16 function 0 "S3 Trio64V2/DX" rev 0x16
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> isa0 at pcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> sysbeep0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> npx0 at isa0 port 0xf0/16: using exception 16
> pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
> isapnp0 at isa0 port 0x279: read port 0x203
> sb1 at isapnp0 "Creative ViBRA16X PnP, CTL0043, , Audio" port
> 0x220/16,0x330
> /2,0x388/4 irq 5 drq 1,3: dsp v4.16
> midi1 at sb1: <SB MPU-401 UART>
> audio0 at sb1
> opl0 at sb1: model OPL3
> midi2 at opl0: <SB Yamaha OPL3>
> joy0 at isapnp0 "Creative ViBRA16X PnP, CTL7005, PNPB02F, Game" port
> 0x201/1
> biomask fd45 netmask ff45 ttymask ffc7
> pctr: 586-class performance counters and user-level cycle counter
> enabled
> dkcsum: wd0 matched BIOS disk 80
> root on wd0a
> rootdev=0x0 rrootdev=0x300 rawdev=0x302
> 
> -- 
> stephen_(_at_)_cl-is_(_dot_)_com