[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: em (Intel 1000GT) on 3.6



On Fri, Feb 18, 2005 at 06:17:17AM -0600, J.D. Bronson wrote:
> At 09:13 PM 02/17/2005, Kevin wrote:
> >On Thu, 17 Feb 2005 19:50:38 -0600, J.D. Bronson <jbronson_(_at_)_wixb_(_dot_)_com> wrote:
> >> No one replied to me, but for the record this Intel card
> >> does NOT work under 3.6-STABLE.
> >>
> >> it is detected by the kernel, but claims that the MAC address is invalid
> >> and wont enable the card.
> >
> >Interesting.  I am using various Intel PRO/1000 models under 3.6-Release
> >without any issues, including PRO/1000CT, MT, and MF (server adapters).
> >
> >Intel has a promotional "evaluation program", offering single units of 
> >various
> >products (including the GT) at reduced prices.
> 
> This is how I got this card...It uses a different controller
> (82541PI).It does not say it is supported on the em man page.
> 
> However, freebsd does support this and I had thought this driver was 
> 'shared' between these OSs. I bought it and it doesnt work. I can return 
> it, but dont mind hanging onto it...I would expect sooner or later OBSD 
> will support it.
> I just dont know who to ask about this as the man page refers me to 
> INTEL...I am sure someone within OBSD would be a contact ??
> 
> So I wanted to at least report back to the group that the Intell 1000GT 
> card does NOT work with 3.6-stable.

The driver is shared. A few changes went into -current from the FreeBSD
driver but not much and nothing that would affect cards based on the 82541
chipset. The chipset is supported. Can you please try a -current snap and
see if the situation improves? And yes our em man page needs a little bit
of syncing with FreeBSD' man page.

// Brad