[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

3.6 Release -> 3.6 Stable: FATAL: ... File truncated



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I'm trying to update from 3.6 release to stable, I followed the
different FAQ's:
I got stable from cvs, rebuild the kernel, rebooted, make obj and make
build. But the make build fails (see below). I tried it several times.
I even tried to first reinstall only libc because of the getcwd bug,
but no difference. Make build keeps failing and each time on a
different file.
It probably is my own fault because I can't find anything similar in
the mailinglists. I did however find similar things in freebsd and
linux lists, but it was all developer talk. But I'm not a programmer,
so if anyone knows the solution, please answer in laymens terms.

Thanx in advance,

Boris

One of the errors:

....
cc -O2   -DPTHREAD_KERNEL -D_POSIX_THREADS -D_THREAD_SAFE -Wall
- -Wpointer-arith -Wwrite-strings -Wstrict-prototypes
- -Wmissing-prototypes -Wsign-compare -I/usr/src/lib/libpthread/uthread
- -I/usr/src/lib/libpthread/include
- -I/usr/src/lib/libpthread/../libc/include -D_LOCK_DEBUG
- -D_PTHREADS_INVARIANTS -I/usr/src/lib/libpthread/arch/i386   -c -fpic
- -DPIC /usr/src/lib/libpthread/uthread/uthread_detach.c -o
uthread_detach.so
/tmp//ccW24234.s: Assembler messages:
/tmp//ccW24234.s:90: FATAL: can't close uthread_detach.so.o
: File truncated
*** Error code 1

Stop in /usr/src/lib/libpthread.
*** Error code 1

Stop in /usr/src/lib.
*** Error code 1

Stop in /usr/src (line 72 of Makefile).


My dmesg output:

OpenBSD 3.6-stable (GENERIC) #0: Wed Feb 16 18:37:37 CET 2005
~    root_(_at_)_openbsd_(_dot_)_bori_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Duron(tm) processor ("AuthenticAMD" 686-class) 698 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 267952128 (261672K)
avail mem = 237490176 (231924K)
using 3296 buffers containing 13500416 bytes (13184K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(fb) BIOS, date 10/24/01, BIOS32 rev. 0 @
0xfb1f0
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xb670
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdba0/160 (8 entries)
pcibios0: PCI Exclusive IRQs: 7 10 11 12
pcibios0: PCI Interrupt Router at 000:07:0 ("VIA VT82C596A ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x10000 0xd0000/0x4000! 0xd4000/0x1000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8363 Host" rev 0x02
ppb0 at pci0 dev 1 function 0 "VIA VT8363 AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Nvidia Vanta" rev 0x15
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0 "VIA VT82C686 ISA" rev 0x22
pciide0 at pci0 dev 7 function 1 "VIA VT82C571 IDE" rev 0x10: ATA66,
channel 0 configured to compatibility, channel 1 configured to
compatibility
wd0 at pciide0 channel 0 drive 0: <ST34321A>
wd0: 32-sector PIO, LBA, 4103MB, 8404830 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <ASUS, CD-S400/A, 1.00> SCSI0 5/cdrom
removable
cd0(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
uhci0 at pci0 dev 7 function 2 "VIA VT83C572 USB" rev 0x10: irq 10
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 7 function 3 "VIA VT83C572 USB" rev 0x10: irq 10
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
viaenv0 at pci0 dev 7 function 4 "VIA VT82C686 SMBus" rev 0x30
auvia0 at pci0 dev 7 function 5 "VIA VT82C686 AC97" rev 0x20: irq 7
ac97: codec id 0x83847609 (SigmaTel STAC9721/23)
ac97: codec features 18 bit DAC, 18 bit ADC, SigmaTel 3D
audio0 at auvia0
tl0 at pci0 dev 16 function 0 "Compaq Netelligent 10 T" rev 0x10: irq
10 address 00:80:5f:e5:58:83
ukphy0 at tl0 phy 31: Generic IEEE 802.3u media interface
ukphy0: OUI 0x100014, model 0x0001, rev. 5
fxp0 at pci0 dev 18 function 0 "Intel 82557" rev 0x08: irq 11, address
00:d0:b7:0a:f2:3d
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: density unknown
fd1 at fdc0 drive 1: density unknown
biomask f765 netmask ff65 ttymask ff67
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
open eacces vtyp=0
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCFelKfquIraS4V3ERAkthAJ98UdE0PA3Hi6wMhZaMl9LWibHOmgCfVJwL
XPyJnuNfNv4CNBqmllZbNdc=
=kjkt
-----END PGP SIGNATURE-----

[demime 1.01d removed an attachment of type APPLICATION/DEFANGED which had a name of boris.22937DEFANGED-vcf]