[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

macppc panic on port graphics/lcms with NFS-mounted PKGREPOSITORYBASE



Hi,

since I'm still suffering from traumatic post-xmas symptoms, I
hesitate to file a bug report ;-)

So here's what happened:

When building the port graphics/lcms on a -CURRENT macppc with
an NFS-mounted PKGREPOSITORYBASE, I get the following panic:

panic: vinvalbuf: flush failed
Stopped at	Debugger at 0x10:	lwz r0,20(r1)

Unfortunately, the keyboard is unresponsible, so I can't get trace
and ps output.

It happens when I do this:

$ cd /usr/ports/graphics/lcms
$ make install clean

It panics exactly here (reproducible):

===>  Building package for lcms-1.12
Creating package /var/ports/packages/macppc/all/lcms-1.12.tgz
Switching to /usr/ports/graphics/lcms/pkg/PFRAG.shared
Creating gzip'd tar ball in '/var/ports/packages/macppc/all/lcms-1.12.tgz'

The panic occurs only if /var/ports is NFS-mounted. (see my
mk.conf below)

When just /var/ports/distfiles NFS-mounted and /var/ports/packages
is on a local filesystem, everything's fine.

Also interesting: even if /var/ports (i.e. distfiles *and* packages)
comes from NFS, the package itself seems to be o.k. -- I compared
both results (NFS and local). The only difference is on liblcms.a
due to timestamps stored within the archive. The *contents* of the
liblcms.a archives on both builds are identical. Thus, the panic
seems to occur right after the package has been successfully written.

Here's /etc/mk.conf on the macppc box:

DISTDIR=/var/ports/distfiles
PKGREPOSITORYBASE=/var/ports/packages/macppc
BSDOBJDIR=/var/obj
SUDO=/usr/bin/sudo
CLEANDEPENDS=Yes

And here are the dmesgs for the macppc and the i386(NFS server):

[ using 291684 bytes of bsd ELF symbol table ]
console out [ATY,Jasper_A]console in [keyboard] USB and ADB found, using USB
using parent ATY,JasperParent:: memaddr b8000000 size 8000000, : consaddr b8008000, : ioaddr b0020000, size 20000: memtag 8000, iotag 8000: width 1280 linebytes 1280 height 854 depth 8
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2004 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 3.6-current (GENERIC) #24: Mon Dec 27 15:09:59 CET 2004
    kili_(_at_)_giggles_(_dot_)_outback_(_dot_)_escape_(_dot_)_de:/var/compile/GENERIC
real mem = 1073741824 (1048576K)
avail mem = 979656704 (956696K)
using 1254 buffers containing 53686272 bytes of memory
mainbus0 (root)
cpu0 at mainbus0: Version 8003 (Revision 101): 1333 MHz
memc0 at mainbus0: uni-n
mpcpcibr0 at mainbus0: uni-north, Revision 0xff
pci0 at mpcpcibr0 bus 0
pchb0 at pci0 dev 11 function 0 "Apple UniNorth AGP" rev 0x00
vgafb0 at pci0 dev 16 function 0 "ATI Radeon Mobility M10 NP" rev 0x00, mmio
wsdisplay0 at vgafb0: console (std, vt100 emulation)
mpcpcibr1 at mainbus0: uni-north, Revision 0x5
pci1 at mpcpcibr1 bus 0
pchb1 at pci1 dev 11 function 0 "Apple UniNorth PCI" rev 0x00
vendor "Broadcom", unknown product 0x4320 (class network subclass miscellaneous, rev 0x03) at pci1 dev 18 function 0 not configured
cbb0 at pci1 dev 19 function 0 "Texas Instruments PCI1510 CardBus" rev 0x00: irq 53
macobio0 at pci1 dev 23 function 0 "Apple Intrepid" rev 0x00
openpic0 at macobio0: version 0x4614
gpio_obio0 at macobio0
modem-reset at gpio_obio0 offset 0x1d not configured
modem-power at gpio_obio0 offset 0x1c not configured
gpio_obio1 at gpio_obio0 offset 0x9 irq 47
programmer-switch at gpio_obio0 offset 0x11 not configured
cpu-vcore-select at gpio_obio0 offset 0x6b not configured
gpio4 at gpio_obio0 offset 0x1e not configured
gpio5 at gpio_obio0 offset 0x6f not configured
gpio6 at gpio_obio0 offset 0x70 not configured
extint-gpio4 at gpio_obio0 offset 0x5c not configured
gpio11 at gpio_obio0 offset 0x75 not configured
extint-gpio15 at gpio_obio0 offset 0x67 not configured
zsc0 at macobio0: irq 22,23
zstty0 at zsc0 channel 0
zstty1 at zsc0 channel 1
adb0 at macobio0 irq 25: via-pmu 3 targets
aed0 at adb0 addr 0: ADB Event device
akbd0 at adb0 addr 2: iBook keyboard with inverted T (ISO layout)
wskbd0 at akbd0 mux 1
wskbd0: connecting to wsdisplay0
ams0 at adb0 addr 3: EMP trackpad <tpad> 4-button, 400 dpi
wsmouse0 at ams0 mux 0
abtn0 at adb0 addr 7: brightness/volume/eject buttons
apm0 at adb0: battery flags 0x5, 96% charged
ki2c0 at macobio0
wdc0 at macobio0 irq 24: DMA
atapiscsi0 at wdc0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, CD-RW CW-8123, CA0T> SCSI0 5/cdrom removable
cd0(wdc0:0:0): using BIOS timings, DMA mode 2
ohci0 at pci1 dev 24 function 0 "Apple Intrepid USB" rev 0x00: irq 0, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Apple OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ohci1 at pci1 dev 25 function 0 "Apple Intrepid USB" rev 0x00: irq 0, version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: Apple OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ohci2 at pci1 dev 26 function 0 "Apple Intrepid USB" rev 0x00: irq 29, version 1.0, legacy support
usb2 at ohci2: USB revision 1.0
uhub2 at usb2
uhub2: Apple OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhidev0 at uhub2 port 1 configuration 1 interface 0
uhidev0: Apple Computer product 0x1000, rev 2.00/15.86, addr 2, iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 (mux 1 ignored for console): console keyboard, using wsdisplay0
uhidev1 at uhub2 port 1 configuration 1 interface 1
uhidev1: Apple Computer product 0x1000, rev 2.00/15.86, addr 2, iclass 3/1
ums0 at uhidev1: 5 buttons
wsmouse1 at ums0 mux 0
ohci3 at pci1 dev 27 function 0 "NEC USB" rev 0x43: irq 63, version 1.0
usb3 at ohci3: USB revision 1.0
uhub3 at usb3
uhub3: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 3 ports with 3 removable, self powered
ohci4 at pci1 dev 27 function 1 "NEC USB" rev 0x43: irq 63, version 1.0
usb4 at ohci4: USB revision 1.0
uhub4 at usb4
uhub4: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
"NEC USB" rev 0x04 at pci1 dev 27 function 2 not configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 1 device 0 cacheline 0x8, lattimer 0x20
pcmcia0 at cardslot0
mpcpcibr2 at mainbus0: uni-north, Revision 0x6
pci2 at mpcpcibr2 bus 0
pchb2 at pci2 dev 11 function 0 "Apple UniNorth PCI" rev 0x00
kauaiata0 at pci2 dev 13 function 0 "Apple Intrepid ATA" rev 0x00
wdc1 at kauaiata0 irq 39: DMA
wd0 at wdc1 channel 0 drive 0: <FUJITSU MHT2060AT>
wd0: 16-sector PIO, LBA48, 57231MB, 117210240 sectors
wd0(wdc1:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 5
"Apple UniNorth Firewire" rev 0x81 at pci2 dev 14 function 0 not configured
gem0 at pci2 dev 15 function 0 "Apple GMAC Ethernet" rev 0x80: irq 41, address 00:0d:93:2d:f5:aa
ukphy0 at gem0 phy 0: Generic IEEE 802.3u media interface
ukphy0: OUI 0x005043, model 0x000c, rev. 1
bootpath: '/pci_(_at_)_f4000000/ata-6_(_at_)_d/disk_(_at_)_0/bsd'
boot device: wd0.
root on wd0a
rootdev=0x0 rrootdev=0xb00 rawdev=0xb02

NFS server (i386) [sorry for that UCK mess, I was too lazy to
reboot after fixing pcibios]:

OpenBSD 3.6-stable (GENERIC) #4: Mon Dec 27 09:04:21 CET 2004
    kili_(_at_)_petunia_(_dot_)_outback_(_dot_)_escape_(_dot_)_de:/var/compile/GENERIC
cpu0: AMD Athlon(TM) XP 2400+ ("AuthenticAMD" 686-class) 1.99 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 1073307648 (1048152K)
avail mem = 972640256 (949844K)
using 4278 buffers containing 53768192 bytes (52508K) of memory
User Kernel Config
UKC> find pcibios
241 pcibios0 at bios0 flags 0x0
UKC> change 241
241 pcibios0 at bios0 flags 0x0
change (y/n) ?
flags [0] ? 4
241 pcibios0 changed
241 pcibios0 at bios0 flags 0x4
UKC> quity\^H \^H
Continuing...
mainbus0 (root)
bios0 at mainbus0: AT/286+(bf) BIOS, date 04/21/04, BIOS32 rev. 0 @ 0xf1aa0
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x2162
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xd000 0xd0000/0x1800 0xd4000/0x400
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8377 PCI" rev 0x00
ppb0 at pci0 dev 1 function 0 "VIA VT8235 AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 vendor "ATI", unknown product 0x5964 rev 0x01
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
vendor "ATI", unknown product 0x5d44 (class display subclass miscellaneous, rev 0x01) at pci1 dev 0 function 1 not configured
bce0 at pci0 dev 9 function 0 "Broadcom BCM4401" rev 0x01: irq 5, address 00:e0:18:9a:2a:7d
ukphy0 at bce0 phy 1: Generic IEEE 802.3u media interface
ukphy0: OUI 0x001018, model 0x0036, rev. 0
pcscp0 at pci0 dev 14 function 0 "AMD 53c974 PCscsi-PCI" rev 0x10: irq 5
pcscp0: AM53C974, 40MHz, SCSI ID 7
pcscp0: SCSI bus reset
scsibus0 at pcscp0: 8 targets
cd0 at scsibus0 targ 0 lun 0: <PIONEER, DVD-ROM DVD-303R, 1.10> SCSI2 5/cdrom removable
cd1 at scsibus0 targ 2 lun 0: <TEAC, CD-R55S, 1.0J> SCSI2 5/cdrom removable
trm0 at pci0 dev 15 function 0 "Tekram DC-3x5U" rev 0x01: irq 5
scsibus1 at trm0: 8 targets
uhci0 at pci0 dev 16 function 0 "VIA VT83C572 USB" rev 0x80: irq 5
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 16 function 1 "VIA VT83C572 USB" rev 0x80: irq 5
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 16 function 2 "VIA VT83C572 USB" rev 0x80: irq 5
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 16 function 3 "VIA VT6202 USB 2.0" rev 0x82: irq 5
ehci0: EHCI version 1.0
ehci0: companion controllers, 2 ports each: uhci0 uhci1 uhci2
usb3 at ehci0: USB revision 2.0
uhub3 at usb3
uhub3: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
pcib0 at pci0 dev 17 function 0 "VIA VT8235 ISA" rev 0x00
pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA133, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <Maxtor 6Y080L0>
wd0: 16-sector PIO, LBA, 78167MB, 160086528 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
pciide0: channel 1 disabled (no drives)
auvia0 at pci0 dev 17 function 5 "VIA VT8233 AC97" rev 0x50: irq 5
ac97: codec id 0x414c4720 (Avance Logic ALC650)
ac97: codec features 20 bit DAC, 18 bit ADC, Realtek 3D
audio0 at auvia0
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ef65 netmask ef65 ttymask ffe7
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
umass0 at uhub3 port 4 configuration 1 interface 0
umass0: Iomega Optical USB 2.0 Drive, rev 2.00/0.01, addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets
cd2 at scsibus2 targ 1 lun 0: <LITE-ON, DVDRW SOHW-1633S, BS0C> SCSI0 5/cdrom removable
udsbr0 at uhub0 port 1
udsbr0: GemTek Corp USB FM Radio, rev 1.00/4.10, addr 2
radio0 at udsbr0

Ciao,
	Kili