[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Is yds on amd64 supported or not?



yds is listed as supported at http://www.openbsd.org/amd64.html#hardware

However, it's not in GENERIC.

http://www.openbsd.org/cgi-bin/cvsweb/~checkout~/src/sys/arch/amd64/conf/GENERIC?rev=1.39&content-type=text/plain

So is it really supported?

It works on my amd64 in 3.6 after enabling it and compiling a new kernel.

dmesg:

OpenBSD 3.6 (SKULD) #0: Tue Nov 23 22:39:07 EST 2004
    jdew_(_at_)_skuld_(_dot_)_yggdrasil_(_dot_)_ca:/usr/src/sys/arch/amd64/compile/SKULD
real mem = 1341714432 (1310268K)
avail mem = 1138520064 (1111836K)
using 22937 buffers containing 134377472 bytes (131228K) of memory
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: AMD Athlon(tm) 64 Processor 3200+, 2010.36 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0 "VIA K8HTB Host" rev 0x01
ppb0 at pci0 dev 1 function 0 "VIA K8HTB AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 vendor "ATI", unknown product 0x5964 rev 0x01
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
vendor "ATI", unknown product 0x5d44 (class display subclass miscellaneous, rev 0x01) at pci1 dev 0 function 1 not configured
yds0 at pci0 dev 9 function 0 "Yamaha 724F" rev 0x03: irq 10
ac97: codec id 0x574d4c00 (Wolfson WM9701A)
ac97: codec features 18 bit DAC, 18 bit ADC, No 3D Stereo
audio0 at yds0
"Brooktree BT878" rev 0x11 at pci0 dev 10 function 0 not configured
"Brooktree BT878 Audio" rev 0x11 at pci0 dev 10 function 1 not configured
uhci0 at pci0 dev 11 function 0 "VIA VT83C572 USB" rev 0x61: irq 11
uhci0: controller did not reset
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 11 function 1 "VIA VT83C572 USB" rev 0x61: irq 11
uhci1: controller did not reset
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 11 function 2 "VIA VT6202 USB 2.0" rev 0x63: irq 10
ehci0: EHCI version 1.0
ehci0: companion controllers, 2 ports each: uhci0 uhci1
usb2 at ehci0: USB revision 2.0
uhub2 at usb2
uhub2: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 4 ports with 4 removable, self powered
"VIA VT6306 FireWire" rev 0x46 at pci0 dev 11 function 3 not configured
ahc0 at pci0 dev 12 function 0 "Adaptec AHA-3960D U160" rev 0x01: irq 11
scsibus0 at ahc0: 16 targets
sd0 at scsibus0 targ 0 lun 0: <IBM, DCAS-34330W !#, S69D> SCSI2 0/direct fixed
sd0: 4134MB, 8205 cyl, 6 head, 171 sec, 512 bytes/sec, 8467200 sec total
sd1 at scsibus0 targ 1 lun 0: <IBM, DCAS-34330W !#, S69D> SCSI2 0/direct fixed
sd1: 4134MB, 8205 cyl, 6 head, 171 sec, 512 bytes/sec, 8467200 sec total
ahc1 at pci0 dev 12 function 1 "Adaptec AHA-3960D U160" rev 0x01: irq 10
scsibus1 at ahc1: 16 targets
ahc1: target 0 using 8bit transfers
ahc1: target 0 using asynchronous transfers
sd2 at scsibus1 targ 0 lun 0: <COMPAQPC, MAG3091LP, 1811> SCSI2 0/direct fixed
sd2: 8678MB, 5273 cyl, 20 head, 168 sec, 512 bytes/sec, 17773500 sec total
fxp0 at pci0 dev 13 function 0 "Intel 82557" rev 0x05: irq 10, address 00:08:c7:08:23:67
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 0
pciide0 at pci0 dev 15 function 0 "VIA VT82C571 IDE" rev 0x06: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus2 at atapiscsi0: 2 targets
cd0 at scsibus2 targ 0 lun 0: <TOSHIBA, DVD-ROM SD-R5112, X433> SCSI0 5/cdrom removable
cd0(pciide0:0:0): using PIO mode 4, DMA mode 2
atapiscsi1 at pciide0 channel 1 drive 0
scsibus3 at atapiscsi1: 2 targets
cd1 at scsibus3 targ 0 lun 0: <TOSHIBA, DVD-ROM SD-R5112, X433> SCSI0 5/cdrom removable
cd1(pciide0:1:0): using PIO mode 4, DMA mode 2
uhci2 at pci0 dev 16 function 0 "VIA VT83C572 USB" rev 0x81: irq 11
usb3 at uhci2: USB revision 1.0
uhub3 at usb3
uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
uhci3 at pci0 dev 16 function 1 "VIA VT83C572 USB" rev 0x81: irq 11
usb4 at uhci3: USB revision 1.0
uhub4 at usb4
uhub4: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
uhci4 at pci0 dev 16 function 2 "VIA VT83C572 USB" rev 0x81: irq 10
usb5 at uhci4: USB revision 1.0
uhub5 at usb5
uhub5: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub5: 2 ports with 2 removable, self powered
uhci5 at pci0 dev 16 function 3 "VIA VT83C572 USB" rev 0x81: irq 10
usb6 at uhci5: USB revision 1.0
uhub6 at usb6
uhub6: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub6: 2 ports with 2 removable, self powered
ehci1 at pci0 dev 16 function 4 "VIA VT6202 USB 2.0" rev 0x86: irq 5
ehci1: EHCI version 1.0
ehci1: companion controllers, 2 ports each: uhci2 uhci3 uhci4 uhci5
usb7 at ehci1: USB revision 2.0
uhub7 at usb7
uhub7: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub7: 8 ports with 8 removable, self powered
"VIA VT8237 ISA" rev 0x00 at pci0 dev 17 function 0 not configured
auvia0 at pci0 dev 17 function 5 "VIA VT8233 AC97" rev 0x60: irq 5
ac97: codec id 0x414c4780 (Avance Logic <80>)
ac97: codec features 20 bit DAC, 18 bit ADC, No 3D Stereo
audio1 at auvia0
pchb1 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb4 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
opl0 at yds0: model OPL3
midi0 at opl0: <DS-1 integrated Yamaha OPL3>
mpu at yds0 not configured
mpu at yds0 not configured
mpu at yds0 not configured
mpu at yds0 not configured
isa0 at mainbus0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
it0 at isa0 port 0x290/8: IT87
ahc0: target 0 using 16bit transfers
ahc0: target 0 synchronous at 20.0MHz, offset = 0xf
dkcsum: sd0 matched BIOS disk 80
ahc0: target 1 using 16bit transfers
ahc0: target 1 synchronous at 20.0MHz, offset = 0xf
dkcsum: sd1 matched BIOS disk 81
ahc1: target 0 using 16bit transfers
ahc1: target 0 synchronous at 20.0MHz, offset = 0x3f
dkcsum: sd2 matched BIOS disk 82
root on sd1a
rootdev=0x410 rrootdev=0xd10 rawdev=0xd12
uhidev0 at uhub4 port 1 configuration 1 interface 0
uhidev0: HP HP USB WHEEL MOUSE, rev 1.00/0.04, addr 2, iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.
wsmouse0 at ums0 mux 0




-- 
"Most moms teach their daughters how to run a house, but you?  You teach
yours the fine art of mass destruction."
      - Nabs - Goodbye is not forever

perl -le '$_="6110>374086;2064208213:90<307;55";tr[0->][ LEOR!AUBGNSTY];print'



Visit your host, monkey.org