[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Em driver fails on recent snap... urgent help needed! Anybody???



Anyone have any info on this problem I've got? Interfaces em1-em4 are still non-functional...

-- Robert


-------- Original Message --------

The system simply hangs, it locks up. I don't get dumped to ddb. A complete freeze. Now, this was with an older snapshot. I built -current yesterday morning and finally got around to playing with it today. It does the same as the most recent snapshot. It does NOT hang any longer, but the NIC just simply doesn't work. Pinging anything on the local network from any port on the quad port NIC results in "sendto: host is down" responses. "tcpdump -i em4 -n" should show me a variety of traffic, instead of shows nothing. No packets received.

Here is the dmesg. The devices in question are em1-em4. Again, the on-board NICs, em0 and em5, seem to work just fine.


OpenBSD 3.6-current (GENERIC) #0: Fri Oct 8 23:31:00 MDT 2004
root_(_at_)_fw1_(_dot_)_xxxxxxxxxxx_(_dot_)_com:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Celeron(R) CPU 2.40GHz ("GenuineIntel" 686-class) 2.40 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID
real mem = 1072197632 (1047068K)
avail mem = 971739136 (948964K)
using 4278 buffers containing 53710848 bytes (52452K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(90) BIOS, date 07/27/04, BIOS32 rev. 0 @ 0xfb830
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf64
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde60/240 (13 entries)
pcibios0: PCI Exclusive IRQs: 5 9 10 11 12
pcibios0: no compatible PCI ICU found: ICU vendor 0x8086 product 0x25a1
pcibios0: PCI bus #5 is the last bus
bios0: ROM list: 0xc0000/0x8000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82875P Host" rev 0x02
ppb0 at pci0 dev 1 function 0 "Intel 82875P AGP" rev 0x02
pci1 at ppb0 bus 1
ppb1 at pci0 dev 3 function 0 "Intel 82875P PCI-CSA" rev 0x02
pci2 at ppb1 bus 2
em0 at pci2 dev 1 function 0 "Intel PRO/1000CT (82547EI)" rev 0x00: irq 10, address: 00:30:48:80:d1:9a
ppb2 at pci0 dev 28 function 0 "Intel 6300ESB PCIX" rev 0x02
pci3 at ppb2 bus 3
ppb3 at pci3 dev 1 function 0 "IBM PCIX-PCIX" rev 0x02
pci4 at ppb3 bus 4
em1 at pci4 dev 4 function 0 "Intel PRO/1000MF QP (82546EB)" rev 0x01: irq 11, address: 00:04:23:45:fe:70
em2 at pci4 dev 4 function 1 "Intel PRO/1000MF QP (82546EB)" rev 0x01: irq 5, address: 00:04:23:45:fe:71
em3 at pci4 dev 6 function 0 "Intel PRO/1000MF QP (82546EB)" rev 0x01: irq 10, address: 00:04:23:45:fe:72
em4 at pci4 dev 6 function 1 "Intel PRO/1000MF QP (82546EB)" rev 0x01: irq 12, address: 00:04:23:45:fe:73
vendor "Marvell", unknown product 0x5041 (class mass storage subclass SCSI, rev 0x03) at pci3 dev 4 function 0 not configured
ppb4 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0x0a
pci5 at ppb4 bus 5
vga1 at pci5 dev 9 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
em5 at pci5 dev 10 function 0 "Intel PRO/1000MT (82541EI)" rev 0x00: irq 12, address: 00:30:48:80:d1:9b
ichpcib0 at pci0 dev 31 function 0 "Intel 6300ESB LPC" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 6300ESB IDE" rev 0x02: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD400JB-00FMA0>
wd0: 16-sector PIO, LBA, 38166MB, 78165360 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM SR244W, T01A> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
"Intel 6300ESB SMBus" rev 0x02 at pci0 dev 31 function 3 not configured
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
lm0 at isa0 port 0x290/8: W83627HF
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask e345 netmask ff65 ttymask ffe7
pctr: user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302



-- Robert



Visit your host, monkey.org