[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: midnight commander



On Monday 04 October 2004 04:09 pm, Kiraly Zoltan wrote:
>ray_(_at_)_gree_(_dot_)_org wrote:
>>Hi, I am new with OpenBSD, comming from Debian.
>>I try to find a way to install MC 4.5 on my machine but when I try to
>> compile it I have a message telling that the port is broken.
>>is someone knows how to fix this simply
>>many thanks
>>Raymond
>
>Ok, i think you have OpenBSD 3.5 on i386 machine.
>
>Step 1 : fetch this file :
>ftp.openbsd.org/pub/OpenBSD/3.5/packages/i386/glib-1.2.10.tgz  to
>OpenBSD box

The packages i had to install before compiling Midnight Commander were 
glib2-2.2.3.tgz and pkgconfig-0.15.0.tgz. I think glib2 also depends on 
gettext-0.10.40p1.tgz.

>Step 2 : fetch this file :
>http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-4.6.0.tar.g
>z to OpenBSD box
>
>Step 3 : on OpenBSD box type : pkg_add glib-1.2.10.tgz
>Step 4:  tar xvzf  mc-4.6.0.tar.gz

Step 4.5: cd mc-4.6.0

>Step 5:  ./configure && make && make install
>Step 6:  rehash
>
>Tell me if work..

-- 
------------------------------------------------------------------------
Dan Ramaley
Digital Media Library Specialist
(515) 271-1934
Cowles Library 140, Drake University