[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cross-tools compile for alpha fails



I am trying to compile the cross-tools for alpha, on a i386 machine,
howerver it fails pretty quick in trying to compile binutils. I typed
the following command on my shell:
$ sudo make cross-tools TARGET=alpha

I get the following error:
Making all in po
make: don't know how to make fr.po. Stop in
/usr/cross/alpha/usr/obj/gnu/usr.bin/binutils/bfd/po.
*** Error code 1

Stop in /usr/cross/alpha/usr/obj/gnu/usr.bin/binutils/bfd (line 437 of
Makefile).
*** Error code 1

Stop in /usr/cross/alpha/usr/obj/gnu/usr.bin/binutils/bfd (line 568 of
Makefile).
*** Error code 1

Stop in /usr/cross/alpha/usr/obj/gnu/usr.bin/binutils (line 1653 of Makefile).
*** Error code 1

Stop in /usr/src (line 196 of Makefile).

/usr/cross/alpha does exist, as you can see, and all the
obj.i386.alpha symlinks appear to be working. Now for the dmesg:

OpenBSD 3.6-current (GENERIC.MP) #0: Wed Sep 29 11:15:29 EDT 2004
    root_(_at_)_edge_(_dot_)_chrissa_(_dot_)_net:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 864 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 536449024 (523876K)
avail mem = 482529280 (471220K)
using 4278 buffers containing 26927104 bytes (26296K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 06/08/00, BIOS32 rev. 0 @ 0xffe90
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfc320/208 (11 entries)
pcibios0: PCI Interrupt Router at 000:15:0 ("ServerWorks ROSB4
SouthBridge" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000! 0xcc000/0x5e00
mainbus0: Intel MP Specification (Version 1.4) (DELL     POWEREDGE 9B)
cpu0 at mainbus0: apid 1 (boot processor)
cpu0: apic clock running at 132 MHz
cpu1 at mainbus0: apid 0 (application processor)
cpu1: Intel Pentium III ("GenuineIntel" 686-class) 864 MHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
mainbus0: bus 0 is type PCI   
mainbus0: bus 1 is type PCI   
mainbus0: bus 2 is type PCI   
mainbus0: bus 3 is type ISA   
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 11, 16 pins
ioapic0: misconfigured as apic 0, remapped to apic 2
ioapic1 at mainbus0: apid 3 pa 0xfec01000, version 11, 16 pins
ioapic1: misconfigured as apic 0, remapped to apic 3
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CNB20LE Host" rev 0x05
pchb1 at pci0 dev 0 function 1 "ServerWorks CNB20LE Host" rev 0x05
pci1 at pchb1 bus 2
ppb0 at pci0 dev 2 function 0 "Intel i960 RM PCI-PCI" rev 0x01
pci2 at ppb0 bus 1
ahc1 at pci2 dev 6 function 0 "Adaptec AIC-7880" rev 0x02: apic 3 int
14 (irq 10)
scsibus0 at ahc1: 8 targets
sd0 at scsibus0 targ 0 lun 0: <SEAGATE, ST52160N, 0285> SCSI2 0/direct fixed
sd0: 2069MB, 6536 cyl, 4 head, 162 sec, 512 bytes/sec, 4238282 sec total
cd0 at scsibus0 targ 5 lun 0: <NEC, CD-ROM DRIVE:466, 1.06> SCSI2
5/cdrom removable
aac0 at pci0 dev 2 function 1 "Dell PERC 2/Si" rev 0x01: apic 3 int 15 (irq 14)
aac0: i960RX 100MHz, 62MB, no battery support (5) Kernel 2.1-3
scsibus1 at aac0: 64 targets
sd1 at scsibus1 targ 0 lun 0: <Adaptec, Container #00, > SCSI2 0/direct fixed
sd1: 69421MB, 8850 cyl, 255 head, 63 sec, 512 bytes/sec, 142175250 sec total
fxp0 at pci0 dev 8 function 0 "Intel 82557" rev 0x08, i82559: apic 3
int 0 (irq 11), address 00:b0:d0:22:83:11
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
vga1 at pci0 dev 14 function 0 "ATI Mach64 GY" rev 0x7a
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 15 function 0 "ServerWorks ROSB4 SouthBridge" rev 0x4f
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 0 netmask 0 ttymask 0
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
ahc1: target 0 synchronous at 20.0MHz, offset = 0xf
dkcsum: sd0 matched BIOS disk 80
dkcsum: sd1 matched BIOS disk 81
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02

This is a DELL PowerEdge server, however I do not have physical access
to the machine at this point in the day, I will tomorrow. It is dual
pIII with half a gig of ram, running OpenBSD 3.6-current grabbed via
cvsup this morning, running the GENERIC.MP kernel asyou can see. I've
searched on marc.theaimsgroup.com and google, including
site:openbsd.org for cross-tools errors that are relative to mine,
have not found any yet. If this is more appropriate for tech@ or
alpha@, then tell me and I'll forward this to either of those lists as
I am also subscribed there. A side note: I've tried compiling
cross-tools for alpha on a athlon MP machine (only 1 processor thought
at the moment) and it also failed with the same error, and now that
I've gotten this error on two different boxes, oen with OPENBSD_3_6
tag and one with current tag, I thought I'd post to misc@

Jason



Visit your host, monkey.org