[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RP: i386 serial console question...



(Apologies early for the repost... it's been 2 days and I've yet to see the original show up)

I'm having an odd issue with my serial console that I don't with SSH... namely, arrow keys in vi result in extra garbage that is interpreted either as invalid commands or excess garbage (while in edit mode). FAQ 7.7 only goes into how to set them up :( I'm guessing it's likely the windows client not emulating vt100 properly, but don't have a means to test this. I'd like to get it working so I can switch SSH off. Salient details...

-Server-
OpenBSD 3.5-RELEASE on i386, GENERIC kernel.
tty00 "/usr/libexec/getty std.9600" vt100 on secure
sshd_flags=""

OpenBSD 3.5 (GENERIC) #34: Mon Mar 29 12:24:55 MST 2004
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium (P54C) ("GenuineIntel" 586-class) 171 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8
cpu0: F00F bug workaround installed
real mem = 100249600 (97900K)
avail mem = 86745088 (84712K)
using 1249 buffers containing 5115904 bytes (4996K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(c8) BIOS, date 02/26/97, BIOS32 rev. 0 @ 0xfb340
apm0 at bios0: Power Management spec V1.2
apm0: APM engage (device 1): power management disabled (1)
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xb804
pcibios0: PCI BIOS has 6 Interrupt Routing table entries
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371SB ISA" rev 0x00)
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82437VX" rev 0x02
pcib0 at pci0 dev 7 function 0 "Intel 82371SB ISA" rev 0x01
pciide0 at pci0 dev 7 function 1 "Intel 82371SB IDE" rev 0x00: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <Maxtor 91024U2>
wd0: 16-sector PIO, LBA, 9770MB, 20010816 sectors
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
pciide0: channel 1 ignored (disabled)
fxp0 at pci0 dev 9 function 0 "Intel 82557" rev 0x02: irq 15, address
00:a0:c9:77:80:0d
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 0
rl0 at pci0 dev 10 function 0 "Realtek 8139" rev 0x10: irq 11 address
00:08:a1:56:e1:6c
rlphy0 at rl0 phy 0: RTL internal phy
vga1 at pci0 dev 11 function 0 "S3 ViRGE DX/GX" rev 0x01
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom0: console
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 4040 netmask c840 ttymask c8c2
pctr: 586-class performance counters and user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

-Client-
WindowsXP SP1
Serial through Hyperterminal vt100 client, default settings
SSH through SSH Communications Security Corp non-commercial client
v3.2.9(283).



Visit your host, monkey.org