[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bgpd "set prepend-self" -- does it work?



In one of my bgp routers, I have a neighbor config like the following:

neighbor $somepeer {
        remote-as       $someas
        descr           "Bar Net"
        local-address   10.10.89.50
        #announce       self
#       tcp md5sig key  deadbeef
        set prepend-self 2
        set localpref 90
}

The BGP session is up, it announces our network, and incoming routes
are correctly tagged with a localpref of 90.

The outgoing announcement, however, doesn't have our AS-number
prepended to the AS-path as it should.

Am I doing something wrong here; e.g. should my prepend-self go
somewhere else?  Or is this a bug?

FWIW, "bgpd -n -v" shows the above config as:

neighbor 10.10.89.49 {
        descr "Bar Net"
        remote-as 34543
        local-address 10.10.89.50
        announce self
        set { localpref 90 }
}

I'm using a snapshot version of bgpd here, with the following
timestamp:

-r-xr-xr-x  1 root  bin  137748 Aug 10 19:34 /usr/sbin/bgpd

dmesg attached.

Also, somewhat related but far more esoteric: Is there a way, with
bgpd, to prepend a peer's AS-number to an incoming as-path?

-- 

Arvid

OpenBSD 3.6-beta (GENERIC) #7: Tue Aug 10 11:58:32 MDT 2004
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Duron(tm) processor ("AuthenticAMD" 686-class) 1.10 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 527998976 (515624K)
avail mem = 480903168 (469632K)
using 4278 buffers containing 26501120 bytes (25880K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(7a) BIOS, date 06/18/02, BIOS32 rev. 0 @ 0xfb200
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xb6a0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdc10/128 (6 entries)
pcibios0: PCI Exclusive IRQs: 3 5 10 11
pcibios0: PCI Interrupt Router at 000:07:0 ("VIA VT82C596A ISA" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xc000 0xcc000/0x10000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 vendor "VIA", unknown product 0x3112 rev 0x00
ppb0 at pci0 dev 1 function 0 vendor "VIA", unknown product 0xb112 rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Trident CyberBlade i1" rev 0x00
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0 "VIA VT82C686 ISA" rev 0x40
pciide0 at pci0 dev 7 function 1 "VIA VT82C571 IDE" rev 0x06: ATA100, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 1: <ST320011A>
wd0: 16-sector PIO, LBA, 19092MB, 39102336 sectors
wd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 5
pciide0: channel 1 disabled (no drives)
uhci0 at pci0 dev 7 function 2 "VIA VT83C572 USB" rev 0x1a: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 7 function 3 "VIA VT83C572 USB" rev 0x1a: irq 11
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
viaenv0 at pci0 dev 7 function 4 "VIA VT82C686 SMBus" rev 0x40
auvia0 at pci0 dev 7 function 5 "VIA VT82C686 AC97" rev 0x50: irq 5
ac97: codec id 0x414c4730 (Avance Logic <30>)
ac97: codec features Realtek 3D
audio0 at auvia0
ppb1 at pci0 dev 9 function 0 "DEC 21152 PCI-PCI" rev 0x03
pci2 at ppb1 bus 2
dc0 at pci2 dev 4 function 0 "DEC 21142/3" rev 0x41: irq 3, address 00:60:f5:08:85:64
lxtphy0 at dc0 phy 1: LXT971 10/100 media interface, rev. 1
dc1 at pci2 dev 5 function 0 "DEC 21142/3" rev 0x41: irq 5, address 00:60:f5:08:85:65
lxtphy1 at dc1 phy 1: LXT971 10/100 media interface, rev. 1
dc2 at pci2 dev 6 function 0 "DEC 21142/3" rev 0x41: irq 11, address 00:60:f5:08:85:66
lxtphy2 at dc2 phy 1: LXT971 10/100 media interface, rev. 1
dc3 at pci2 dev 7 function 0 "DEC 21142/3" rev 0x41: irq 10, address 00:60:f5:08:85:67
lxtphy3 at dc3 phy 1: LXT971 10/100 media interface, rev. 1
dc4 at pci0 dev 15 function 0 "ADMtek AN983" rev 0x11: irq 11, address 00:10:dc:61:f4:f6
ukphy0 at dc4 phy 1: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000749, model 0x0001, rev. 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask eb45 netmask ef6d ttymask ffef
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302