[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 3.5-release console lockup



Fabio Olive Leite wrote:

> On Wed, May 05, 2004 at 06:23:01PM +0300, Alexey E. Suslikov wrote:
>>     deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
>> pckbc0 at isa0 port 0x60/5
>> pckbd0 at pckbc0 (kbd slot)
>> pckbc0: using irq 1 for kbd slot
>> wskbd0 at pckbd0: console keyboard, using wsdisplay0
>> pms0 at pckbc0 (aux slot)
>> pckbc0: using irq 12 for aux slot
>> wsmouse0 at pms0 mux 0
>> pckbcintr: no dev for slot 1
> 
>>     deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/RAMDISK_CD
>> pckbc0 at isa0 port 0x60/5
>> pckbd0 at pckbc0 (kbd slot)
>> pckbc0: using irq 1 for kbd slot
>> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> 
> It seems the problem is somehow related to your ps/2 mouse port. The
> GENERIC kernel detects it and soon after spews a pckbcintr problem,
> most likely disabling interrupts for the keyboard driver.
> 
> The RAMDISK_CD kernel will not mess with the ps/2 port and then seems
> to work ok.
> 
> Perhaps you can try booting with the mouse unplugged, or if you don't
> have a mouse disable that ps/2 port in the BIOS' setup.

the appropriate 3.4 dmesg strings looks like:

pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0

so there is no "pckbcintr: no dev for slot 1" scream.

i should mention: this box is the notebook with aux port
and both onboard and external keyboards work fine on 3.4
and fail on 3.5 (i think both keyboard schematically
parallel).

i have tried another box with 3.5: keyboard works fine.

but Greg Thomas mention above:

> I reported this back at the beginning of April for a snapshot from the end
> of March.  Unfortunately it was a test machine and my original note to
> misc was woefully lacking in details.  I hadn't added users yet and I had
> turned off the ability to login as root via SSH.  I haven't had a chance
> to get back to troubleshoot it and get a dmesg from it.

so i think the keyboard driver was broken somewhere on the
path to the 3.5.

maybe developers have some ideas?

full 3.4 dmesg:

OpenBSD 3.4-stable (GENERIC) #0: Thu Nov 13 17:56:27 EET 2003
    root_(_at_)_localhost:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium III (Tualatin) ("GenuineIntel" 686-class) 1.07 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SIMD
real mem  = 259039232 (252968K)
avail mem = 234070016 (228584K)
using 3187 buffers containing 13053952 bytes (12748K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(6a) BIOS, date 03/05/02, BIOS32 rev. 0 @ 0xfd850
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xfd800/0x800
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdf10/208 (11 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB PCI-ISA" rev 0x00)
pcibios0: PCI bus #3 is the last bus
bios0: ROM list: 0xc0000/0xc600! 0xdf800/0x800! 0xe0000/0x4000!
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82830MP CPU to I/O Bridge 1" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82830MP Integrated Video" rev 0x03: aperture at 0xe8000000, size 0x8000000
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Intel 82830MP Integrated Video" rev 0x00 at pci0 dev 2 function 1 not configured
uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x01: irq 9
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801CA/CAM USB" rev 0x01: irq 5
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801CA/CAM USB" rev 0x01: irq 5
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ppb0 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x41
pci1 at ppb0 bus 1
"ESS ES2838/2839 SuperLink Modem" rev 0x01 at pci1 dev 2 function 0 not configured
esa0 at pci1 dev 3 function 0 "ESS ES1989" rev 0x12: irq 5
ac97: codec id 0x45838308 (ESS Technology ES1921)
ac97: codec features 20 bit DAC, 20 bit ADC, ESS Technology
audio0 at esa0
cbb0 at pci1 dev 4 function 0 "O2 Micro OZ6933 CardBus" rev 0x01: irq 9
cbb1 at pci1 dev 4 function 1 "O2 Micro OZ6933 CardBus" rev 0x01: irq 9
fxp0 at pci1 dev 8 function 0 "Intel PRO/100 VE" rev 0x41: irq 10, address 00:02:3f:35:02:d9
inphy0 at fxp0 phy 1: i82562ET 10/100 media interface, rev. 0
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 3 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
pcib0 at pci0 dev 31 function 0 "Intel 82801CAM LPC" rev 0x01
pciide0 at pci0 dev 31 function 1 "Intel 82801CAM IDE" rev 0x01: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <IC25N020ATDA04-0>
wd0: 16-sector PIO, LBA, 19077MB, 16383 cyl, 16 head, 63 sec, 39070080 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HITACHI, DVD-ROM GD-S250, 0012> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
"Intel 82801CA/CAM SMB" rev 0x01 at pci0 dev 31 function 3 not configured
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c260 netmask c660 ttymask d6e2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302



Visit your host, monkey.org