[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Slow net



I have a 8Mb Internet connection but since i installed a OpenBSD 3.4 Firewall i lose alot of speed. Used to have 800kB/s, now i only get 200kB/s. This is verified by switching the firewall.

This is a copy of my DMESG:

 OpenBSD 3.4 (GENERIC) #18: Wed Sep 17 03:34:47 MDT 2003
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: F00F bug workaround installed
cpu0: Intel Pentium/MMX ("GenuineIntel" 586-class) 166 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8,MMX
real mem  = 66695168 (65132K)
avail mem = 55967744 (54656K)
using 839 buffers containing 3436544 bytes (3356K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 09/09/97, BIOS32 rev. 0 @ 0xfd881
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0x10000
pcibios0: PCI BIOS has 6 Interrupt Routing table entries
pcibios0: PCI Interrupt Router at 000:01:0 ("Intel 82371SB PCI-ISA" rev 0x00)
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82437VX" rev 0x02
pcib0 at pci0 dev 1 function 0 "Intel 82371SB PCI-ISA" rev 0x01
pciide0 at pci0 dev 1 function 1 "Intel 82371SB IDE" rev 0x00: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALL_TM1700A>
wd0: 16-sector PIO, LBA, 1628MB, 3309 cyl, 16 head, 63 sec, 3335472 sectors
wd1 at pciide0 channel 0 drive 1: <Maxtor 6Y120P0>
wd1: 16-sector PIO, LBA, 117246MB, 16383 cyl, 16 head, 63 sec, 240121728 sectors
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
wd1(pciide0:0:1): using PIO mode 4, DMA mode 2
pciide0: channel 1 ignored (disabled)
uhci0 at pci0 dev 1 function 2 "Intel 82371SB USB" rev 0x01: irq 15
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
vga1 at pci0 dev 8 function 0 "Cirrus Logic CL-GD5446" rev 0x00
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
fxp0 at pci0 dev 10 function 0 "Intel 82557" rev 0x05: irq 11, address 00:a0:c9:e7:21:9a
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 0
rl0 at pci0 dev 11 function 0 "Realtek 8139" rev 0x10: irq 15 address 00:06:4f:01:e2:24
rlphy0 at rl0 phy 0: RTL internal phy
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask c040 netmask c840 ttymask c842
pctr: 586-class performance counters and user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
dkcsum: wd1 matched BIOS disk 81
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302


Netstat -ni:
Name    Mtu   Network     Address              Ipkts Ierrs    Opkts Oerrs Colls
lo0     33224 <Link>                              34     0       34     0     0
lo0     33224 127/8       127.0.0.1               34     0       34     0     0
lo0     33224 ::1/128     ::1                     34     0       34     0     0
lo0     33224 fe80::%lo0/ fe80::1%lo0             34     0       34     0     0
lo1*    33224 <Link>                               0     0        0     0     0
fxp0    1500  <Link>      00:a0:c9:e7:21:9a 33976805     2 24531034     0 414679
fxp0    1500  192.168.3/2 192.168.3.1       33976805     2 24531034     0 414679
fxp0    1500  fe80::%fxp0 fe80::2a0:c9ff:fe 33976805     2 24531034     0 414679
rl0     1500  <Link>      00:06:4f:01:e2:24 13419288     0 49878337     0     0
rl0     1500  fe80::%rl0/ fe80::206:4fff:fe 13419288     0 49878337     0     0
rl0     1500  213.113.68/ 213.113.68.188    13419288     0 49878337     0     0
pflog0  33224 <Link>                               0     0        0     0     0
pfsync0 1896  <Link>                               0     0        0     0     0
sl0*    296   <Link>                               0     0        0     0     0
sl1*    296   <Link>                               0     0        0     0     0
ppp0*   1500  <Link>                               0     0        0     0     0
ppp1*   1500  <Link>                               0     0        0     0     0
tun0*   3000  <Link>                               0     0        0     0     0
tun1*   3000  <Link>                               0     0        0     0     0
enc0    1536  <Link>                               0     0        0     0     0
bridge0 1500  <Link>                               0     0        0     0     0
bridge1 1500  <Link>                               0     0        0     0     0
vlan0*  1500  <Link>      00:00:00:00:00:00        0     0        0     0     0
vlan1*  1500  <Link>      00:00:00:00:00:00        0     0        0     0     0
gre0*   1450  <Link>                               0     0        0     0     0
gif0*   1280  <Link>                               0     0        0     0     0
gif1*   1280  <Link>                               0     0        0     0     0
gif2*   1280  <Link>                               0     0        0     0     0
gif3*   1280  <Link>                               0     0        0     0     0


load by uptime:
11:19AM  up 4 days, 21:26, 2 users, load averages: 0.08, 0.10, 0.19

Swapinfo:
-bash-2.05b# swapctl -l
Device      512-blocks     Used    Avail Capacity  Priority
swap_device     234401       64   234337     0%    0


I really want to run OpenBSD, but i really need help with the speed problem.

With best regards / Jimmy