[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

openbsd hostap and airport extreme



I found a post in the archive regarding an airport extreme not being able
to associate with an openbsd hostap. (I believe the OP was running 3.1)

I see the patch which made it into 3.3 that was supposed to fix this
problem, however I still cannot get a Mac with an airport extreme to
associate.

If I enable debugging on the wireless interface, this is the only output I
get:

	wihap_mgmt_input: len=13 MGMT: auth:

before the Mac informs me there were problems. I don't know how to get any
more debug information beyond that.

The same hardware works as expected in FreeBSD 5.1.

Here's the dmesg:

OpenBSD 3.3 (RAMDISK_CD) #40: Sat Mar 29 13:33:25 MST 2003
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/RAMDISK_CD
cpu0: AMD Duron Model 7 (Morgan) ("AuthenticAMD" 686-class) 1 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SIMD
real mem  = 100249600 (97900K)
avail mem = 87879680 (85820K)
using 1249 buffers containing 5115904 bytes (4996K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 02/06/02, BIOS32 rev. 0 @ 0xfdae0
apm0 at bios0: Power Management spec V1.2
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf8350/96 (4 entries)
pcibios0: PCI Interrupt Router at 000:01:0 ("SIS 85C503 PCI System I/O Chipset" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xc000 0xcc000/0x8000!
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "SIS 730 Host-PCI" rev 0x02
pciide0 at pci0 dev 0 function 1 "SIS 5513 EIDE" rev 0xd0: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD400BB-00CFC0>
wd0: 16-sector PIO, LBA, 38166MB, 16383 cyl, 16 head, 63 sec, 78165360 sectors
atapiscsi0 at pciide0 channel 0 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM FX54++W, U01H> SCSI0 5/cdrom removable
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
cd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 disabled (no drives)
pcib0 at pci0 dev 1 function 0 "SIS 85C503 PCI System I/O Chipset" rev 0x00
sis0 at pci0 dev 1 function 1 "SIS 900 10/100BaseTX" rev 0x82: irq 5 address 03:29:02:50:80:00
ukphy0 at sis0 phy 0: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000020, model 0x0020, rev. 1
ohci0 at pci0 dev 1 function 2 "SIS 5597/5598 USB" rev 0x07: irq 3, OHCI version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1 at pci0 dev 1 function 3 "SIS 5597/5598 USB" rev 0x07: irq 3, OHCI version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: vendor 0x0000 OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
"SIS 7018 Audio" rev 0x02 at pci0 dev 1 function 4 not configured
"SIS 7013 Modem" rev 0xa0 at pci0 dev 1 function 6 not configured
ppb0 at pci0 dev 2 function 0 "SIS 86C201 Host-AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "SIS 6300" rev 0x31
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wi0 at pci0 dev 11 function 0 "Netgear MA301" rev 0x02: irq 5
wi0: "SMC, SMC2532W-B EliteConnect Wireless Adapter, "
wi0: PRISM2.5 ISL3873, Firmware 1.1.0 (primary), 1.4.9 (station), address 00:04:e2:63:68:93
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 4048 netmask 4068 ttymask 406a
rd0: fixed, 3560 blocks
root on rd0a
rootdev=0x1100 rrootdev=0x2f00 rawdev=0x2f02
wihap_shutdown: sc=0xd07cc000 whi=0xd07ccfa4
Sending disassoc to sta ff:ff:ff:ff:ff:ff
Sending deauth to sta ff:ff:ff:ff:ff:ff
Sending disassoc to sta ff:ff:ff:ff:ff:ff
Sending deauth to sta ff:ff:ff:ff:ff:ff
Sending disassoc to sta ff:ff:ff:ff:ff:ff
Sending deauth to sta ff:ff:ff:ff:ff:ff
Sending disassoc to sta ff:ff:ff:ff:ff:ff
Sending deauth to sta ff:ff:ff:ff:ff:ff
Sending disassoc to sta ff:ff:ff:ff:ff:ff
Sending deauth to sta ff:ff:ff:ff:ff:ff
wihap_init: sc=0xd07cc000 whi=0xd07ccfa4
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth:
wihap_mgmt_input: len=13 MGMT: auth: