[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Mysterious Routing Problem



I just got a static ip address two days ago. Ever since I changed my ip information my computer has not been routing internet addresses correctly. The server is able to access the internet and I enabled port 53 for tcp and udp on my pf rules. here are some of my files.

/etc/hosts

127.0.0.1 localhost localhost.bryckwyndows.com
131.238.135.243  tyler tyler.bryckwyndows.com

/etc/resolv.conf

search udayton.edu
nameserver 131.238.75.165
nameserver 131.238.75.20
lookup file bind

/etc/mygate

131.238.135.1

/etc/hostname.xl0

inet 131.238.135.243 255.255.255.0 NONE

/etc/hostname.rl0

inet 10.1.1.1 255.255.255.0 NONE

xl0 = external interface
rl0 = internal interface
10.1.1.18 is a machine on the network

netstat -rn

Routing tables

Internet:
Destination Gateway Flags Refs Use Mtu Interface
default 131.238.135.1 UGS 17 520 - xl0
10.1.1/24 link#2 UC 0 0 - rl0
127/8 127.0.0.1 UGRS 0 0 33224 lo0
127.0.0.1 127.0.0.1 UH 3 44 33224 lo0
131.238.135/24 link#1 UC 0 0 - xl0
131.238.135.1 0:5:31:53:83:ff UHL 1 0 - xl0
131.238.135.243 127.0.0.1 UGHS 0 0 33224 lo0
224/4 127.0.0.1 URS 0 0 33224 lo0


route show

Routing tables

Internet:
Destination      Gateway            Flags
default          131.238.135.1      UG
10.1.1.0         link#2             U
127.0.0.0        127.0.0.1          UG
localhost        127.0.0.1          UH
131.238.135.0    link#1             U
131.238.135.1    0:5:31:53:83:ff    UH
tyler            127.0.0.1          UGH
224.0.0.0        127.0.0.1          U




Mike 



_________________________________________________________________
Protect your PC - get McAfee.com VirusScan Online http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963