[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

X11R6 and sparc64 help



Curious if anyone can help this noob out.
Attempting to run X on a sun AXi, just installed, but running into some trouble.
XF86Config was taken from the README in /usr/X11R6 for a single, accelerated
display from an ATI card.

On 'startx' I get:
(--) Using wscons driver

XFree86 Version 4.2.1 (for OpenBSD) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 3 September 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: OpenBSD 3.2  [ELF]
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Dec 26 05:27:58 2002
(==) Using config file: "/etc/X11/XF86Config"
Data incomplete in file /etc/X11/XF86Config
        Undefined InputDevice "wsmouse0" referenced by ServerLayout "wsfb".
(EE) Problem parsing the config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found



I assume the mouse was defined along with the sun keyboard (I am using type 5)
in the sample XFConfig given in the README

Here's my /etc/X11/XF86Config

Section "ServerLayout"
        Identifier      "wsfb"
        Screen  0       "Screen0" 0 0
        InputDevice    "wsmouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
    Load        "type1"
    Load        "freetype"
    Load        "glx"
    Load        "extmod"
EndSection
# All Sun keyboards (USB Type 6, Serial Type 3/4/5/6)
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "Protocol"    "wskbd"
        Option      "Device"      "/dev/wskbd0"
        Option      "XkbRules"    "xfree86"
        Option      "XkbLayout"   "us"
EndSection

# All monitors
Section "Monitor"
        Identifier   "Monitor"
        VendorName   "Unknown"
        ModelName    "Unknown"
# Adujst those to your monitor before using another device than wsfb
# or you can destroy it !!
        HorizSync    31-82
        VertRefresh  55-100
EndSection

# All framebuffers
Section "Device"
        Identifier      "Card0"
        Driver          "ati"
        BusID           "PCI:2:4:0"
        Option          "composite_sync" "True"
EndSection
# All framebuffers
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor"
        DefaultDepth 24
        SubSection "Display"
                Depth     8
                Modes   "640x480" "800x600" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes   "640x480" "800x600" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes   "640x480" "800x600" "1024x768"
        EndSubSection
EndSection
#
# EOF
#

And last but not least, my dmesg.  TIA for any help provided, and it is greatly
appreciated.
Jake

console is keyboard/display
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2002 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 3.2 (GENERIC) #8: Thu Oct  3 20:00:17 MDT 2002
    deraadt_(_at_)_sparc64_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/sparc64/compile/GENERIC
total memory = 536870912
avail memory = 489324544
using 3276 buffers containing 26836992 of memory
bootpath: /pci_(_at_)_1f,0/pci_(_at_)_1,0/scsi_(_at_)_1,0/disk_(_at_)_3,0
mainbus0 (root): SUNW,UltraSPARC-IIi-Engine
cpu0 at mainbus0: SUNW,UltraSPARC-IIi @ 300.101 MHz, version 0 FPU
cpu0: physical 32K instruction (32 b/l), 16K data (32 b/l), 512K external (64 b/
l)
psycho0 at mainbus0 addr 0xfffc0000
SUNW,sabre: impl 0, version 0: ign 7c0 bus range 0 to 128; PCI bus 0
IOTDB: 1eac000 to 1f2c000
pci0 at psycho0
ppb0 at pci0 dev 1 function 1 "Sun Simba PCI-PCI" rev 0x13
pci1 at ppb0 bus 1
ebus0 at pci1 dev 1 function 0 "Sun PCIO Ebus2" rev 0x01
auxio0 at ebus0 addr 726000-726003, 728000-728003, 72a000-72a003, 72c000-72c003,
 72f000-72f003
power at ebus0 addr 724000-724003 ipl 37 not configured
SUNW,pll at ebus0 addr 504000-504002 not configured
sab0 at ebus0 addr 400000-40007f ipl 43: rev 3.2
sabtty0 at sab0 port 0
sabtty1 at sab0 port 1
comkbd0 at ebus0 addr 3803f8-3803ff ipl 41: layout 34
wskbd0 at comkbd0: console keyboard
com0 at ebus0 addr 3602f8-3602ff ipl 42, mouse: ns16550a, 16 byte fifo
lpt0 at ebus0 addr 340278-340287, 30015c-30015d, 700000-70000f ipl 34: polled
fdthree at ebus0 addr 3203f0-3203f7, 706000-70600f, 720000-720003 ipl 39 not con
figured
clock0 at ebus0 addr 0-1fff: mk48t59: hostid 80a74472
flashprom at ebus0 addr 0-fffff not configured
beeper0 at ebus0 addr 722000-722003
hme0 at pci1 dev 1 function 1 "Sun HME" rev 0x01: address 08:00:20:a7:44:72
nsphy0 at hme0 phy 1: DP83840 10/100 media interface, rev. 1
hme0: using ivec 3021 for interrupt
ppb1 at pci0 dev 1 function 0 "Sun Simba PCI-PCI" rev 0x13
pci2 at ppb1 bus 128
siop0 at pci2 dev 1 function 0 "Symbios Logic 53c875" rev 0x14 using on-board RA
M ivec 20
scsibus0 at siop0: 16 targets
siop0: target 3 now using tagged 16 bit 20.0 MHz 15 REQ/ACK offset xfers
sd0 at scsibus0 targ 3 lun 0: <SEAGATE, ST34520W, 1444> SCSI2 0/direct fixed
sd0: 4340MB, 9006 cyl, 4 head, 246 sec, 512 bytes/sec, 8888924 sec total
siop1 at pci2 dev 1 function 1 "Symbios Logic 53c875" rev 0x14 using on-board RAM ivec 20
scsibus1 at siop1: 16 targets
siop1: target 6 now using 8 bit 20.0 MHz 8 REQ/ACK offset xfers
cd0 at scsibus1 targ 6 lun 0: <PLEXTOR, CD-R PX-W124TS, 1.04> SCSI2 5/cdrom remo
vable
vgafb0 at pci2 dev 4 function 0 "ATI Mach64 GV" rev 0x3a
wsdisplay0 at vgafb0: console (sun, sun emulation), using wskbd0
pcons at mainbus0 not configured
No counter-timer -- using %tick at 300MHz as system clock.
root on sd0a
rootdev=0x700 rrootdev=0x1100 rawdev=0x1102



Visit your host, monkey.org