[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Xfree86 and Thinkpad 770e



Hi All,

It would be nice if someone could give me a hand with my XF86config file.
The problem is the next :

- machine IBM Think Pad 770
- system installed OpenBSD 3.2-release

The problème :

The machine can do 1024x768 in 24bits (tested using win2000)

I set my Xfree config as below.
I results that X runs properly only in 8bits mode.
In 16 et 24bits mode X startx with error be results on showing
unproper colors (red shows as tan etc..)

If someone has a better XF86Config or any idea that could help me
*please* reply this message.

Thanks in advnce for your helps guys.

Thomas.


Section "Module"
    Load        "dbe"   # Double buffer extension

    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

    Load        "type1"
    Load        "freetype"
EndSection

Section "Files"
    RgbPath     "/usr/X11R6/lib/X11/rgb"
    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"


EndSection

Section "ServerFlags"

EndSection

Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "Keyboard"

    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc104"
    Option "XkbLayout"  "us"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "wsmouse"
    Option "Device"      "/dev/wsmouse"

EndSection

Section "Monitor"

    Identifier  "tomtom"
    HorizSync   31.5 - 57.0
    VertRefresh 50-70

EndSection


Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"
    Driver     "vga"

EndSection

# Device configured by xf86config:

Section "Device"
    Identifier  "toto"
    Driver      "trident"
    VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "toto"
    Monitor     "tomtom"
    DefaultDepth 8

    Subsection "Display"
        Depth       8
        Modes       "1024x768"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1024x768"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768"
        ViewPort    0 0
    EndSubsection
EndSection


Section "ServerLayout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection


my dmesg

OpenBSD 3.2 (GENERIC) #25: Thu Oct  3 19:51:53 MDT 2002
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache) 265 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 200716288 (196012K)
avail mem = 180285440 (176060K)
using 2475 buffers containing 10137600 bytes (9900K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(71) BIOS, date 09/17/99, BIOS32 rev. 0 @
0xfd820
apm0 at bios0: Power Management spec V1.2
apm0: battery life expectancy 0%
apm0: AC on, battery charge critical
apm0: battery life expectancy 0%
apm0: AC on, battery charge critical
apm0: battery life expectancy 0%
apm0: AC on, battery charge critical
pcibios0 at bios0: rev. 2.1 @ 0xfd880/0x800
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf9f90/96 (4 entries)
pcibios0: PCI Exclusive IRQs: 11
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371AB PIIX4 ISA" rev
0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xa000
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX" rev 0x02
cbb0 at pci0 dev 2 function 0 "Texas Instruments PCI1250 PCI-CardBus" rev
0x02: irq 11
cbb1 at pci0 dev 2 function 1 "Texas Instruments PCI1250 PCI-CardBus" rev
0x02: irq 11
vga1 at pci0 dev 3 function 0 "Trident CYBER 9397" rev 0xf3
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x01
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <IBM-DPLA-25120>
wd0: 16-sector PIO, LBA, 4887MB, 10592 cyl, 15 head, 63 sec, 10009440
sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <SANYO, CRD-S372B, 1.24> SCSI0 5/cdrom
removable
cd0(pciide0:1:0): using PIO mode 0, DMA mode 1
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82371AB Power Mgmt" rev 0x01 at pci0 dev 7 function 3 not
configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 1 device 0 cacheline 0x8, lattimer 0xb0
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 2 device 0 cacheline 0x8, lattimer 0xb0
pcmcia1 at cardslot1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
sb0 at isa0 port 0x220/24 irq 5 drq 1: dsp v3.02
midi0 at sb0: <SB MIDI UART>
audio0 at sb0
opl0 at sb0: model OPL3
midi1 at opl0: <SB Yamaha OPL3>
pcppi0 at isa0 port 0x61
midi2 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask c840 netmask c840 ttymask d842
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
dc0 at cardbus1 dev 0 function 0 irq 11 address 00:10:a4:f9:dd:9a
tqphy0 at dc0 phy 0: 78Q2120 10/100 media interface, rev. 10
Xircom, CardBus Ethernet 10/100 + Modem 56, CBEM56G, 1.03 (manufacturer
0x105, product 0x1000) vendor "Xircom", unknown product 0x103 (class
communications, subclass serial, rev 0x03) at cardbus1 dev 0 function 1
not configured



+-------------------------------------------------------+
       Thomas Serra
       tom_(_at_)_argol_(_dot_)_org
       www.argol.org
+-------------------------------------------------------+