[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

fetchmail doesn't work after upgrade to 3.2



I have just upgraded to 3.2 and everything seems to work fine (so far)
except fetchmail.  If I run it the way I ran it with 3.1:

 fetchmail -a xmission.com

I get this:

 fetchmail: client/server protocol error while fetching from xmission.com
 fetchmail: Query status=4 (PROTOCOL)

So I tried specifying IMAP because that's what AUTO selected before:

 fetchmail -v -v -p IMAP -a xmission.com

 fetchmail: 6.1.0 querying xmission.com (protocol IMAP) at Sun, 01 Dec
2002 10:47:07 -0700 (MST): poll started
 fetchmail: 6.1.0 querying xmission.com (protocol IMAP) at Sun, 01 Dec
2002 10:47:07 -0700 (MST): poll completed
 fetchmail: Query status=2 (SOCKET)
 fetchmail: Deleting fetchids file.
 fetchmail: normal termination, status 2
 fetchmail: Deleting fetchids file.

I also tried using POP3 just in case:

 fetchmail -v -v -p POP3 -a xmission.com

 fetchmail: 6.1.0 querying xmission.com (protocol POP3) at Sun, 01 Dec
2002 10:46:54 -0700 (MST): poll started
 fetchmail: POP3< Can't open perl script "/usr/local/sbin/fakepop":
Permission denied
 fetchmail: POP3> QUIT
 fetchmail: client/server protocol error while fetching from xmission.com
 fetchmail: 6.1.0 querying xmission.com (protocol POP3) at Sun, 01 Dec
2002 10:46:55 -0700 (MST): poll completed
 fetchmail: Query status=4 (PROTOCOL)
 fetchmail: Deleting fetchids file.
 fetchmail: normal termination, status 4
 fetchmail: Deleting fetchids file.

I did a find and couldn't find the "fakepop" file anywhere on the system.

I'm not using a ~/.fetchmailrc file (and I wasn't before).

Do I need to use fetchmail differently on 3.2 or do I have something set
up wrong now?

Thanks
  -Scott