[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

OpenBSD 3.2 and Adaptec 2940UW



Just to add to the confusion over the "OpenBSD 3.2 won't run with Adaptec 2940UW controllers" issue.....

I successfully installed 3.2 on my Pentium Pro box with an Adaptec 2940UW Pro controller. The default GENERIC kernel was stable long enough to allow me to fetch and build a 3.2-stable kernel and do a reboot with that newly built kernel. The box then ran successfully and error free through a make build.

The only hard drive in the box is on SCSI ID 0, the CD-ROM is on SCSI ID 5. There are no IDE devices in the box, the IDE controller is disabled in the BIOS.

The box is still up now.  Seems to be working great.

Dmesg follows....

OpenBSD 3.2-stable (GENERIC) #0: Sun Nov 17 16:18:49 CST 2002
root_(_at_)_bagel_(_dot_)_creamcheese_(_dot_)_lox:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium Pro ("GenuineIntel" 686-class, 256KB L2 cache) 233 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV
real mem = 167358464 (163436K)
avail mem = 149327872 (145828K)
using 2068 buffers containing 8470528 bytes (8272K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(5f) BIOS, date 02/18/97, BIOS32 rev. 0 @ 0xfb260
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xb724
pcibios0: PCI BIOS has 6 Interrupt Routing table entries
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371SB PCI-ISA" rev 0x00)
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x5800 0xce000/0x800
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82441FX" rev 0x02
pcib0 at pci0 dev 7 function 0 "Intel 82371SB PCI-ISA" rev 0x01
pciide0 at pci0 dev 7 function 1 "Intel 82371SB IDE" rev 0x00: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
pciide0: channel 0 ignored (disabled)
pciide0: channel 1 ignored (disabled)
ahc1 at pci0 dev 17 function 0 "Adaptec AHA-2940UWPro" rev 0x01: irq 15
ahc1: aic7880: Ultra Wide Channel A, SCSI Id=7, 16/255 SCBs
scsibus0 at ahc1: 16 targets
ahc1: target 0 synchronous at 20.0MHz, offset = 0x8
ahc1: target 0 using tagged queuing
sd0 at scsibus0 targ 0 lun 0: <IBM, DCHS09Y, 6464> SCSI2 0/direct fixed
sd0: 8678MB, 6082 cyl, 18 head, 162 sec, 512 bytes/sec, 17774160 sec total
ahc1: target 5 synchronous at 20.0MHz, offset = 0xf
cd0 at scsibus0 targ 5 lun 0: <PLEXTOR, CD-ROM PX-40TS, 1.12> SCSI2 5/cdrom removable
xl0 at pci0 dev 19 function 0 "3Com 3c905C 100Base-TX" rev 0x78: irq 11 address 00:01:03:df:0a:5f
exphy0 at xl0 phy 24: Broadcom 3C905C internal PHY, rev. 7
vga1 at pci0 dev 20 function 0 "S3 86C968-0 (Vision968)" rev 0x00
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 8040 netmask 8840 ttymask 88c2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: sd0 matched BIOS disk 80
root on sd0arootdev=0x400 rrootdev=0xd00 rawdev=0xd02