[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

3.2 pciide reboot



Hello,

I have recently installed 3.2 on my desktop machine (i386), but I had
to disable pciide via UKC in order to get floppy32 to boot.  If I
don't disable pciide, then the machine reboots after printing the
'wdx: no disk label' messages.  After installing and booting with the
installed kernel I still have to disable pciide or the machine reboots
at the same point.

I searched the archives, but I could not find anyone reporting similar
behaviour.  I have a Promise ATA 100TX2 card with 2 hard disks and a
cd writer hanging off it.  I also have onboard ide and a scsi card.
When I do boot with pciide enabled I see the Promise controller and
all the disks shown during the boot sequence.

Is there some kind of probe that is being done near the end of the
boot sequence that is causing the reboot?  Is there anything I can do
to boot with pciide?

dmesg below.

Thanks,
Cam


OpenBSD 3.2 (GENERIC) #25: Thu Oct  3 19:51:53 MDT 2002
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium III ("GenuineIntel" 686-class, 512KB L2 cache) 451 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SIMD
real mem  = 1073307648 (1048152K)
avail mem = 990474240 (967260K)
using 4278 buffers containing 53768192 bytes (52508K) of memory
User Kernel Config
UKC> disable pciide
 75 pciide* disabled
UKC> quit
Continuing...
mainbus0 (root)
bios0 at mainbus0: AT/286+(28) BIOS, date 07/30/99, BIOS32 rev. 0 @ 0xf06b0
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xf12
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf0e70/160 (8 entries)
pcibios0: PCI Interrupt Router at 000:04:0 ("Intel 82371FB PCI-ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x2000 0xcc000/0x4800 0xd4000/0x800
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX PCI-AGP" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP" rev 0x03
pci1 at ppb0 bus 1
pcib0 at pci0 dev 4 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
"Intel 82371AB IDE" rev 0x01 at pci0 dev 4 function 1 not configured
uhci0 at pci0 dev 4 function 2 "Intel 82371AB USB" rev 0x01: irq 9
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82371AB Power Mgmt" rev 0x02 at pci0 dev 4 function 3 not configured
emu0 at pci0 dev 9 function 0 "Creative Labs SoundBlaster Live" rev 0x07: irq 9
ac97: codec id 0x83847608 (SigmaTel STAC9708/11)
ac97: codec features 18 bit DAC, 18 bit ADC, SigmaTel 3D
audio0 at emu0
"Creative Labs SoundBlaster Live Digital Input" rev 0x07 at pci0 dev 9 function 1 not configured
"Promise PDC20268" rev 0x01 at pci0 dev 10 function 0 not configured
ahc1 at pci0 dev 11 function 0 "Adaptec AHA-2930CU" rev 0x03: irq 10
ahc1: NONE: Single Channel A, SCSI Id=7, 3/255 SCBs
scsibus0 at ahc1: 8 targets
ahc1: target 2 synchronous at 10.0MHz, offset = 0xf
sd0 at scsibus0 targ 2 lun 0: <HP, C3725S, 5153> SCSI2 0/direct fixed
sd0: 2047MB, 3703 cyl, 9 head, 125 sec, 512 bytes/sec, 4194058 sec total
ahc1: target 5 synchronous at 10.0MHz, offset = 0xf
ahc1: target 5 using tagged queuing
sd1 at scsibus0 targ 5 lun 0: <SEAGATE, ST39140W, 1281> SCSI2 0/direct fixed
sd1: 8683MB, 9006 cyl, 8 head, 246 sec, 512 bytes/sec, 17783240 sec total
ahc1: target 6 synchronous at 5.0MHz, offset = 0xb
st0 at scsibus0 targ 6 lun 0: <EXABYTE, EXB-85058SQANXR1, 0781> SCSI2 1/sequential removable
st0: drive empty
xl0 at pci0 dev 12 function 0 "3Com 3c905C 100Base-TX" rev 0x74: irq 11 address 00:01:02:65:20:aa
exphy0 at xl0 phy 24: Broadcom 3C905C internal PHY, rev. 6
vga1 at pci0 dev 13 function 0 "Matrox MGA G200 PCI" rev 0x01
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
wdc0 at isa0 port 0x1f0/8 irq 14
wd0 at wdc0 channel 0 drive 0: <WDC AC34300L>
wd0: 16-sector PIO, LBA, 4104MB, 8896 cyl, 15 head, 63 sec, 8406720 sectors
wd1 at wdc0 channel 0 drive 1: <QUANTUM FIREBALL EL5.1A>
wd1: 16-sector PIO, LBA, 4892MB, 10602 cyl, 15 head, 63 sec, 10018890 sectors
wd0(wdc0:0:0): using BIOS timings
wd1(wdc0:0:1): using BIOS timings
wdc1 at isa0 port 0x170/8 irq 15
wd2 at wdc1 channel 0 drive 0: <Maxtor 92041U4>
wd2: 16-sector PIO, LBA, 19541MB, 16383 cyl, 16 head, 63 sec, 40020624 sectors
atapiscsi0 at wdc1 channel 0 drive 1
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <PIONEER, DVD-ROM DVD-114, 1.10> SCSI0 5/cdrom removable
wd2(wdc1:0:0): using BIOS timings
cd0(wdc1:0:1): using BIOS timings
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c640 netmask ce40 ttymask dec2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: sd0 matched BIOS disk 85
dkcsum: sd1 matched BIOS disk 86
dkcsum: wd0 matched BIOS disk 80
wd1: no disk label
dkcsum: wd1 matched BIOS disk 81
wd2: no disk label
dkcsum: wd2 matched BIOS disk 82
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302