[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Oct 2 snapshot(i386), system lockup while acting as ftp server

(Nate cc'd)

I have several NexCom blade servers with 1 Intel 10/100 and 2 Broadcom
10/100/1000 NIC's.

I wanted to setup a test of the throughput of an OpenBSD bridge running
across through a GigE connected box.

Crappy line art follows describing the desired configuration:

Public          NexCom0      NexCom1                               Nexcom2
Network <-----> fxp0(pfnat)
( <==x==> fxp0(control ckt)( 
   ( <==x==> bge0(bridge int)
                             bge1(bridge int) <==x==> (

I'm installing the Oct 2 i386 snapshot.  1st installs goes fine to
NexCom0, then I download all the snapshot files to NexCom0 so the files
are local for NexCom1/NexCom2 installs.  I setup nat on NexCom0, what a
breeze, so my DNS stuff works.  Start install on NexCom1, I point it to
NexCom0 as the ftp source, downloads gets though ~40& of "base32.tgz" and
it stalls.  Go to NexCom0 and it's locked up hard, no response to
keyboard.  On this first install I let the cards auto negotiate, both the
bge0(NexCom0) and fxp0(NexCom1) set to 100/Full.  Power cycle Nexcom0,
force bge0(NexCom0) to 10/Half, reboot NexCom1, restart install on
NexCom1, everything works up to the download of "base32.tgz", it stalls at

So I never even get to the install of NexCom2.

I have seem some mail exchanges on the tech list related to the Broadcoms.
However nothing strictly related to systemlockup.

Hope this make sense.


NexCom Blade server dmesg

OpenBSD 3.2 (GENERIC) #24: Wed Oct  2 16:36:27 MDT 2002
cpu0: Intel Pentium III (Tualatin) ("GenuineIntel" 686-class) 1.14 GHz
real mem  = 1073262592 (1048108K)
avail mem = 990433280 (967220K)
using 4278 buffers containing 53764096 bytes (52504K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(e8) BIOS, date 01/29/02, BIOS32 rev. 0 @ 0xfb380
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xddb4
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdd30/128 (6 entries)
pcibios0: PCI Exclusive IRQs: 3 5 7 10 11
pcibios0: no compatible PCI ICU found
pcibios0: Warning, unable to fix up PCI interrupt routing
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0xac00
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CNB20LE Host" rev 0x06
pchb1 at pci0 dev 0 function 1 "ServerWorks CNB20LE Host" rev 0x06
pci1 at pchb1 bus 1
bge0 at pci1 dev 12 function 0 "Broadcom BCM5701" rev 0x15: irq 10: address:
brgphy0 at bge0 phy 1: BCM5701 10/100/1000baseTX PHY, rev. 0
bge1 at pci1 dev 13 function 0 "Broadcom BCM5701" rev 0x15: irq 11: address:
brgphy1 at bge1 phy 1: BCM5701 10/100/1000baseTX PHY, rev. 0
vga1 at pci0 dev 12 function 0 vendor "Chips and Technologies", unknown
product 0xc30 rev 0x61
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
fxp0 at pci0 dev 14 function 0 "Intel 82557" rev 0x08: irq 5, address
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
pcib0 at pci0 dev 15 function 0 "ServerWorks CSB5 SouthBridge" rev 0x92
"ServerWorks CSB5 IDE" rev 0x92 at pci0 dev 15 function 1 not configured
pchb2 at pci0 dev 15 function 3 "ServerWorks unknown SouthBridge" rev 0x00
pci2 at pchb2 bus 2
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
wdc0 at isa0 port 0x1f0/8 irq 14
wd0 at wdc0 channel 0 drive 0: <IC25N020ATDA04-0>
wd0: 16-sector PIO, LBA, 19077MB, 16383 cyl, 16 head, 63 sec, 39070080
wd0(wdc0:0:0): using BIOS timings
wdc1 at isa0 port 0x170/8 irq 15
atapiscsi0 at wdc1 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <NEC, CD-ROM DRIVE:282, 5.21> SCSI0 5/cdrom
cd0(wdc1:0:0): using BIOS timings
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c040 netmask cc60 ttymask cc62
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
WARNING: / was not properly unmounted

Visit your host, monkey.org