[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Promise Ultra133 TX2 fails with devices on second channel



A brief update, the same issue occurs if you use only the second channely on the drive, and also occurs if you use the primary channel of a second Ultra133 TX2 controller in the same system.

Scott

Scott Wells wrote:

I have a problem with my Promise Ultra133 TX2 controller. It's a Promise Ultra133 TX2 controller, uses the PDC20269 chipset. It works fine as long as I put no devices on the secondary channel. When I put a device on the second IDE channel, the boot process stops when dcksum attempts to match a BIOS disk to a physical device. If I leave the system along for a long period of time (~15 minutes +), a pciide timeout message comes up. dmesg is listed below. If any other information is needed, let me know...

Thanks,

Scott

OpenBSD 3.1 (GENERIC) #59: Sat Apr 13 15:28:52 MDT 2002
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Athlon Model 6 (Palomino) ("AuthenticAMD" 686-class) 1.74 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SIMD


real mem = 268001280 (261720K)
avail mem = 242708480 (237020K)
using 3297 buffers containing 13504512 bytes (13188K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(e5) BIOS, date 03/14/02, BIOS32 rev. 0 @ 0xf1a70
apm0 at bios0: Power Management spec V1.2 (BIOS mgmt disabled)
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0x2122
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf2050/208 (11 entries)
pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT82C586 PCI-ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xcc000/0x2800
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8366 Host-PCI" rev 0x00
ppb0 at pci0 dev 1 function 0 "VIA VT8366 PCI-AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Rage Fury" rev 0x00
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pciide0 at pci0 dev 12 function 0 "Promise PDC20269" rev 0x02: DMA, channel 0 configured to native-PCI, channel 1 configured to nati
ve-PCI
pciide0: using irq 12 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <ST380021A>
wd0: 16-sector PIO, LBA, 76319MB, 16383 cyl, 16 head, 63 sec, 156301488 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
sis0 at pci0 dev 14 function 0 "National Semiconductor DP83815 10/100" rev 0x00: irq 10 address 00:02:e3:05:c5:59
nsphyter0 at sis0 phy 0: DP83815 10/100 integrated, rev. 1
pcib0 at pci0 dev 17 function 0 vendor "VIA", unknown product 0x3147 rev 0x00
pciide1 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: DMA, channel 0 configured to compatibility, channel 1 configured to c
ompatibility
atapiscsi0 at pciide1 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
wdc_atapi_intr: warning: reading only 32 of 36 bytes
probe(atapiscsi0:0:0): Sense Error Code 5
atapiscsi0(pciide1:0:0): using PIO mode 4, DMA mode 2
pciide1: channel 1 ignored (disabled)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
biomask 5000 netmask 5400 ttymask 5402
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302



Visit your host, monkey.org