[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libc patch (resolver)



> which gives me on a 3.1 box :
> 
> /usr/bin/encrypt:       OpenBSD/i386 demand paged executable
> /usr/bin/gunzip:        OpenBSD/i386 demand paged executable
> /usr/bin/gzcat:         OpenBSD/i386 demand paged executable
> /usr/bin/gzip:          OpenBSD/i386 demand paged executable
> /usr/bin/kdump:         OpenBSD/i386 demand paged executable
> /usr/bin/ktrace:        OpenBSD/i386 demand paged executable
> /usr/sbin/chroot:       OpenBSD/i386 demand paged executable
> /usr/sbin/pwd_mkdb:     OpenBSD/i386 demand paged executable
> /usr/mdec/biosboot:     OpenBSD/i386 object file not stripped
> /usr/mdec/boot:         OpenBSD/i386 demand paged executable
> /usr/mdec/installboot:  OpenBSD/i386 demand paged executable
> /usr/mdec/mbr:          data
> /usr/libexec/makekey:   OpenBSD/i386 demand paged executable
> /usr/local/bin/bash:    OpenBSD/i386 demand paged executable

None of which, unless I'm missing some obscure feature, use the resolver  
in any way.  Just because it's compiled in doesn't mean they're
vulnerable.  (Right?)