[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Sound Distortion



Hi misc@,

Im attempting to get sound to work on my main machine. The sound card being a Game Theater XP. Everything seems to work, however the sound is *very* distorted. Ive searched through the archives on monkey.org and can find anything that matches my problem.

Im running -current compiled earlier today, so im nice and upto date. Ive also compiled my own kernel with just the required options for my card, but to no avail. Ive attached my dmesg, running a GENERIC kernel.

The only thing dodgy that I can see is:
   "reset_codec: AC97 inputs slot ready timeout" - but im not quite sure???

Does any one have any ideas?
Thanks
Chris
OpenBSD 3.1-beta (GENERIC) #1: Wed Apr 10 18:37:35 BST 2002
    root_(_at_)_scooby:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Athlon Model 4 (Thunderbird) ("AuthenticAMD" 686-class) 1.40 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 267956224 (261676K)
avail mem = 242671616 (236984K)
using 3296 buffers containing 13500416 bytes (13184K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(d6) BIOS, date 10/31/01, BIOS32 rev. 0 @ 0xfb430
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xdf54
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdec0/144 (7 entries)
pcibios0: PCI Exclusive IRQs: 5 11
pcibios0: no compatible PCI ICU found
pcibios0: Warning, unable to fix up PCI interrupt routing
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xc800
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8366 Host-PCI" rev 0x00
ppb0 at pci0 dev 1 function 0 "VIA VT8366 PCI-AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Nvidia GeForce2 MX" rev 0xb2
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
dc0 at pci0 dev 9 function 0 "Davicom Technologies DM9102" rev 0x31: irq 11 address 00:80:ad:72:fe:72
ukphy0 at dc0 phy 1: Generic IEEE 802.3u media interface
ukphy0: OUI 0x00606e, model 0x0004, rev. 0
bktr0 at pci0 dev 10 function 0 "Brooktree BT878" rev 0x11: irq 11
bktr0: Hauppauge Model 44805 C135
bktr0: Hauppauge WinCast/TV, Philips PAL I tuner.
"Brooktree BT878 (2nd device)" rev 0x11 at pci0 dev 10 function 1 not configured
clcs0 at pci0 dev 13 function 0 "Cirrus Logic CS4614" rev 0x01: irq 5
reset_codec: AC97 inputs slot ready timeout
ac97: codec id 0x4352592d (Cirrus Logic CS4294 rev 5)
ac97: codec features headphone, 20 bit DAC, 18 bit ADC, Crystal Semi 3D
audio0 at clcs0
pcib0 at pci0 dev 17 function 0 "VIA VT8366 PCI-ISA" rev 0x00
pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA100, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <Maxtor 96147H6>
wd0: 16-sector PIO, LBA, 58625MB, 16383 cyl, 16 head, 63 sec, 120064896 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <IDE, DVD-ROM 16X, 1.11> SCSI0 5/cdrom removable
atapiscsi1 at pciide0 channel 1 drive 1
scsibus1 at atapiscsi1: 2 targets
cd1 at scsibus1 targ 0 lun 0: <ATAPI, CD-R/RW 16X10, G.IF> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
cd1(pciide0:1:1): using PIO mode 4, DMA mode 2
uhci0 at pci0 dev 17 function 2 "VIA VT83C572 USB" rev 0x18: irq 5
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 17 function 3 "VIA VT83C572 USB" rev 0x18: irq 5
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 17 function 4 "VIA VT83C572 USB" rev 0x18: irq 5
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c860 netmask c860 ttymask d8e2
pctr: user-level cycle counter enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
uhub3 at uhub0 port 1
uhub3: Texas Instruments TUSB2046 hub, class 9/0, rev 1.10/1.25, addr 2
uhub3: 4 ports with 4 removable, self powered
ugen0 at uhub0 port 2
ugen0: Logitech Camera, rev 1.10/1.00, addr 3


Visit your host, monkey.org