[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using Drive: 0 Partition 3 .....



Greetings,

So, I could not boot off the hard disk (directly).  Rebooted the system
with the OpenBSD 3.0 CD-ROM in the drive, and at the boot prompt: 

     reading boot.......
     probing pc0 com0 com1 pci mem [639k 79m a20=on]
     disk hd0 fd0
     >> OpenBSD BOOT 1.28
     boot> boot sd0a:/bsd

Once the system is booted, I mounted the CD-ROM to /mnt:

# mount /dev/cd0a /mnt

Install BootEasy:

# fdisk -i -f /mnt/3.0/tools/booteasy/Boot.bin sd0

Halt, and after reboot, I've got:

F4 . . . ??
Default: F?

Pressed <F4>

reading boot....
probing: pc0 com0 com1 pci mem[639K 15M a20=on}
disk: fd0 hd0
>> OpenBSD/i386 BOOT 1.28
boot>
booting hd0a:/bsd: 3698688+327680+773316+[136392+169862]=0x5de91a start=0xe0100020
entry point at 0x100020

 pciinfo .....

Regards,

Ioan


Ioan Nemes wrote:
> 
> Greetings,
> 
> I've just installed OpenBSD 3.0 on a Compaq Prosigna 200 (System BIOS
> P05 12/30/1998), 300 MHZ PII, 128 MB RAM (no Compaq System Partition
> Utilities` are available on this system).  The system boots with the
> following SCSI/ATAPI/PCI/ISA components:
> 
> .....
> 
> siop0 at pci0 dev 13 function 0 "Symbios Logic 53c875" rev 0x04: irq 11 has RAM
> scibus0 at siop0: 16targets
> 
> .....
> 
> sd0at scsibus0targ0 lun0: <IBM, DPSS-318350N, S96H> SCSI3 0/direct fixed
> siop0: target 0 now using tagged 16 20 Mhz 16 REQ/ACK offset xfers
> sd0: 17501MB, 14627 cyl, 5 head, 490 sec, 512 bytes/sec, 35843670 sec total
> 
> .....
> 
> st0: at scsibus0 targ 2 lun0: <SONY, STD-7000, 0300> SCSI2
> 1/sequentialremovable
> st0: siop0: target 2 now using 8bit 10 Mhz 15 REQ/ACK offset xfers
> drive empty
> 
> .....
> 
> fxp0 at pci0 dev 11 function 0 "Intel 82557" rev 0x08: irq 10,
> address 00:90:27:8e:64:cf
> 
> .....
> 
> tl0 at pci0 dev 16 function 0 "Compaq Integrated NetFlex 3/P"
> rev qx10: irq 11 address  0:08:c7:5c:52:98
> 
> .....
> 
> vga1 at pci0 dev 12  function 0 "ATI Mach64 CT" rev 0x09
> wsdisplay0 at vga1: console (80x25, vt100 emulation)
> 
> .....
> 
> atapiscsi0 at pciide0channel 1 drive 0
> scsibus1 at atapiscsi0: 2targets
> cd0 at scsibus1 targ 0 lun 0: <COMPAQ, CRD-8241B, 1.17> SCSI0 5/cdrom removable
> cd0(pciide0:1:0):using PIO mode 4
> 
> .....
> 
> pckbd0 at isa0 port 0x60/5
> pckbd0 at pckbdc0 port (kbd slot)
> pckbd0: using irq 1 for kbd slot
> wskbd at pckbd0: console keyboard, using wsdisplay0
> 
> .....
> 
> pccom0 at isa0 port 0x3f8/8 irq4: ns16550a, 16 byte fifo
> 
> pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> 
> .....
> 
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2head, 18 sec
> 
> .....
> 
> fdisk:
> 
> fdisk /dev/rsd0c
> Disk: /dev/rsd0c        geometry: 2231/255/63 [35841015 sectors]
> Only LBA values are valid in ending cylinder for partition #3.
> Offset: 0       Signatures: 0xAA55,0x0
> 
>                 Starting                Ending
>  #:     id      cyl     hd      sec  -  cyl     hd      sec [start -    size]
>  0:     00      0       0       0     - 0       0       0   [   0   -   0]      unused
>  1:     00      0       0       0     - 0       0       0   [   0   -   0]      unused
>  2:     00      0       0       0     - 0       0       0   [   0   -   0]      unused
> *3      A6      0       1       1     - 1023    254     63  [   63 -35840952]   OpenBSD
> 
> disklabel/mount points:
> 
> > p
> device: /dev/rsd0c
> type: SCSI
> disk: SCSI disk
> label: DPSS-318350N
> bytes/sector: 512
> sectors/track: 490
> Tracks/cylinder: 5
> sectors/cylinder: 2450
> cylinders: 14627
> total sectors: 35843670
> free sectors: 0
> rpm 3600
> 
> 16 partitions:
> 
> #       size            offset          fstype  [fsize  bsize   cpg]
> a:      4194337         63              4.2BSD  1024    8192    16   #  /
> b:      1048600         4194400         swap
> c:      35843670        0               unused  0       0
> d:      1048600         5243000         4.2BSD  1024    8192    16   #  /tmp
> e:      8388800         6291600         4.2BSD  1024    8192    16   #  /usr
> f:      8388800         14680400        4.2BSD  1024    8192    16   #  /usr/local
> g:      8388800         23069200        4.2BSD  1024    8192    16   #  /var
> h:      4383015         31458000        4.2BSD  1024    8192    16   #  /home
> 
> .....
> 
> After halt/reboot I am getting the following message:
> 
>         Using Drive: 0 Partition: 3
> 
> however, OpenBSD (3.0) is not loading.
> 
> Any suggestions, please?
> 
> Regards,
> 
> Ioan


Visit your host, monkey.org