[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: -current ports dependencies broke? Re: -current ports dependencies broke? Re: -current ports dependencies broke?



I would like to ask why couldnt a method similar to
what NetBSD has/uses be used but I have seen at least
one reason on the mailing list archives (however there
may be more reasons why this is not a good idea). The
post basically stated that it was dangerous to remove
a package not knowing if the new package would A)
build correctly and B) install properly. I understand
this point but I have two suggestions on this point .
The first is I believe it would be better to have the
option at least on an "expirimental" basis until
something else is worked out(use at your own risk
kinda thing). Secondly perhaps make use of someting
similar to what Suse Linux uses with its version of
rpm. What this does is whenever you remove a package
(rpm) you are prompted if you want to make a backup to
/var/admin/backup (which can be restored later if
problems arise). Granted there is still an issue of
prompting but  this could be overridden perhaps in a
config file. Anyway these are just a couple
suggestions. Thanks.

Justin

--- Peter Valchev <pvalchev_(_at_)_beryl_(_dot_)_sightly_(_dot_)_net> wrote:
> Yes, it is being thought about, and even worked on.
> 
> It is hard.
> 
> It is not done yet.
> 
> > From m0rph13_(_at_)_yahoo_(_dot_)_com Wed Oct 24 19:08:54 2001
> > Date: Wed, 24 Oct 2001 18:09:50 -0700 (PDT)
> > From: justin <m0rph13_(_at_)_yahoo_(_dot_)_com>
> > Reply-To: m0rph13_(_at_)_yahoo_(_dot_)_com
> > Subject: Re: -current ports dependencies broke?
> > To: Peter Valchev <pvalchev_(_at_)_sightly_(_dot_)_net>
> > In-Reply-To:
> <20011024185206_(_dot_)_A12024_(_at_)_beryl_(_dot_)_sightly_(_dot_)_net>
> > MIME-Version: 1.0
> > Content-Type: text/plain; charset=us-ascii
> >
> > Yes, I had just found this. Thank you. This brngs
> me
> > to the question of upgrades. I had seen on some
> old
> > posts that a more automated upgrade procedure was
> > being worked on anyone know the status? thanks.
> >
> > Justin
> >
> > --- Peter Valchev <pvalchev_(_at_)_sightly_(_dot_)_net> wrote:
> > > > /usr/ports/packages/i386/All/qt2-3.1.tgz
> > > > pkg_add(qt2-3.1): add of dependency
> `libmng-1.0.1'
> > > > failed!
> > > > *** Error code 1
> > > 
> > > Remove the old version of the respective package
> > first.
> > Make a great connection at Yahoo! Personals.
> > http://personals.yahoo.com
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com