[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

arpresolve say: "can't allocate llinfo"



Hello friends,

  I have a multihomed OpenBSD (2.9). The interface xl0 have a netblock /28,
and I need put several machines of the same netblock in the other side 
(interface xl1) with proxy-arp, of course. So, I begin to add routes for 
machines in the Xl1 side:


// begin session ------------------------------------------------------

# route -n flush

# r
Routing tables

Internet:
Destination      Gateway            Flags
127.0.0.1        127.0.0.1          UH
194.140.67.224   link#1             U  

# ifconfig xl1 10.1.1.1 up netmask 255.255.255.0 media 100baseTX mediaopt
full-duplex arp

# ifconfig -a
lo0: flags=8009<UP,LOOPBACK,MULTICAST> mtu 32972
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
        inet6 ::1 prefixlen 128
        inet 127.0.0.1 netmask 0xff000000
lo1: flags=8008<LOOPBACK,MULTICAST> mtu 32972
xl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        media: Ethernet 10baseT
        status: active
        inet 194.140.67.235 netmask 0xfffffff0 broadcast 194.140.67.239
        inet6 fe80::210:5aff:fe41:e9bb%xl0 prefixlen 64 scopeid 0x1
xl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        media: Ethernet 100baseTX full-duplex
        status: active
        inet6 fe80::210:4bff:fe62:4401%xl1 prefixlen 64 scopeid 0x2
        inet 10.1.1.1 netmask 0xffffff00 broadcast 10.1.1.255
enc0: flags=0<> mtu 1536
bridge0: flags=0<> mtu 1500
bridge1: flags=0<> mtu 1500  

# route add -host 194.140.67.234 10.1.1.1 -interface  
Jun 14 15:56:50 beast /bsd: arp_rtrequest: bad gateway value
add host 194.140.67.234: gateway 10.1.1.1

# r
Routing tables

Internet:
Destination      Gateway            Flags
10.1.1.0         link#2             U
127.0.0.1        127.0.0.1          UH
194.140.67.224   link#1             U   
194.140.67.234   10.1.1.1           UH

# ping -c 3 194.140.67.234
Jun 14 15:57:10 beast /bsd: arpresolve: can't allocate llinfo 
PING 194.140.67.234 (194.140.67.234): 56 data bytes
--- 194.140.67.234 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss  

// end session --------------------------------------------------------

*** please note the syslog messages

at the same time I run "tcpdump -n -e -i xl1", but nothing is printed,
no arp request are put on the wire. Any Idea???

regards,

-- 
-----BEGIN GEEK CODE BLOCK-----
Version: 3.1
GCS d- s+: a- C+++ UL++++$ P+ L+++ E--- W++ N+ o K- w---
O+ M+ V- PS PE+ Y PGP+>+++ t+ 5 X+++ R- tv@ b+++ DI-- D+++
G e- h++ !r !z
------END GEEK CODE BLOCK------



Visit your host, monkey.org