[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cmpci & mixer troubles



Having audio problems ...

aumix dies almost immediately.

xmmix doesn't start, but gives an error message:
janky:/usr/ports/audio/xmmix% xmmix

MIXER_READ[6]:line ioctl failed: Invalid argument

xmix works, but gives a warning also:
janky:/usr/ports/audio/xmmix% xmix
supported = 0x31df
Error reading volumes in sync_slider: Invalid argument
Error reading volumes in sync_slider: Invalid argument

I did a 'cvs -d $CVSROOT up -r OPENBSD_2_9 -Pd' in
/usr/src/sys
/usr/ports/audio/[aumix|xmix|xmmix]
today.  The rest of the system was installed from a 'make release' 
I made from OPENBSD_2_9 sources as of May 5.  Only a few files have
been updated, and none that seem to affect audio/mixer, but I went ahead 
and rebuilt a GENERIC kernel and the above mentioned mixer apps.

Sound does work, and so does xmix, but something must not be quite
right ... and I prefer xmix the least anyway ;)

<jakemsr_(_at_)_clipper_(_dot_)_net>

I looked in the BIOS options for a way to disable the AMR, but no luck.
Don't know if that has anything to do with it though.
 
OpenBSD 2.9-stable (GENERIC) #0: Sat May 26 19:07:10 PDT 2001
    root_(_at_)_janky:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Celeron (Mendocino) ("GenuineIntel" 686-class, 128KB L2 cache) 535 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 117026816 (114284K)
avail mem = 103559168 (101132K)
using 1454 buffers containing 5955584 bytes (5816K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 12/21/00, BIOS32 rev. 0 @ 0xfd960
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf7680/128 (6 entries)
pcibios0: PCI Interrupt Router at 000:01:0 ("SIS 85C503 ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xc000 0xcc000/0x8000
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "SIS 630 Host-PCI" rev 0x20
pciide0 at pci0 dev 0 function 1 "SIS 5513 EIDE" rev 0xd0: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <Maxtor 91366U4>
wd0: 16-sector PIO, LBA, 13029MB, 16383 cyl, 16 head, 63 sec, 26684784 sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <BCD, E520C, 049B> SCSI0 5/cdrom removable
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
pcib0 at pci0 dev 1 function 0 "SIS 85C503 ISA" rev 0x00
sis0 at pci0 dev 1 function 1 "SIS 900 10/100BaseTX" rev 0x81: irq 11 address 01:29:02:50:80:00
ukphy0 at sis0 phy 0: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000760, model 0x0000, rev. 0
ohci0 at pci0 dev 1 function 2 "SIS 5597/5598 USB" rev 0x07, OHCI version 1.0, legacy support: irq 10
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1 at pci0 dev 1 function 3 "SIS 5597/5598 USB" rev 0x07, OHCI version 1.0, legacy support: irq 10
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: vendor 0x0000 OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ppb0 at pci0 dev 2 function 0 "SIS 86C201 Host-AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "SIS 6300" rev 0x20
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
cmpci0 at pci0 dev 15 function 0 "C-Media Electronics Inc. CMI8738/C3DX Audio" rev 0x10: irq 9
audio0 at cmpci0
"C-Media Electronics Inc. HSP56 AMR" rev 0x20 at pci0 dev 15 function 1 not configured
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c440 netmask cc40 ttymask dcc2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
cd0(atapiscsi0:0:0): Check Condition on opcode 0x25
    SENSE KEY: Not Ready
     ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition on opcode 0x43
    SENSE KEY: Not Ready
     ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition on opcode 0x25
    SENSE KEY: Not Ready
     ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition on opcode 0x43
    SENSE KEY: Not Ready
     ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition on opcode 0x25
    SENSE KEY: Not Ready
     ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition on opcode 0x43
    SENSE KEY: Not Ready
     ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition on opcode 0x25
    SENSE KEY: Unit Attention
     ASC/ASCQ: Not Ready To Ready Transition (Medium May Have Changed)