[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bridge not bridging



I'm not having a good week, is it time to go home yet?

Trying to bring up the (2.8+ patches) firewall I was almost ready to deploy when NorthPoint died. Bridging (fxp0 ext, fxp1 int) firewall with 3rd NIC (dc0) for administration. The bridge does not seem to be bridging. Doing "tcpdump -i fxp0 -l" shows no traffic. Same thing on fxp1 does show traffic when I try to connect from the test box behind the firewall. This box was sitting between our router & our network, bridging but not filtering, for about 3 weeks. 2 days ago, I put in our ipf ruleset & ran /etc/netstart. At that point, traffic stopped going anywhere. Thinking it was the rules, I edited them, then reduced them to "pass in on fxp0 from any to any" & "pass in on fxp1 from any to any". Still no joy. Our ISP's tech guy had put an IP on this box during our transition from DSL to 802.11, so I thought maybe he'd screwed something up. Remembering all the patches for ipf, I decided to try 2.9. I wiped the box & put 2.9 on via ftp. Still doesn't work. If I configure the fxp cards with IPs, they do respond to pings. Anybody care to whack me with a clue-by-four? Dmesg follows, I don't know what other info may be relevant.

Thanks,
-Kit

berlin:kit {1} dmesg
OpenBSD 2.9-current (GENERIC) #666: Wed May 9 19:55:43 MDT 2001
deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache) 351 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem = 268021760 (261740K)
avail mem = 243560448 (237852K)
using 3297 buffers containing 13504512 bytes (13188K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 07/15/95, BIOS32 rev. 0 @ 0xfd900
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf7820/144 (7 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("VIA VT82C596A PCI-ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xb000 0xcc000/0x1800 0xcd800/0x2800 0xe8000/0x4000!
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT82C691 Host-PCI" rev 0x01
ppb0 at pci0 dev 1 function 0 "VIA VT82C598 PCI-AGP" rev 0x00
pci1 at ppb0 bus 1
pcib0 at pci0 dev 7 function 0 "VIA VT82C596A PCI-ISA" rev 0x05
pciide0 at pci0 dev 7 function 1 "VIA VT82C571 IDE" rev 0x06: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <FUJITSU MPE3136AT>
wd0: 16-sector PIO, LBA, 13031MB, 16383 cyl, 16 head, 63 sec, 26688576 sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TOSHIBA, DVD-ROM SD-M1202, 1020> SCSI0 5/cdrom removable
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
pchb1 at pci0 dev 7 function 3 "VIA VT82C596 Power Management" rev 0x00
fxp0 at pci0 dev 8 function 0 "Intel 82557" rev 0x08: irq 9, address 00:d0:b7:c3:c2:f0
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
fxp1 at pci0 dev 10 function 0 "Intel 82557" rev 0x08: irq 10, address 00:d0:b7:c5:7b:71
inphy1 at fxp1 phy 1: i82555 10/100 media interface, rev. 4
dc0 at pci0 dev 11 function 0 "Lite-On PNIC-II" rev 0x25: irq 11 address 00:00:94:c7:95:72
dcphy0 at dc0 phy 31: internal PHY
vga1 at pci0 dev 12 function 0 "S3 Savage 4" rev 0x04
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c040 netmask ce40 ttymask ce42
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302




Visit your host, monkey.org