[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem upgrading from 2.8 to 2.9



Wynand van Dyk <wynand_(_at_)_type01_(_dot_)_com> wrote:

> Thanks for the response, I see that there are 2 versions on
> cvsweb: 1.1 -> cygnus and 1.1.1.1 -> OPENBSD_2_9 etc...

1.1.1.1 CYGNUS
1.1     OPENBSD_2_9, ..., HEAD

> Is cvsup checking out the 1.1 one instead of the correct one?

The other way around.

> I did specify tag=. instead of tag=OPENBSD_2_9
> tag=. should checkout HEAD right?

Right.  It's not a configuration error.  This particular file has
an unusual CVS history which triggers an arcane bug in CVSup itself.

> I am worried about how many other files have had the wrong version
> checked out... damn

As far as I know, this doesn't affect any other files in the OpenBSD
tree.

> Are the FreeBSD folks also suffering from this cvsup "issue"?

In theory, yes.  In practice, none of the files in their tree has
the requisite CVS history.  It's a very rare condition that triggers
this bug.

> Most importantly, will this get fixed in >= 2.9?

A native port of CVSup, including for the first time a working
server daemon, is forthcoming.  We'll probably base the port on
the latest 16.1a snapshot pre-release of CVSup, where this bug has
been fixed.  I also hope to be able to encourage the growth of a
reasonable infrastructure of CVSup mirrors in the near future.

-- 
Christian "naddy" Weisgerber                          naddy_(_at_)_mips_(_dot_)_inka_(_dot_)_de



Visit your host, monkey.org