[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Memory not found and Adaptec drivers



Hi,

I have a few problem that I cannot find the solution for.

A) My firewall, a Compaq DeskPro 75, is equipped with 72 MB RAM but
OpenBSD only finds 16 MB. When I boot it under Linux, all memory is
accounted for. I have tried to find this in the man-pages and FAQs but
to no avail -- Is there an option to tell the kernel (as with linux
"mem=") about present RAM or what do I do?

B) I have an Adaptec 1530P SCSI host adapter I cannot activate. I've
tried both the "aic" (claims to support 152x) and "aha" (154x and
others) but none of them work. Does anyone know if OpenBSD has a
driver for this particular card?


Here's the output from dmesg:

--8<--
OpenBSD 2.7 (BOROMIR) #3: Sun Dec 17 14:29:52 CET 2000
    fwadmin_(_at_)_boromir:/sys/arch/i386/compile/BOROMIR
cpu0: F00F bug workaround installed
cpu0: Intel Pentium (P54C) ("GenuineIntel" 586-class) 75 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8
real mem  = 16363520 (15980K)
avail mem = 13262848 (12952K)
using 225 buffers containing 921600 bytes (900K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(ed) BIOS, date 03/01/95
apm0 at bios0: Power Management spec V1.1
apm0: AC on, battery charge unknown
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
"Compaq Triflex Host-PCI" rev 0x01 at pci0 dev 0 function 0 not configured
"Compaq QVision 1280/p" rev 0x12 at pci0 dev 10 function 0 not configured
le0 at pci0 dev 11 function 0 "AMD 79c970 PCnet-PCI LANCE" rev 0x02
le0: address 00:80:5f:0c:9c:fd
le0: 8 receive buffers, 2 transmit buffers
le0: interrupting at irq 10
fxp0 at pci0 dev 14 function 0 "Intel 82557" rev 0x08: irq 5, address 00:90:27:d1:3e:a8
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
pcib0 at pci0 dev 15 function 0 "Compaq PCI-ISA" rev 0x43
isa0 at pcib0
isadma0 at isa0
wdc0 at isa0 port 0x1f0/8 irq 14
wd0 at wdc0 channel 0 drive 0: <FUJITSU MPB3043ATU>
wd0: can use 16-bit, PIO mode 4
wd0: 16-sector PIO, LBA, 4125MB, 8940 cyl, 15 head, 63 sec, 8448300 sectors
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60/16 irq 1: vga 80 col, color, 8 scr, mf2-kbd
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
isapnp0 at isa0 port 0x279: read port 0x203
"Adaptec AHA-1530P, ADP3015, ADP2015, SCSI Controller" at isapnp0 port 0x340/32 mem 0xc8000/16384 irq 9 not configured
biomask 4040 netmask 4460 ttymask 44e2
pctr: 586-class performance counters and user-level cycle counter enabled
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
--8<--

And here are the scsi part of my kernel configuration:

--8<--
aha0    at isa? port 0x340 irq ? drq ?  # Adaptec 154[02] SCSI controllers
scsibus* at aha?
--8<--


        /regards Anton
-- 
Q: What do you get if you cross an agnostic, an insomniac and a dyslexic?
A: Someone who lies awake at night wondering if there really is a dog.



Visit your host, monkey.org