[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cdrecord "cannot open scsi driver"



Hello at the OpenBSD mailing list ...

i try to get a scsi cd writer working on one of the obsd boxes.
the machine has ide devices only, but an AHA2940U with an SONY CD CDU926S,
Bios rev. 1.1g connected.
The system is a obsd 2.7 running on a i386 platform (Celeron 400/128MB Ram)

Heres the dmesg output :




        -----SNIP!-----
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <, ATAPI CDROM, 100S> SCSI0 5/cdrom removable
cd0: can use 32-bit, PIO mode 4, DMA mode 2, Ultra-DMA mode 2
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data transfers)
        -----SNIP!-----
ahc1 at pci0 dev 15 function 0 "Adaptec AHA-2940AU" rev 0x03: irq 11
ahc1: Single Channel A, SCSI Id=7, 3/255 SCBs
scsibus1 at ahc1: 8 targets
ahc1: target 2 synchronous at 10.0MHz, offset = 0xf
cd1 at scsibus1 targ 2 lun 0: <SONY, CD-R   CDU926S, 1.1g> SCSI2
5/cdrom removable
        -----SNIP!-----


i tried latest cdrecord (1.9a05) as well as the one included in the 2.7 ports
tree (1.6.1). for reading cd-rom the drives works well.



heres the output of cdrecord (without cd in drive):

rock:~ # cdrecord -dev=/dev/rcd1c:1,2,0 -checkdrive
Cdrecord release 1.6.1 Copyright (C) 1995-1998 Jörg Schilling
scsidev: '/dev/rcd1c:1,2,0'
devname: '/dev/rcd1c'
scsibus: 1 target: 2 lun: 0
cdrecord: Input/output error. Cannot open SCSI driver.
---------------------------------------

this is what i tried to do (with a empty cd in the recorder):

rock:~ # cdrecord -dev=/dev/rcd1c:1,2,0 -checkdrive

Cdrecord release 1.6.1 Copyright (C) 1995-1998 Jörg Schilling
scsidev: '/dev/rcd1c:1,2,0'
devname: '/dev/rcd1c'
scsibus: 1 target: 2 lun: 0
cdrecord: Device not configured. Cannot open SCSI driver.
Jul 15 11:50:04 rock /bsd: ahc1: target 2 synchronous at 10.0MHz, offset = 0xf
rock:~ # Jul 15 11:50:04 rock /bsd: ahc1: target 2 synchronous at 10.0MHz,
offset = 0xf
Jul 15 11:50:04 rock /bsd: cd1(ahc1:2:0): Check Condition on opcode 25
Jul 15 11:50:04 rock /bsd: cd1(ahc1:2:0): Check Condition on opcode 25
Jul 15 11:50:04 rock /bsd:     SENSE KEY: Illegal Request
Jul 15 11:50:04 rock /bsd:     SENSE KEY: Illegal Request
Jul 15 11:50:04 rock /bsd:      ASC/ASCQ: ASC 0x89 ASCQ 0x00
Jul 15 11:50:04 rock /bsd:      ASC/ASCQ: ASC 0x89 ASCQ 0x00

-----------------------------------------------------

and here cdrecord goes with a written cd in drive :
rock:~ # cdrecord -dev=/dev/rcd1c:1,2,0 -checkdrive
Cdrecord release 1.6.1 Copyright (C) 1995-1998 Jörg Schilling
scsidev: '/dev/rcd1c:1,2,0'
devname: '/dev/rcd1c'
scsibus: 1 target: 2 lun: 0
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   : SYNC LINKED 
Vendor_info    : 'SONY    '
Identifikation : 'CD-R   CDU926S  '
Revision       : '1.1g'
Device seems to be: Sony CDU-924S.
Jul 15 11:52:31 rock /bsd: ahc1: target 2 synchronous at 10.0MHz, offset = 0xf
Jul 15 11:52:31 rock /bsd: ahc1: target 2 synchronous at 10.0MHz, offset = 0xf
Using driver for Sony CDU-924 (sony_cdu924).
Driver flags   : SWABAUDIO



I was reading the cdrecord docs and in the README.xxxBSD i read that the
-scanbus doesnt work on the *BSD derivates.
But the device "/dev/rcd1c" is valid on this system (dev file exists) and i
think its the correct device im using.

Any ideas on that ?

Thanks alot ....


Heri















Visit your host, monkey.org